Jump to content
Not connected, Your IP: 3.234.210.25
Staff

Eddie Android edition 3.0 preview available

Recommended Posts

5 hours ago, airvpnforumuser said:


2: 'One tap upload': The log does contain (possible) identifiable information which (for me) I'd prefer to scrub. The one tap solution to upload a log doesn't give the user a chance to see exactly _what_ information is being sent over the wire, it'd be great to have a preview before the data is sent.

I think improving the log system would go a long way to providing more useful error reports, as it would allow me (and others) to quickly identify the source of the issue.


Hello!

Thank you very much for your feedback and suggestions, they will be taken into due consideration for sure, especially to delete a specific information: the log you send may contain (if the country setting is unset) your real IP address in the logging moment, an information which normally would be visible only during an active connection and only to the core AirVPN management members if they perform very specific search inside the VPN server (other developers can't see it), while in this case it would become available to Eddie Android development team as well. Once you have uploaded the report, the data retention in eddie.website is 30 days, OR you can delete anytime the log by yourself.  The log is first visible only to the support team (not outsourced) so the support team can edit it before sending it to the development team. We will seriously consider to include the automatic deletion of such info in Eddie 3.0 beta 2 (which will also contain a fix for the bug you and other testers have reported).

Kind regards
 

Share this post


Link to post

beta 3 on openvpn mode
while I get notification sound on startup, it doesn't plays on going to screen off or resuming from screen off like it use to do on eddie 2.5
is it intended?

Share this post


Link to post

Hello!

We're very glad to inform you that Eddie Android edition 3.0 Beta 2 is now available. The original post has been updated accordingly.
 

New in Beta 2:

  • detected client's IP address not written in local log anymore
  • WireGuard error streams management rewrite (*)
  • dark theme heading color change
(*) fixing reported bug according to internal tests, please check


Find full description, download link and SHA256 signature in the first post of this very thread.

Thank you very much for your tests and please report and describe any bug you find!

Kind regards
 

Share this post


Link to post
19 hours ago, harold.lewis said:

beta 3 on openvpn mode
while I get notification sound on startup, it doesn't plays on going to screen off or resuming from screen off like it use to do on eddie 2.5
is it intended?


Hello!

Yes, it is an intended change following several users request.

Kind regards
 

Share this post


Link to post

Unfortunately I still get the disconnect issue using wireguard with the new beta update, I've opened a ticket...

Share this post


Link to post
@VPN3rd

Hello!

In your case that's an expected behavior because VPN Lock option is enabled. Since you have Android 12 you can safely disable VPN Lock and enable "Always on VPN" and "Block traffic if VPN is inactive" in order to have traffic leaks prevention and, at the same time, let Eddie re-connect when necessary. Also make sure that in Settings > VPN view, the VPN reconnection item is on (you currently have it off, another reason for which Eddie will not re-connect).


@harold.lewis

In your case the missing reconnection attempt is expected because you have disabled VPN reconnection option too (see the note above to VPN3rd). The unexpected occurrence is that Eddie is frozen: how is it frozen? You mention that you can unfreeze it by connecting manually, do you mean that some functions are unresponsive, while other ones are working fine? Can you elaborate?

Thanks a lot to you both for your relentless testing!

Kind regards
 

Share this post


Link to post

hmm, sorry, probably I disable by mistake and didn't check anymore, now is enabled again...
when it disconnect, the connection button is grayed out and does not respond on tapping and no button log is available, to reconnect again I have to go to Server and tap one server there then is reconnecting and I can access the logs...

Share this post


Link to post
@Staff  

The problem with that setup is that I have about 4-5 apps that I need to exclude from the VPN because they block it. With androids always on setting and block connections without VPN setting enabled those apps will no longer work outside of it.. Any solution? Thanks in advance.

Share this post


Link to post
11 hours ago, VPN3rd said:
@Staff  

The problem with that setup is that I have about 4-5 apps that I need to exclude from the VPN because they block it. With androids always on setting and block connections without VPN setting enabled those apps will no longer work outside of it.. Any solution? Thanks in advance.

Hello!

In this case unfortunately you can't have robust leaks protection, trivially because you explicitly need traffic outside the VPN tunnel. You may consider to re-enable VPN re-connection in Eddie settings and disable VPN lock. Any other app may also leak traffic when an unexpected disconnection occurs, but Eddie will reconnect quickly, so the system and the "excluded" apps might not have the time to close the previous socket (which will have a several seconds timeout) and open a new one outside the tunnel: the re-connection, once a network is again available, is often faster.

This is a serious traffic splitting on an apps basis byproduct, when you want auto re-connection, which could be resolved only through more advanced techniques (multiple routing tables and/or cgroups) which are totally out of reach for Android apps not running with root privileges.

Probably,  when traffic leak prevention is an absolute must, you should either renounce to traffic splitting, or keep VPN Lock enabled and give yourself in to manual re-connections, according to the old saying "you can't have your cake and eat it too". Evaluate therefore your threat model and the consequences of a potential, although short lived, traffic leak.

Kind regards
 

Share this post


Link to post
17 hours ago, VPN3rd said:
@Staff

Is that a limitation of Wireguard? Because with OpenVPN i have no issues having cake and eating it too lol

Hello!

You should have the identical behavior. Can you open a ticket and send us a report as usual while you're connected with OpenVPN, with some "excluded" app?

Kind regards
 

Share this post


Link to post

even with Escuded local network on
it keep disconnecting
after I can't access the log, connection button grayed out, I've to go to Server and connect to one manually and than it reconnect and I can get the log

send in client area

Share this post


Link to post
3 hours ago, harold.lewis said:

wireguard disconnected,
/Settings/System/Esclude Local Network From VPN was deselected
now I toggled on an see
log send


Hello!

Can you please tell us the exact system you run in your phone? We see Android 13 from the report but probably you have a custom ROM since you have a Pixel 6. We would like to know what it is to check whether the malfunction is specific.
 
Quote

after I can't access the log, connection button grayed out, I've to go to Server and connect to one manually and than it reconnect and I can get the log


We need to understand this part fully. Please check below and confirm or deny that each step is right:
  1. You leave the device unattended
  2. After some time, you find the device with the screen off
  3. You turn the screen on and you find Eddie disconnected. At this stage, check on Android bar whether your network is up or not (according to Eddie it's not) and tell us what you find (do not test with a browser because your leak prevention Android settings will not allow traffic)
  4. You can't access Eddie's log view at all (please make sure you can confirm or deny this for sure). What happens when you tap the "Log" entry in the side drawer? Is it totally unresponsive? Note that it is normal that the Log button on the status tab is missing when network is off.
  5. The big button for quick connection and disconnection is unresponsive too
  6. You force a connection by selecting manually a server and immediately the log view is again available and Eddie connects to that server instantly.

Kind regards
 

Share this post


Link to post

1) Yes, not much use of the phone
2) Auto screen off after 15 second
3) Yes this after some time, for network on I will check, not remembering now if the LTE shows up...
4) Yes, there is not log button, only message of not connected in Connection Status
5) Yes, unresponsive
6) Yes, after tapping a server manually in Server tab, it reconnects and in Connection Status the button Log is again available

Share this post


Link to post
2 hours ago, harold.lewis said:

1) Yes, not much use of the phone
2) Auto screen off after 15 second
3) Yes this after some time, for network on I will check, not remembering now if the LTE shows up...
4) Yes, there is not log button, only message of not connected in Connection Status
5) Yes, unresponsive
6) Yes, after tapping a server manually in Server tab, it reconnects and in Connection Status the button Log is again available


Thanks a lot. Now, about point 3 and 4, can you please check? Turn on the screen, and wait some time, until the network is up (check Android indicator), Also try to access the Log via the side panel (the drawer which you can access settings etc. from). Note whether the log view opens or not (it should be accessible regardless of network and Eddie condition).

When the network is up, go to Eddie and check again whether Eddie still does not reconnect by itself (big button still unresponsive or not? does Eddie report "disconnected" status in spite of network up?).

If the network never comes up (wait at least a minute or two after you have turned the screen on, and keep thee screen on, do not allow it to go off again) try to switch off your LTE connection (from Android settings (*) ) and then on again, and check what happens both to your device and Eddie.

Thank you in advance for all the additional tests.

(*) IMPORTANT: If your device connects via WiFi to an LTE router (and not directly by using a SIM in itself), and your switching on/off the WiFi card doesn't change Eddie status, reboot the router (or press the activation button which is available on certain LTE routers) and check whether Eddie status changes after the router has re-established the LTE connection.

Kind regards
 

Share this post


Link to post

 I connect directly via SIM mobile data,
one question, mi wifi option is off, how to keep Settings//System/Esclude local network from VPN, off or on?

Share this post


Link to post
33 minutes ago, harold.lewis said:

one question, mi wifi option is off, how to keep Settings//System/Esclude local network from VPN, off or on?


Hello!

Local network exclusion is not possible when the connection is on LTE/mobile, so it's irrelevant, don't worry about it.

Please review our previous questions and reply when you have time to do so, because we have some ideas and we need confirmations (or denials) from you to fully understand the issue.

Kind regards
 

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Security Check
    Play CAPTCHA Audio
    Refresh Image

×
×
  • Create New...