Jump to content
Not connected, Your IP:

[solved] airvpn-suite and hummingbird failing

Recommended Posts

Posted ... (edited)
I can't get hummingbird to run anymore. Installing airvpn-suite only has bluetit fail with the same error.

[amw@alarm hummingbird-linux-armv7l-1.1.2]$ sudo hummingbird -e

Hummingbird - AirVPN OpenVPN 3 Client 1.1.2 - 4 June 2021

It seems this program did not exit gracefully or has been killed.
Your system may not be working properly and your network connection may not work
as expected. To recover your network settings, run this program again and use
the "--recover-network" option.

[amw@alarm hummingbird-linux-armv7l-1.1.2]$ sudo ls -la /etc/airvpn/
total 148
drwxr-xr-x  2 airvpn airvpn   4096 Oct 29 21:25 .
drwxr-xr-x 65 root   root     4096 Oct 29 21:26 ..
-rw-------  1 airvpn airvpn 121378 Oct 29 21:09 airvpn-manifest.xml
-rw-------  1 airvpn airvpn   2203 Oct 29 21:09 bluetit.rc
-rw-------  1 airvpn airvpn   1439 Oct 29 21:09 connection_priority.txt
-rw-------  1 airvpn airvpn     48 Oct 29 21:09 connection_sequence.csv
-rw-------  1 airvpn airvpn   1743 Oct 29 21:09 country_continent.csv
-rw-------  1 airvpn airvpn   3730 Oct 29 21:09 country_names.csv
lrwxrwxrwx  1 airvpn airvpn     32 Jun  2  2019 resolv.conf.airvpnbackup -> /run/systemd/resolve/resolv.conf

There is no lock file in my /etc/airvpn directory as above Edited ... by amw

Share this post

Link to post

Did you try --recover-network as you're told? You've got a .airvpnbackup symlink there. Run the option, or make sure your network is reset, then remove the symlink.


LZ1's New User Guide to AirVPN « Plenty of stuff for advanced users, too!

Unofficial Eddie for Android F-Droid repository: repo.opensourcery.eu

Want to contact me directly? All relevant methods are on my About me page.

Share this post

Link to post
Posted ... (edited)

Sorry, forgot to mention that. Yes I have run this. It does not detect any issues.

Removing the symlink fixed the issue. Thanks!

I seems like the --recover-network switch should remove this symlink when no issues are detected.

Edited ... by amw

Share this post

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Security Check
    Play CAPTCHA Audio
    Refresh Image

  • Create New...