Jump to content
Not connected, Your IP:
Sign in to follow this  

Keep getting error checking ipv4 route

Recommended Posts

I use airvpn on my VM and it has been working correctly for years, with no changes, but today it will not connect to anything.  It keeps failing the ipv4 route check.  I have tried to multiple vpn endpoints with no success. 

From the logs, it looks like the certs are messed up:

. 2021.09.30 13:53:31 - curl: (60) server certificate verification failed. CAfile: /usr/share/eddie-ui/cacert.pem CRLfile: none

How to fix?

Share this post

Link to post

Connecting to airvpn.org (airvpn.org)||:443... connected.
WARNING: cannot verify airvpn.org's certificate, issued by ‘CN=R3,O=Let's Encrypt,C=US’:
  Issued certificate has expired.
HTTP request sent, awaiting response... 500 Internal Server Error
2021-09-30 14:15:10 ERROR 500: Internal Server Error.

When trying to use wget to get updated gui


Share this post

Link to post

Hello and thank you for your choice!

Please make sure that you're running Eddie 2.19.7 or higher version (upgrade if necessary).

Then, please try the following settings:

  • from Eddie's main window select "Preferences" > "Advanced"
  • de-tick "Check if the VPN tunnel works"
  • click "Save"
  • from Eddie's main window select "Preferences" > "DNS"
  • de-tick "Check Air VPN DNS"
  • click "Save"
  • from Eddie's main window enable Network Lock

Try again connections to various servers.

Explanation of the issue: consider that AirVPN uses mainly LetsEncrypt certificates. Then read here:

Now, if you run a cURL version linked against OpenSSL 1.1.0 or older versions, or against LibreSSL older than 3.2.0, or GnuTLS older than 3.6.7, the validation chain will fail (and Eddie does use libcurl and curl). It's a TLS library bug. At the moment we can not fix on our side: we would cut out all Android versions older than 7.1, and we don't want to do so .

Momentarily, the above quick fix will resolve the problem on Eddie. The initial checks become useless when you keep Network Lock enabled, so you don't have to worry about safety and security.

Kind regards

Share this post

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Security Check
    Play CAPTCHA Audio
    Refresh Image
Sign in to follow this  

  • Create New...