Jump to content
Not connected, Your IP: 3.233.219.62
dragoworld235

My sonos device on local network not detect when connected to AirVPN with Eddie

Recommended Posts

Posted ... (edited)

I'm using Eddie 2.4 to connect to AirVPN on my phone running Android 10.
I've checked the option to exclude local networks from VPN.
When connected, my sonos device is not detected by the Sonos app (using sonos s1 because my device can't be used with the new s2).
A traceroute to my device shows that I'm outside the VPN :
traceroute 192.168.0.200  1?: [LOCALHOST]                      pmtu 1500  1:  192.168.0.200                                        91.003ms reached  1:  192.168.0.200                                         1.934ms reached      Resume: pmtu 1500 hops 1 back 1

When I'm using an AirVPN generated profil on de.blinkt.openvpn v0.7.21 (with some adjustments like routing local networks outside the VPN) instead of Eddie, my sonos device is working.

Edited ... by dragoworld235

Share this post


Link to post

In Settings > VPN, try disabling VPN Lock.


» I am not an AirVPN team member. All opinions are my own and are not to be considered official. Only the AirVPN Staff account should be viewed as such.

» The forums is a place where you can ask questions to the community. You are not entitled to guaranteed answer times. Answer quality may vary, too. If you need professional support, please create tickets.

» If you're new, take some time to read LZ1's New User Guide to AirVPN. On questions, use the search function first. On errors, search for the error message instead.

» If you choose to create a new thread, keep in mind that we don't know your setup. Give info about it. Never forget the OpenVPN logs or, for Eddie, the support file (Logs > lifebelt icon).

» The community kindly asks you to not set up Tor exit relays when connected to AirVPN. Their IP addresses are subject to restrictions and these are relayed to all users of the affected servers.

 

» Furthermore, I propose that your paranoia is to be destroyed. If you overdo privacy, chances are you will be unique amond the mass again.

Share this post


Link to post

Okay, then try using your local DNS server with the VPN. In Settings > DNS, enable Use custom DNS, then enter your local DNS server in Custom DNS.


» I am not an AirVPN team member. All opinions are my own and are not to be considered official. Only the AirVPN Staff account should be viewed as such.

» The forums is a place where you can ask questions to the community. You are not entitled to guaranteed answer times. Answer quality may vary, too. If you need professional support, please create tickets.

» If you're new, take some time to read LZ1's New User Guide to AirVPN. On questions, use the search function first. On errors, search for the error message instead.

» If you choose to create a new thread, keep in mind that we don't know your setup. Give info about it. Never forget the OpenVPN logs or, for Eddie, the support file (Logs > lifebelt icon).

» The community kindly asks you to not set up Tor exit relays when connected to AirVPN. Their IP addresses are subject to restrictions and these are relayed to all users of the affected servers.

 

» Furthermore, I propose that your paranoia is to be destroyed. If you overdo privacy, chances are you will be unique amond the mass again.

Share this post


Link to post
3 hours ago, OpenSourcerer said:

Okay, then try using your local DNS server with the VPN. In Settings > DNS, enable Use custom DNS, then enter your local DNS server in Custom DNS.


Thanks for the help, my previous response was a bit dry.
So, no, with the dns set to it's value when I'm not using the VPN, the sonos app is still not finding the speaker.

I just found something interesting. The openvpn app with which sonos is working is using openvpn 2.x. You can configure it to use openvpn 3 core, in that case, Sonos is not accessible.
Eddie is using openvpn 3.3 :  I just have to say that the Eddie client on my windows 10 laptop does not have the sonos problem.

Share this post


Link to post
1 hour ago, dragoworld235 said:

I just found something interesting. The openvpn app with which sonos is working is using openvpn 2.x. You can configure it to use openvpn 3 core, in that case, Sonos is not accessible.


That is indeed.. interesting. If it's in the code, there is no way to configure it away.. 😕

» I am not an AirVPN team member. All opinions are my own and are not to be considered official. Only the AirVPN Staff account should be viewed as such.

» The forums is a place where you can ask questions to the community. You are not entitled to guaranteed answer times. Answer quality may vary, too. If you need professional support, please create tickets.

» If you're new, take some time to read LZ1's New User Guide to AirVPN. On questions, use the search function first. On errors, search for the error message instead.

» If you choose to create a new thread, keep in mind that we don't know your setup. Give info about it. Never forget the OpenVPN logs or, for Eddie, the support file (Logs > lifebelt icon).

» The community kindly asks you to not set up Tor exit relays when connected to AirVPN. Their IP addresses are subject to restrictions and these are relayed to all users of the affected servers.

 

» Furthermore, I propose that your paranoia is to be destroyed. If you overdo privacy, chances are you will be unique amond the mass again.

Share this post


Link to post
Posted ... (edited)
1 hour ago, OpenSourcerer said:

That is indeed.. interesting. If it's in the code, there is no way to configure it away.. 😕

I've just checked, eddie 2.19.4 that I use on windows is using openvpn 2.4.9. I think that's why Sonos is working.
Openvpn 3+ is still experimental, maybe eddie on Android should reverse to openvpn 2+.

Edit:
I've just realized the problem is not only sonos.
None of my local network is accessible.
To be sure the problem was not coming from my tinkering with eddie, I reset the app data.
I just set the master password, save the login info and activate the local network access setting.
When connected, I can't ping my router on his local ipv4, I can't access my ssh server on it's local ipv4.
I've configured a port redirection rule to access my ssh server from the outside. I can connect to my ssh server by using my public ipv4 (the connection is going through the VPN).
If I add a directive to keep the access to my public ipv4 outside of the VPN (route X.X.X.X 255.255.255.255 net_gateway), I can't connect to my ssh server using the public ipv4 anymore.

I'm opening an issue on the git repo. Edited ... by dragoworld235
Adding more details

Share this post


Link to post
@dragoworld235

Hello!

Changing Eddie to make it run OpenVPN 2 is a problematic matter, because OpeNVPN 2 is not a library, while OpenVPN3 is. By avoiding to run an external binary Eddie Android edition complies to security best practices as well as Google requirements in latest API.

Anyway OpenVPN3-AirVPN library is not OpenVPN3. It's a fork which is 90 commits ahead of OpenVPN:master and had many important bugs fixed. An updated Eddie Android edition using our latest library version might be a Christmas present to you all, while you will see very soon an updated Hummingbird (which also calls OpenVPN3-AirVPN library) for Linux and macOS.

Kind regards
 

Share this post


Link to post
On 11/6/2020 at 11:03 AM, Staff said:
@dragoworld235

Hello!

Changing Eddie to make it run OpenVPN 2 is a problematic matter, because OpeNVPN 2 is not a library, while OpenVPN3 is. By avoiding to run an external binary Eddie Android edition complies to security best practices as well as Google requirements in latest API.

Anyway OpenVPN3-AirVPN library is not OpenVPN3. It's a fork which is 90 commits ahead of OpenVPN:master and had many important bugs fixed. An updated Eddie Android edition using our latest library version might be a Christmas present to you all, while you will see very soon an updated Hummingbird (which also calls OpenVPN3-AirVPN library) for Linux and macOS.

Kind regards
 
Tanks @Staff
Do you think it's a good idea that I open an issue on https://gitlab.com/AirVPN/EddieAndroid for the problem with accessing local network with openvpn 3?
As you said, you're using a customize version so maybe you can fix the bug and submit the patch to OpenVPN ?
I will open an issue with OpenVPN for that problem.

Share this post


Link to post
@dragoworld235

Hello!

Yes, please open an issue in our git.

Do you want to open an issue for OpenVPN3 main branch too because you see the very same problem with latest "OpenVPN for Android" when it is configured to work with OpenVPN3?

Kind regards
 

Share this post


Link to post
Posted ... (edited)
2 hours ago, Staff said:
@dragoworld235

Hello!

Yes, please open an issue in our git.

Do you want to open an issue for OpenVPN3 main branch too because you see the very same problem with latest "OpenVPN for Android" when it is configured to work with OpenVPN3?

Kind regards
 
As the problem is clearly coming from Openvpn3, yes I will open an issue on their github.
I was just wondering if creating an issue on your gitlab repo was needed or if that forum topic would do the trick.
You have answered to me. I will created an issue without every elements I have (screenshots, routing table, ...) and I will add them as needed. Edited ... by dragoworld235

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Security Check
    Play CAPTCHA Audio
    Refresh Image

×
×
  • Create New...