Jump to content
Not connected, Your IP: 34.239.150.57
WYjNh056OGEG2tgNvV4iHzoNNU

Fedora 33 - Checking DNS failed. systemd-resolved

Recommended Posts

Posted ... (edited)

Hi,

Using Eddie 2.18.9 and the OS Fedora 32 works great. After upgrading to Fedora 33, Eddie 2.18.9 failed to connect to any server with this error : "Checking DNS failed". In the preferences, if I uncheck DNS -> Check AirVPN DNS, then it will connect. BUT this will be unsafe as there will be a DNS leak as tested with ipleak.net .

There has been a change in the way Fedora handle DNS in the 33 version :
systemd-resolved: introduction to split DNS (
fedoramagazine.org)

Fedora 33 now use systemd-resolved for DNS queries. IMHO This is the culprit.

Please help with this issue : default safe configuration is now broken and disabling AirVPN DNS  is not as secure as I could expect using AirVPN.

Kind regards.
 

Edited ... by WYjNh056OGEG2tgNvV4iHzoNNU
Typo ipleak.net

Share this post


Link to post

Hello!

Yes, we are aware of the issue. You are almost right. systemd-resolved can work in different modes. One of those modes is not compatible with the DNS handling performed by Hummingbird and Eddie.

Same problem with Hummingbird. Please see here for a momentary workaround and a more detailed insight on the specific working mode, causing the issue, of systemd-resolved now enabled by default on Fedora 33:
https://airvpn.org/forums/topic/48252-eddie-checking-dns-failed/

The workaround suggests to disable systemd-resolved, but in reality you could also keep it up but re-configure it to work in any "resolv.conf" compatible mode.

Kind regards
 

Share this post


Link to post
Posted ... (edited)

Thank you for the quick answer. I disabled the service using those commands :

$ sudo systemctl stop systemd-resolved
$ sudo systemctl disable systemd-resolved
Now I can use the default configuration for Eddie, and it doesn't leak DNS anymore according to ipleak.net .
I'll wait for an update to use systemd-resolved in the future, which seems to bring new features.

Kind regards. Edited ... by WYjNh056OGEG2tgNvV4iHzoNNU
Typo ipleak.net

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Security Check
    Play CAPTCHA Audio
    Refresh Image

×
×
  • Create New...