Jump to content
Not connected, Your IP: 54.236.35.159
Sasquatch05

Faster speeds on WiFi connected desktop vs a second desktop on Ethernet

Recommended Posts

I just got a 100/10 Mbps connection, coming from a 50/10 Mbps one. Both machines run Win 10 2004. I have the most recent Eddie client and the same settings on each machine. Using the Ookla speedtest the desktop on WiFi is hitting @ 93 Mbps and the other is only getting @ 50 Mbps on Ethernet (sits next to router, gigabit NIC). Both max out at >100 Mbps with the VPN off, and I can't figure out why there's a difference with it on.

I know that the CPU can make a difference, and that plus RAM is the difference in the setups:

WiFi Desktop: AMD Phenom II X4 B65 @ 3.4 GHz | 8 GB DDR3-1866MHz

Ethernet Desktop: Intel Pentium J2900 @ 2.41 GHz | 4 GB DDR3-1600MHz

Does anyone think the CPU is the issue here, or have any other ideas/suggestions?

Share this post


Link to post

The Pentium J series are CPUs optimized for embedded systems. They will consider throttling at most workloads to keep cool, quiet and energy efficient, mostly to not die from warmth.
The Phenom is a desktop CPU and requires active cooling. It will try to keep the max clock speed until temperature gets life-threatening to it.

There's the existence of Thermal Design Power values, or TDP, in Watts. It's generally a unit for how much heat a CPU can release. A CPU with a lower TDP requires less cooling and energy, but will throttle faster if stressed to keep it that way. A higher one needs more cooling and energy, but will usually keep its head in the face of workload and rising temperature.
So it shouldn't really surprise knowing that the AMD CPU is specified for 95W TDP, while the Intel J is just 10W, and that Intel gets you 50 Mbit/s on Ethernet and 93 on AMD, despite it being a WLAN connection.


» I am not an AirVPN team member. All opinions are my own and are not to be considered official. Only the AirVPN Staff account should be viewed as such.

» The forums is a place where you can ask questions to the community. You are not entitled to guaranteed answer times. Answer quality may vary, too. If you need professional support, please create tickets.

» If you're new, take some time to read LZ1's New User Guide to AirVPN. On questions, use the search function first. On errors, search for the error message instead.

» If you choose to create a new thread, keep in mind that we don't know your setup. Give info about it. Never forget the OpenVPN logs or, for Eddie, the support file (Logs > lifebelt icon).

» The community kindly asks you to not set up Tor exit relays when connected to AirVPN. Their IP addresses are subject to restrictions and these are relayed to all users of the affected servers.

 

» Furthermore, I propose that your paranoia is to be destroyed. If you overdo privacy, chances are you will be unique amond the mass again.

Share this post


Link to post
18 hours ago, Sasquatch05 said:

Does anyone think the CPU is the issue here, or have any other ideas/suggestions?

Configure your WiFI and the Ethernet this way: 
Speed & Duplex: 1.0 Gbps Full-Duplex
Receive Buffers/Transmit Buffers: to the max 512/1024


 

Share this post


Link to post
Posted ... (edited)
10 hours ago, giganerd said:

The Pentium J series are CPUs optimized for embedded systems. They will consider throttling at most workloads to keep cool, quiet and energy efficient, mostly to not die from warmth.
The Phenom is a desktop CPU and requires active cooling. It will try to keep the max clock speed until temperature gets life-threatening to it.

There's the existence of Thermal Design Power values, or TDP, in Watts. It's generally a unit for how much heat a CPU can release. A CPU with a lower TDP requires less cooling and energy, but will throttle faster if stressed to keep it that way. A higher one needs more cooling and energy, but will usually keep its head in the face of workload and rising temperature.
So it shouldn't really surprise knowing that the AMD CPU is specified for 95W TDP, while the Intel J is just 10W, and that Intel gets you 50 Mbit/s on Ethernet and 93 on AMD, despite it being a WLAN connection.


I follow the logic in what you're saying, and it makes sense that there are protective measures. As I said, it will get the full 100+ Mbps internet without the VPN on, and much faster than that on the LAN. I could be mistaken, but if the overhead of the VPN was sufficient to push the CPU to it's limits wouldn't the usage be higher? The screenshots below are the CPU and Ethernet activity with the VPN on while downloading a Linux ISO. Thanks for your feedback!


image.thumb.png.cc0b2d180de43067fdb96aa634b5feff.png

image.thumb.png.1f4506dadffa6021cf8454f26a49c527.png
  Edited ... by Sasquatch05
Fixed message body - appeared as hyperlink

Share this post


Link to post
Posted ... (edited)
2 hours ago, Flx said:
Configure your WiFI and the Ethernet this way: 
Speed & Duplex: 1.0 Gbps Full-Duplex
Receive Buffers/Transmit Buffers: to the max 512/1024


 
I changed it to what you suggested and there was no increase in speed. The "Transmit Buffer" value max was 128, not 1024. I'm not sure if that's indicative of another configuration issue.  Thanks for your feedback! Edited ... by Sasquatch05
Added thanks

Share this post


Link to post
10 hours ago, Sasquatch05 said:

I could be mistaken, but if the overhead of the VPN was sufficient to push the CPU to it's limits wouldn't the usage be higher?


Know that OpenVPN is a single-core/single-thread application, so it will push one core/thread to its limit and not use the others, which seems to roughly be happening in your screenshot.
More technical info on this can be found in the OpenVPN roadmap, if you're into that. :)
 
10 hours ago, Sasquatch05 said:

I changed it to what you suggested and there was no increase in speed. The "Transmit Buffer" value max was 128, not 1024. I'm not sure if that's indicative of another configuration issue.  Thanks for your feedback!


You shouldn't need to set duplex at all, it's automatically configured. But then again, it's Windows… :D

» I am not an AirVPN team member. All opinions are my own and are not to be considered official. Only the AirVPN Staff account should be viewed as such.

» The forums is a place where you can ask questions to the community. You are not entitled to guaranteed answer times. Answer quality may vary, too. If you need professional support, please create tickets.

» If you're new, take some time to read LZ1's New User Guide to AirVPN. On questions, use the search function first. On errors, search for the error message instead.

» If you choose to create a new thread, keep in mind that we don't know your setup. Give info about it. Never forget the OpenVPN logs or, for Eddie, the support file (Logs > lifebelt icon).

» The community kindly asks you to not set up Tor exit relays when connected to AirVPN. Their IP addresses are subject to restrictions and these are relayed to all users of the affected servers.

 

» Furthermore, I propose that your paranoia is to be destroyed. If you overdo privacy, chances are you will be unique amond the mass again.

Share this post


Link to post
20 hours ago, Flx said:

Configure your WiFI and the Ethernet this way: 
Speed & Duplex: 1.0 Gbps Full-Duplex
Receive Buffers/Transmit Buffers: to the max 512/1024


Oddly enough, the duplex setting don't always work as it is supposed to do. If changing the duplex setting to 1.0 Gbps Full-Duplex didn't work, try set it as "Auto Negotiation" to see if that work. I had issue with my ethernet in the past when my NIC negotiated on 100Mbps for some reason despite the setting is on 1Gbps full duplex (My Realtek NIC is capable of doing 1Gbps). I found that people have this similar issue, their best recommendation is to set it as Auto Negotiation to get 1Gbps Full Duplex. My NIC finally negotiated on 1Gbps when I switched to auto negotiation. Try to see if that works, Sasquatch05?

Lastly, it is my understanding that WiFi is only half-duplex, it cannot do full duplex currently.

Share this post


Link to post
1 hour ago, NoiselessOwl said:

it cannot do full duplex currently


It can do that, actually. Some people at Stanford University once built something that can transmit and receive signals at the same time through a technique they call Signal Inversion Cancellation. As I understand it, it wasn't nearly powerful enough for real-world applications, so the work continues.
What we've got today instead is MIMO, which is not the definition of full duplex, but comes quite close to it. Actually, it's the laziest, cheapest way to increase throughput. You just use a broader channel width and multiple antennas for multiple streams, at least one for send and one for receive. Ta-da, Retarded Full Duplex Operation® mode :D

» I am not an AirVPN team member. All opinions are my own and are not to be considered official. Only the AirVPN Staff account should be viewed as such.

» The forums is a place where you can ask questions to the community. You are not entitled to guaranteed answer times. Answer quality may vary, too. If you need professional support, please create tickets.

» If you're new, take some time to read LZ1's New User Guide to AirVPN. On questions, use the search function first. On errors, search for the error message instead.

» If you choose to create a new thread, keep in mind that we don't know your setup. Give info about it. Never forget the OpenVPN logs or, for Eddie, the support file (Logs > lifebelt icon).

» The community kindly asks you to not set up Tor exit relays when connected to AirVPN. Their IP addresses are subject to restrictions and these are relayed to all users of the affected servers.

 

» Furthermore, I propose that your paranoia is to be destroyed. If you overdo privacy, chances are you will be unique amond the mass again.

Share this post


Link to post
On 9/2/2020 at 6:49 PM, Sasquatch05 said:

if the overhead of the VPN was sufficient to push the CPU to it's limits

What other processes are there that are eating the life of your CPU?
Did you manually update to ver 2004 or was it done automatically?

 

Share this post


Link to post
Posted ... (edited)
On 9/3/2020 at 10:06 PM, Flx said:
What other processes are there that are eating the life of your CPU?
Did you manually update to ver 2004 or was it done automatically?

 

 It is also set up as a Plex server, but in the screenshots I posted only the torrent client was running. I also use Radarr, Sonarr, and Jackett, but have gotten the same results whether they are running or not.

I had the same speed issues before updating to 2004. For what it's worth, I manually ran the update. I prefer to do a clean install with the major updates, but I didn't want to migrate all the clients and services if I could help it. I'll be upgrading to a newer machine when I can, and the one in question I had laying around so I used it as a lockdown project.

It's just a strange phenomenon that I can have everything running or not and get 100 Mbps without the VPN, but the VPN cuts it almost in half. And I'll still get the fast transfer speeds on the LAN. Edited ... by Sasquatch05
Clarity

Share this post


Link to post
On 9/3/2020 at 1:18 PM, NoiselessOwl said:

Oddly enough, the duplex setting don't always work as it is supposed to do. If changing the duplex setting to 1.0 Gbps Full-Duplex didn't work, try set it as "Auto Negotiation" to see if that work. I had issue with my ethernet in the past when my NIC negotiated on 100Mbps for some reason despite the setting is on 1Gbps full duplex (My Realtek NIC is capable of doing 1Gbps). I found that people have this similar issue, their best recommendation is to set it as Auto Negotiation to get 1Gbps Full Duplex. My NIC finally negotiated on 1Gbps when I switched to auto negotiation. Try to see if that works, Sasquatch05?

Lastly, it is my understanding that WiFi is only half-duplex, it cannot do full duplex currently.
It was already set to "Auto Negotiation" when I noticed the issue, which I believe is the default setting. I am willing to try just about anything to see what might work, and so I took Flx's suggestion to manually set it to "full duplex." As I reported above, it did not increase the speed. Thanks for responding though.  

Share this post


Link to post
On 9/3/2020 at 5:28 AM, giganerd said:

Know that OpenVPN is a single-core/single-thread application, so it will push one core/thread to its limit and not use the others, which seems to roughly be happening in your screenshot.
 
Thanks for the info, and it was an interesting read. I think you're correct in that the CPU is being throttled because of the demands of the VPN overhead, and I already suspected I was pushing the machine I'm using to it's limits. I've said elsewhere in this thread I will just bear with it until I can afford to get a newer machine that can handle it. I have also looked into the wintun driver as a possible solution, but have had issues with Eddie connecting with it and am waiting for a response to a service request. 

Share this post


Link to post
21 hours ago, Sasquatch05 said:

 It is also set up as a Plex server, but in the screenshots I posted only the torrent client was running. I also use Radarr, Sonarr, and Jackett, but have gotten the same results whether they are running or not.

Plex will drain your CPU. Unless you have an I9 for your new build. Do a search online if you like and see how/why so many are displeased with Plex Server. Disable any other service-related that you have no need for such as Backup etc.

 

Share this post


Link to post
11 hours ago, Flx said:
Plex will drain your CPU. Unless you have an I9 for your new build. Do a search online if you like and see how/why so many are displeased with Plex Server. Disable any other service-related that you have no need for such as Backup etc.

 
Plex has worked fine for me as the sole user, but I realize that the computer I'm using isn't ideal for all that I'm doing with it. It was a starting point to see if I liked Plex and if it was worth investing in a better suited machine. I don't plan on having many users, but when I start traveling for work again I'll be using it quite a bit.

I have disabled everything I can previously and still lose half my speed with the VPN running. It seems that giganerd is on to something with the idea that there's CPU throttling to avoid overheating. I believe I have quoted you on another post regarding wintun, and am trying to get that working to see if it's the solution I need.      
UPDATE: I just tested it in Safe Boot with Networking and it was still 50 Mbps with the VPN running. It has to be Intel throttling at work. I can check the BIOS to see if there is a setting there I can adjust.

Share this post


Link to post
8 hours ago, Sasquatch05 said:

Plex has worked fine for me as the sole user, but I realize that the computer I'm using isn't ideal for all that I'm doing with it.

Most don't have a problem when Plex Server is running without VPN on host computer.
If you wish to run Plex over VPN you can. If your Client Computer(s) is/are also connected over VPN that is when all the "fun" begins. It will Buffer like "crazy". I did test Plex as well from a remote location(my brother-in law real IP) last weekend after fixing his network problems. Well, streaming a 10 gigabyte video no luck for duck. A 2 gigabyte video (YTS type) did work.
Other than Plex see if Serviio or EMBY works for you.
P.S. If you don't craft your Windows System OS a little and hope that "Default Settings"  will do it for you Good Luck!

 

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Security Check
    Play CAPTCHA Audio
    Refresh Image

×
×
  • Create New...