Jump to content
Not connected, Your IP: 18.207.106.142
bookth

ANSWERED Cannot Use Internet Unless Connected to VPN

Recommended Posts

Hey - I'm really hoping you guys can help me.

I'm using AirVPN on a MAC - works great so far, very happy with it - but have noticed that I can no longer connect to the internet AT ALL unless I'm using the VPN. This seems a little extreme to me, and likely a bug.

I cannot put into words how hopeless I am with these kinds of things - I've looked at some previous posts of people with the same problem. Most seem to be Windows users (no use to me) and the language goes right over my head. 

Does anyone think they can help? I'd be sad to change VPNS or give them up altogether, but I don't like the idea of it not allowing me to use the internet without it. 

Share this post


Link to post
@bookth

Hello!

That's actually unexpected. First thing to check is DNS settings. Make sure that publicly accessible DNS servers are set in your Mac, while Air software is not running. Did it happen while you were running Eddie or Hummingbird?

Kind regards
 

Share this post


Link to post

Hmmmmm, I am running Eddie and the exact same thing just started happening to me. I am running 2.18.9 of Eddie and the latest update of Catalina. I was running older yesterday when I first noted the problem and updated both to see if it would help. It didn't. Was the problem solved but the solution above? And I am not sure I understand it anyhow. How do I set publicly accessible DNS servers in my Mac? Sorry for being not too smart.

Share this post


Link to post
On 7/31/2020 at 7:35 AM, Staff said:
@bookth

Hello!

That's actually unexpected. First thing to check is DNS settings. Make sure that publicly accessible DNS servers are set in your Mac, while Air software is not running. Did it happen while you were running Eddie or Hummingbird?

Kind regards
 
so I’ve accessed my DNS settings but can’t see anything about making them publically accessible? 

this is becoming a real problem for me as my computer can no longer pick up WiFi when I’m away from home...

Share this post


Link to post
Posted ... (edited)

Thanks for your response. Following that link takes me to a page explaining how to access my DNS settings - but I'm not sure what I should be changing? For example, two DNS servers are listed. Should I just remove them both? There is nothing there that suggests how I'd make them publicly accessible (to my eyes).

Edit to add: I've just checked my partner's Mac settings (she's never used VPN and her connection is fine). I've matched my network settings exactly to hers, removing one DNS server that wasn't present on her computer. Sadly no change...

Edited ... by bookth

Share this post


Link to post

You should probably read Staff's first reply again, and more carefully. You are not supposed to make anything publically accessible, but enter IP addresses of DNS server that are themselves publically accessible, so that you as a member of that public can access them and get DNS to work again.
For example: Cloudflare DNS would be publically accessible. Anyone can enter 1.1.1.1 in there and DNS would work. In contrast, AirDNS is not publically accessible, because not everyone can simply enter 10.4.0.1 and have a working DNS server: You need to be connected to AirVPN. And that is what Staff writes about.


» I am not an AirVPN team member. All opinions are my own and are not to be considered official. Only the AirVPN Staff account should be viewed as such.

» The forums is a place where you can ask questions to the community. You are not entitled to guaranteed answer times. Answer quality may vary, too. If you need professional support, please create tickets.

» If you're new, take some time to read LZ1's New User Guide to AirVPN. On questions, use the search function first. On errors, search for the error message instead.

» If you choose to create a new thread, keep in mind that we don't know your setup. Give info about it. Never forget the OpenVPN logs or, for Eddie, the support file (Logs > lifebelt icon).

» The community kindly asks you to not set up Tor exit relays when connected to AirVPN. Their IP addresses are subject to restrictions and these are relayed to all users of the affected servers.

 

» Furthermore, I propose that your paranoia is to be destroyed. If you overdo privacy, chances are you will be unique amond the mass again.

Share this post


Link to post

Thank you Giganerd! (And apologies for misunderstanding the original post).

I've just added the suggested 1.1.1.1 DNS while AirVPN was disconnected and I am now able to access the internet while not using the VPN. Very grateful for everyone's patience. 

Share this post


Link to post

hmmmmm, that solved the problem, but luckily i had saved the old DNS addresses in a text file, because i had to reneter them to get Eddie working again. A friend says i should install it all on a virtual UBUNTU machine so that Eddie is only running on there, and my regular internet access will work as well. I am goign to look into that. Thanks for the suggestions, wish there was another way.
 

Share this post


Link to post

The thing is that you usually don't need to set them in the first place. Your router sends its own to all the clients connecting to the network, but Eddie sometimes messes up DNS settings. The real solution would be to let them be set automatically/via DHCP again.


» I am not an AirVPN team member. All opinions are my own and are not to be considered official. Only the AirVPN Staff account should be viewed as such.

» The forums is a place where you can ask questions to the community. You are not entitled to guaranteed answer times. Answer quality may vary, too. If you need professional support, please create tickets.

» If you're new, take some time to read LZ1's New User Guide to AirVPN. On questions, use the search function first. On errors, search for the error message instead.

» If you choose to create a new thread, keep in mind that we don't know your setup. Give info about it. Never forget the OpenVPN logs or, for Eddie, the support file (Logs > lifebelt icon).

» The community kindly asks you to not set up Tor exit relays when connected to AirVPN. Their IP addresses are subject to restrictions and these are relayed to all users of the affected servers.

 

» Furthermore, I propose that your paranoia is to be destroyed. If you overdo privacy, chances are you will be unique amond the mass again.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Security Check
    Play CAPTCHA Audio
    Refresh Image

×
×
  • Create New...