Jump to content
Not connected, Your IP:

Recommended Posts

This is really stupid but I can't figure out how to download Airvpn. I signed up for a plan and now when I go to download it gives me all these options for what OS to use but when I click any of them there's no link or file to download. What is it that I'm doing wrong?

Share this post

Link to post


We apologize for any inconvenience, it was a temporary problem on our side. Can you please try again now?


You might still have a JavaScript script causing the problem cached in the browser: make sure to delete or refresh (usually hit F5 on the web site page) your browser's cache if you still don't see "Download" button.

Kind regards

Share this post

Link to post
14 minutes ago, lindaburger said:

I've tried again and it still doesn't work for me. I've tried different browsers as well.

Cannot reproduce, it's showing and is clickable.
If you reload, make sure to press CTRL + F5, not F5 alone. That CTRL press is what invalidates the cache upon reloading.

» I am not an AirVPN team member. All opinions are my own and are not to be considered official. Only the AirVPN Staff account should be viewed as such.

» The forums is a place where you can ask questions to the community. You are not entitled to guaranteed answer times. Answer quality may vary, too. If you need professional support, please create tickets.

» If you're new, take some time to read LZ1's New User Guide to AirVPN. On questions, use the search function first. On errors, search for the error message instead.

» If you choose to create a new thread, keep in mind that we don't know your setup. Give info about it. Never forget the OpenVPN logs or, for Eddie, the support file (Logs > lifebelt icon).

» The community kindly asks you to not set up Tor exit relays when connected to AirVPN. Their IP addresses are subject to restrictions and these are relayed to all users of the affected servers.


» Furthermore, I propose that your paranoia is to be destroyed. If you overdo privacy, chances are you will be unique amond the mass again.

Share this post

Link to post
Posted ... (edited)
7 minutes ago, giganerd said:

Cannot reproduce, it's showing and is clickable.
If you reload, make sure to press CTRL + F5, not F5 alone. That CTRL press is what invalidates the cache upon reloading.
I found this picture in another thread andI guess that's what it's supposed to look like but for me there's no download button. I've tried Control+F5 as well and no luck.

(Edited a grammatical error)

Edited ... by lindaburger

Share this post

Link to post

I attached the screenshot to show the layout of the download page, this is what it looks like on AirVPN site. Does it look the same to you? Can you see the download button from your side? If something is off with the screenshot that are not the same as your experience, let us know about this.

AirVPN Download Screenshot.png

Share this post

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Security Check
    Play CAPTCHA Audio
    Refresh Image

  • Create New...