Jump to content
Not connected, Your IP:
Veep Peep

Eddie 2.16.x-->2.18.9 Issue

Recommended Posts


I updated Eddie from 2.16.x to 2.18.9 on Windows 10.

I did not uninstall the old version first, just installed over it.  It installed ok.

The Eddie screen comes up with my login and password already filled out from before when it worked.

Upon launching I am not greeted with Cannot login (curl (7) Failed to connect to 63.xxx.xxx.xxx port 80 bad access.

I typed my user name and password again - same error.  

Windows Firewall is on, so I turned it off for Domain, Private and Public.  It works.

I turned them on one by one and it works for Domain and Public, but as soon as I add private it fails again with the above error.
I used 'Allow an app through firewall' added Eddie - Windows UI (both private and public.
Still the problem persists when the Private Firewall is turned on.

With the private firewall turned off, I can see the list of servers then try to connect to a server and it keep trying and failing with the error

curl: (7) Failed to Connect to <server>_exit.airservers.org port 89: Bad access
<red x> Checking route IPv4 failed

If more info is needed, please let me know!





Share this post

Link to post
@Veep Peep


Try to delete file default.profile while Eddie is not running, then re-run Eddie. Looking at the log you can see the location of that file, it is shown in the initial log entries.

Kind regards

Share this post

Link to post

Ok, did that.   The file shows the currete date and time when I logged in again.
I also noticed a firewall rule file - winfirewallrules_original.vfw   

It works with the firewall off now.
But as soon as I enable the Windows Firewall it - it gives the same error.  And I lose my connection.

Is there more info I can send you?




Share this post

Link to post

All fixed with AV support.

reset Firewall rules

netsh advfirewall reset

Then reset my tap-9 adapter default gateway

TCPIP Properties
TCPIP Advanced Properties

Hope this help others!

Thanks for the super fast support!


Share this post

Link to post

Did you try staffs advice?

Just remove default.profile

Run eddie-ui from the command line and look for a line that says "Profile path:" (If might appear in the logs tab of eddie)

Something like:

Profile path: /usr/lib/eddie-ui/default.profile

then remove (or move to keep a backup) that file and run eddie again.

Share this post

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Security Check
    Play CAPTCHA Audio
    Refresh Image

  • Create New...