Jump to content
Not connected, Your IP:

Eddie Stopped Working After Printer Install - FIXED

Recommended Posts

So I installed a new printer yesterday....and then Eddie fell over, at precisely 1am.  😱 😱 😱😫😫😫

To install my new (wireless) printer I needed the HP smart app.  This had to be downloaded from the Microsoft store; which promptly refused to accept that I was already connected to the internet (error-0x800704cf - "you'll need the internet for this" message)   🤬🤬.  I found two sites which were both helpful: https://windowsreport.com/error-0x800704cf-pc-fix/   and   https://answers.microsoft.com/en-us/windows/forum/all/windows-store-not-working-while-running-on-a-vpn/90d51e9b-4f4c-4b63-b542-dfb1b6862239.  😇

I tried everything on the first site, to no avail.  Then tried the second site and Microsoft Store started to work.  I downloaded the app and the printer works.  Happy days!  👍 .  Summary of the advice is here:

Go to: Control Panel\Network and Internet\Network Connections

Right-click the TAP network device for your VPN.                         
Go to properties.
Click Configure.
click the Advanced tab

Select "Media Status"
Change Value to "Always connected"
Click ok.

Right-click the TAP network device for your VPN again.
Go to properties.
Click "internet services version 4 (TCP/IPv4)"
Click Properties.
Click Advanced.
Tick the "Automatic Metric" boxClick ok.

Click ok.
Click Close.

However....Later in the evening I try to complete a foreign payment with my bank.  I've tried to complete this several times but the bank's website kept crashing.  Tonight I get to the final password check... and everything freezes, at exactly 1 am (AST, 5am GMT).  Eddie has just gone into a loop of connecting/disconnecting.  This is hugely irritating and slightly suspicious given the timing (on the hour - don't know what was scheduled but something got checked or updated).  Anyway to cut the story short, Setting the' Media status' (1st para of the summary above) back to 'Application Controlled' sorted the problem.  Eddie started working immediately, without a reboot.  😍😍😍

Hope this helps someone.

Share this post

Link to post

At exactly 1 A.M. would suggest a recurring task (Windows) or cronjob (Linux, in your router for example). Can you check on that?


LZ1's New User Guide to AirVPN « Plenty of stuff for advanced users, too!

Unofficial Eddie for Android F-Droid repository: repo.opensourcery.eu

Want to contact me directly? All relevant methods are on my About me page.

Share this post

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Security Check
    Play CAPTCHA Audio
    Refresh Image

  • Create New...