Jump to content
Not connected, Your IP:
Sign in to follow this  

Local connected printer with cross cable not working with network lock on

Recommended Posts

Hello, i have an issue with a computer that has a a local printer connected and shared to the network. This computer has eddie with network lock active.


The local printer is connected with a cross cable, it's is in the private network 169.254.182.XX.


When network lock is off, i can ping and print from this computer and from any computer in the lan (the printer is shared with windows). But when network lock is on, i can't event print from the same computer connected to the printer (i can't ping either).


Using last Eddie version 2.16.3. I alredy tried setting allow lan/private check, allow ping check, adding the private ip to addresses allowed and also adding the ip in the Routes "tab". But nothing change, it still not work.


Anyone knows how to fix this?


Thanks in advance

Share this post

Link to post

In IPv4, private networks are:
The is a range of link-local addresses. It has been allocated for zero configuration networking when DHCP services are not available or disabled, and manual configuration by the network administrator has not been performed.


As such, Network Lock does not explicitly allow communications from and to range. Please try to add it (we would say to include the whole range in case the printer address varies) in the Preferences > Routes Eddie window, outside the tunnel. This will also unblock the range from Network Lock and should fix the issue.


Kind regards

Share this post

Link to post

Hello! thanks for the prompt response.


I think i fix the issue. The problem was precisely adding the range to the network lock "addresses allowed" and/or  "routes ouside the vpn".


When i was doing that, a route was created trying to make that range going through the default gateway     21


After completely removing that route from the "addresses allowed" and "routes outside the vpn", the printer start to work with network lock too, i suppose because that route was not created anymore. I think my mistake was supposing from the start that i need to add a route to get the local link working.


By the way, sorry for asking something not related but as i create another thread that didn't receive any answer, can i ask you if there is any leak risk or known problem when using same server (same public exit IP) with two sessions at the same time? For example i found this in "forward port" page

"Warning: Two or more sessions are connected to the same server. The same IP+Port can't be mapped to multiple destination."


Thanks again for your help

Share this post

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Security Check
    Play CAPTCHA Audio
    Refresh Image
Sign in to follow this  

  • Create New...