Jump to content
Not connected, Your IP: 18.207.238.169
whiskey_76

Won't Connect at checking Ipv6

Recommended Posts

Lately certain servers Eddie will not connect to at the checking IPV6 part of the process. Even servers that are not experimental and it's kind of annoying.

What could be causing that problem? I tried different settings in the network section of preferences but nothing seems to help. Eddie will fallback and connect to another server without any problems though.

For example, I just tried to connect to Acamar and it kept disconnecting after "checking route IPv6". Shouldn't it just be able to use IPV4?

 

Edit: The next time this happens I will post logs. I did see when I looked earlier it had something to do with CURL?

Share this post


Link to post

I tweaked settings in network preferences and told it to block ipv6 and I could connect on first try, interesting.

Share this post


Link to post

I have the same problem. I can connect to some servers, but others hang at "Checking route IPv6". The logs show cURL timing out after 20000ms, three times, before declaring "Checking route IPv6 failed" and disconnecting.

In options/Networking, I had the Layer IPv6 combo dropdown set to "Inside tunnel if supported, otherwise blocked" and had the "Switch to Block if issue is detected" checked.

By setting the Layer IPv6 combo dropdown to "Block", I can connect to servers which fail with the default settings active. All other selections result in the "Checking route IPv6 failed" error.

Something's not right - it would be nice to know what causes this.

Sample log excerpt and system report attached.

eddie-ipv6-timeout.txt

eddie-system-report.txt

Share this post


Link to post

I have run into a similar issue, so I switched back to the last version available in the changelog, the modern client seems to be giving me more trouble then the old.

Share this post


Link to post

I had issues connecting to some servers with ipv6 (running  Linux) as described.

I changed airvpn settings to force UDP protocol (don't think that has anything to do with it though), then changed protocol settings:

Layer ipv4 inside tunnel

Layer ipv6 Block

Switch to block if issue Yes

 

IP used for connection: Ipv4, IPv6 , Automatic

 

It's weird but I think not having IPv6 enabled even though you're blocking it might be causing the connection issue. Looking through logs IPv6 is actually blocked on the WAN side but I am connecting to servers just fine now.

Share this post


Link to post

Hi guys,

 

Works on my PC just fine as normal. Just installed on laptop, as unable to access PC as I'm bedridden. And have the same problems as above.

The above didn't generally help me, although I could connect Eddie to a server, it said network blocked when I tried accessing the net.

If the above doesn't help anyone else, try the following:

 

Preferences>Networking:

Layer ipv4: inside tunnel must be supported.

Switch to block ticked on.

Layer ipv6 blocked.

switch to block switched on and ticked.

Internet protocol used: ipv4 only (this I had to change, and different from previous posts). 

Interface for connection: Automatic. 

 

Hope that helps others in similar circumstances.

 

Also check this post: https://airvpn.org/topic/29401-checking-route-ipv6-failed-cannot-connect-to-vpn-server-using-eddie/

Share this post


Link to post

Hello! Got same issue, couldn't connect to vpn throu Eddie with default settings.

Always stuck at this thing in logs:

. 2018.11.03 20:48:34 - OpenVPN > do_ifconfig, tt->did_ifconfig_ipv6_setup=1
. 2018.11.03 20:48:35 - OpenVPN > NETSH: C:\Windows\system32\netsh.exe interface ipv6 set address ... store=active
. 2018.11.03 20:48:36 - OpenVPN > NETSH: C:\Windows\system32\netsh.exe interface ipv6 set dns ... validate=no
E 2018.11.03 20:49:21 - OpenVPN > ERROR: netsh command failed: returned error code 1

 

Disabled IpV6 in settings, that's solve my issue.

Layer ipv6 Block

Switch to block if issue Yes

Internet protocol used for connection IPv4 only

 

But i'm curious, what was the reason for errof?

Could it be that my ISP didn't support IpV6? And everything stuck at checking at this point?

Share this post


Link to post

I was having the same problem since upgrading to 2.16.3. I made the changes listed above and connected effortlessly.

 

My question though has to do with blocking ipv6:

Doesn't doing so create some kind of limitation on access to websites that use that protocol? Or, is it not a problem until Ipv4 is finally declared obsolete?

 

Originally the connectivity to Air servers seemed to become less of a problem when I deactivated Network Lock on start-up, but I also like to have Network Lock enabled even when I am not online since it seems to function as a Firewall of sorts.

Share this post


Link to post

I'm a new member running Airvpn on Ubuntu systems. I was able to log in with ipv6 blocked on the eddie UI but when I checked whatismyip.com it showed ipv6 address as my true address and the ipv4 as the VPN address. I disabled ipv6 on both my systems and now whatismyip.com only detects ipv4 VPN addresses and ipv6 not detected. It works but I am worried about not being able to access ipv6 protocol sites. Or is that even a thing yet?

Share this post


Link to post

Try:

Enable temporary ipv6 in your  connection profile settings, I think that will be a choice on all Ubuntu systems that use Ubuntu's Network Manager.

All this does is scramble another chunk in the chain of identable info.

ipv6 addresses in Mint/Ubuntu are "derived" from the mac address you provide network manager, so you may as well mac spoof it up. I don't use vanilla ubuntu, so maybe it's a little tougher to spoof macs from the UI.

 

Enable network lock when using Eddie, because it's a fantastic security option.

 

Also, don't worry about ipv6 unless stuff isn't working. I have had it throttled through eddie for a long time and the internet works fine. One place where it might cause probs is p2p, at least in my experience.

 

More important is what kinds of privacy/security habits one uses with a browser, regardless of VPN, and if you use IoT stuff like Roku without thinking about security at all and so on. There's much easier ways to mess with you than tracking a fluid ipv6 address I think.

Share this post


Link to post

IPv6 hasn't worked on AirVPN for a while now. It did for a short term, but stopped working and as we've seen, won't connect or fails to check the route. Doesn't matter what device or connection, it'll fail v6.

 

Shame, really. 

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Security Check
    Play CAPTCHA Audio
    Refresh Image

×
×
  • Create New...