Jump to content
Not connected, Your IP:

AirVPN won't work with custom DNS on router

Recommended Posts



I set up airVPN on my mini router using a custom build of openWRT from GL.inet but when I run ipleak and whoer it comes back with a ton of DNS leaks (50+). 


When I changed the DNS from "Keep blank to use default DNS" to Custom DNS of and then airVPN can no longer connect at all!


I've also tried checking the box that says: "Force all clients to use: [  ] Override Clients' DNS setting" but it doesn't solve the issue. 


After setting the Custom DNS, airVPN disconnects and says the following over and over:


RESOLVE: Cannot resolve host address: America.vpn.airdns.org:1194 (try again)

Could not determine IPv4/IPv6 Protocol

SIGUSR1 [soft,init_instance] received, process restarting




NOTE: When NOT connecting through the router, and just firing up Eddie on my mac, I get no leaks.

Share this post

Link to post

The problem is that you router cannot resolve America.vpn.airdns.org:1194 if you set your DNS servers to and before you have successfully established an OpenVPN connection to an OpenVPN servers. So etiher you use AirVPN servers with resolved ips or you have to dynamically change your DNS server after your router has connected to AirVPN.

Share this post

Link to post

I'm currently connected to an AirVPN server in Canada (enif), and currently my DNS is essentially the same as my IP (only the last digit is different), but I just ran ipleak and got 72 DNS leaks from the USA. At this point how do I fix the DNS leaks? 

Share this post

Link to post

For DD-WRT router firewall set?

Use this for Scripts-Firewall


iptables -I FORWARD -i br0 -o tun0 -j ACCEPT
iptables -I FORWARD -i tun0 -o br0 -j ACCEPT
iptables -I FORWARD -i br0 -o vlan2 -j DROP
iptables -I FORWARD -i br0 -o ppp0 -j DROP
iptables -I INPUT -i tun0 -j REJECT
iptables -t nat -A POSTROUTING -o tun0 -j MASQUERADE




Share this post

Link to post


When I changed the DNS from "Keep blank to use default DNS" to Custom DNS of and then airVPN can no longer connect at all!

For DNS3 after airvpn dns in the list Use a DNS such as https://blog.uncensoreddns.org/

Forget about OpenDNS/Google DNS.



It's worth mentioning OpenNIC, which Air officially supports.

Moderators do not speak on behalf of AirVPN. Only the Official Staff account does. Please also do not run Tor Exit Servers behind AirVPN, thank you.
Did you make a guide or how-to for something? Then contact me to get it listed in my new user guide's Guides Section, so that the community can find it more easily.

Share this post

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Security Check
    Play CAPTCHA Audio
    Refresh Image

  • Create New...