Jump to content
Not connected, Your IP: 3.90.56.90
twoez

ANSWERED Download speeds dropping to zero and going up and down

Recommended Posts

Hello,

 

I have problems when downloading with AirVPN on Ubuntu 16.04 using OpenVPN client. I have tried switching to other VPN servers, but still have problems with the download speed. The speed often goes to zero and sometimes it goes up, but then quickly drops to zero again. For example it goes up to 1.1Mbit and then slowly goes back to zero. And 1.1Mbit is not even close to my actual network speed.

 

When I disable openvpn the download speed is back to normal.

 

Any ideas why this is happening?

 

Cheers!

Share this post


Link to post

I have solved the problem. It had to do with the DOS Defense protection of my Draytek router's firewall. I now use TCP instead of UDP and I now get full speed! So take a look at your router's firewall if you are experiencing the same problems.

 

Edit: Some Swedish servers are also slow for me, but that's another issue.

Share this post


Link to post

I have been trying to debug the same problem for the last few days.

 

I have a Draytek router, connecting via a Windows 7 PC, I have switched to TCP 443 in Eddie, I've disabled DDOS protection, firewall, and internal VPNs on the router, and I still get the exact described problem.

 

Any time I try to use AirVPN from pretty much any server, it's like the act of traffic passing through nukes the connection. A brief spike of traffic, followed by 0 kb/s then recovery a few seconds later. Websites will load in stutters, games will work then completely freeze then repeat that, it's quite frustrating. Eddie's logs show nothing untoward.

 

I've attached a screenshot of pinging google.co.uk. The massive ping time increases are whenever I actually try to use the connection. NetLimiter tells me that I'm not even hitting 1MB/s.

PingPlotter interprets the problem as significant local packet loss (i.e. from the 10.4.X.X location onwards).

 

Any insights others can share as to further debug these things would be greatly appreciated.

 

Edit: I should of course also add that without AirVPN, the connection is perfectly fine, and a work VPN works similarly without issue, so something is up specifically with how AirVPN and my PC/network environment is mixing.

Share this post


Link to post

Mm weird although I find it remarkable that we both have a Draytek router and have/had this problem. Have you tried rebooting the router after disabling stuff like a firewall/dos protection? Also some VPN servers are very bad speaking of speed.

Share this post


Link to post

After trying to uninstall AirVPN and TAP, to try a clean reinstall, the network connection on the machine in question ended up completely screwed up (such that Windows insisted it couldn't load the original drivers for the Ethernet adapters), so I have a feeling that particular machine was having more general issues. Trying AirVPN on a similar machine yielded no problems, so the router itself was operating fine.

 

After a few abortive attempts to resurrect it, I ended up wiping the machine and reinstalling Windows. Now I have no such issues, so I don't know what was up with it but it was clearly machine specific. I'm also glad to have come across the DDOS protection pointer since I suspect I never would have thought to turn that off, so thanks!

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Security Check
    Play CAPTCHA Audio
    Refresh Image

×
×
  • Create New...