Jump to content
Not connected, Your IP: 3.90.56.90
404nbt

ANSWERED Ubuntu 16.04 LTS Eddie Install - How?

Recommended Posts

 

​Hi,

​I went to this page https://airvpn.org/linux/ selected Linux, 64bit, Debian/Ubuntu, Graphical UI, and then downloaded the file "eddie-ui_2.12.4_linux_x64_debian.deb".

 

​So then I right clicked & selected "open with software install"​, then selected "Install" and nothing happens. It does not install.

I'm new to Ubuntu/Linux and I'm just wondering if someone can point me to a guide or can help me solve this issue. On OS X its just a matter installing it and signing in, simple. Not so simple with Ubuntu.

​Thanks

Share this post


Link to post

​I $ cd into Downloads and run the command you suggested and it worked but I had to install some dependencies as was recommended in Terminal. All is working fine now. Thanks for taking the time out to help.

 

Edit: To be clear for others, this is what I did.

 

so, $ cd /Downloads

Then: $ sudo dpkg -i  eddie-ui_2.12.4_linux_x64_debian.deb

Then $ sudo apt-get install gksu

 

Wait until install finishes, then:

$ sudo apt-get -f install

 

Wait until the install finishes,

 

Finally,

Then Open Eddie, sign in, select your server, and wait until it connects. Then go to https://ipleak.net and check that you're not leaking your ip or dns.

Share this post


Link to post

I tried to do this by going to the Downloads folder and then tring to go to root and it said I did not have root installed

I theninstalled it like it recomended and I saw this also it shows it is software from2010 and it has a woman showing her breasts, like a fairy or something. I hope I did not download something with malware.

 

 

Couldn't find font "-adobe-helvetica-medium-r-*-*-10-*-*-*-*-*-iso8859-1",
trying "fixed". Please fix your system so helvetica can be found,
this font typically is in the rpm (or pkg equivalent) package
XFree86-[75,100]dpi-fonts or fonts-xorg-[75,100]dpi.
  *******************************************
  *                                         *
  *        W E L C O M E  to  R O O T       *
  *                                         *
  *   Version   5.34/14  16 December 2013   *
  *                                         *
  *  You are welcome to visit our Web site  *
  *          http://root.cern.ch            *
  *                                         *
  *******************************************

ROOT 5.34/14 (heads/v5-34-00-patches@v5-34-13-131-gd110ad3, Jan 07 2014, 00:12:00 on linuxx8664gcc)

 

 

Then after when I was in the download folder again I ran this

 

 

sudo dpkg -i  eddie-ui_2.12.4_linux_x64_debian.deb

 

and it started to work but then said this

 

Selecting previously unselected package airvpn.
(Reading database ... 162965 files and directories currently installed.)
Preparing to unpack eddie-ui_2.12.4_linux_x64_debian.deb ...
Unpacking airvpn (2.12.4) ...
dpkg: dependency problems prevent configuration of airvpn:
 airvpn depends on mono-utils; however:
  Package mono-utils is not installed.
 airvpn depends on libmono-system-windows-forms4.0-cil; however:
  Package libmono-system-windows-forms4.0-cil is not installed.
 airvpn depends on stunnel4; however:
  Package stunnel4 is not installed.
 airvpn depends on curl; however:
  Package curl is not installed.

dpkg: error processing package airvpn (--install):
 dependency problems - leaving unconfigured
Processing triggers for man-db (2.6.7.1-1ubuntu1) ...
Processing triggers for gnome-menus (3.10.1-0ubuntu2) ...
Processing triggers for desktop-file-utils (0.22-1ubuntu1) ...
Processing triggers for mime-support (3.54ubuntu1.1) ...
Errors were encountered while processing:
 airvpn
 

 

 

 

Then I thought toinstall thedependency mono and I ran

 

sudo apt-get install mono-devel

 

then it told me this

 

sudo apt-get install mono-devel
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 airvpn : Depends: mono-utils but it is not going to be installed
          Depends: libmono-system-windows-forms4.0-cil but it is not going to be installed
          Depends: stunnel4 but it is not going to be installed
          Depends: curl
 mono-devel : Depends: libmono-cecil-private-cil (>= 3.2.8) but it is not going to be installed
              Depends: libmono-codecontracts4.0-cil (>= 1.0) but it is not going to be installed
              Depends: libmono-compilerservices-symbolwriter4.0-cil (>= 3.0.6) but it is not going to be installed
              Depends: libmono-corlib2.0-cil (>= 3.2.8) but it is not going to be installed
              Depends: libmono-peapi2.0a-cil (>= 3.2.8) but it is not going to be installed
              Depends: libmono-peapi4.0a-cil (>= 3.2.8) but it is not going to be installed
              Depends: libmono-relaxng4.0-cil (>= 2.10.1) but it is not going to be installed
              Depends: libmono-security2.0-cil (>= 3.0.6) but it is not going to be installed
              Depends: libmono-system-componentmodel-composition4.0-cil (>= 3.0.6) but it is not going to be installed
              Depends: libmono-system-componentmodel-dataannotations4.0-cil (>= 3.2.3) but it is not going to be installed
              Depends: libmono-system-configuration-install4.0-cil (>= 1.0) but it is not going to be installed
              Depends: libmono-system-data-linq4.0-cil (>= 1.0) but it is not going to be installed
              Depends: libmono-system-data2.0-cil (>= 3.0.6) but it is not going to be installed
              Depends: libmono-system-runtime4.0-cil (>= 2.10.1) but it is not going to be installed
              Depends: libmono-system-servicemodel4.0a-cil (>= 3.2.3) but it is not going to be installed
              Depends: libmono-system-web-services4.0-cil (>= 1.0) but it is not going to be installed
              Depends: libmono-system-web2.0-cil (>= 2.10.3) but it is not going to be installed
              Depends: libmono-system2.0-cil (>= 3.2.1) but it is not going to be installed
              Depends: libmono2.0-cil (>= 3.0.6) but it is not going to be installed
              Depends: mono-mcs (= 3.2.8+dfsg-4ubuntu1.1) but it is not going to be installed
              Depends: mono-xbuild (= 3.2.8+dfsg-4ubuntu1.1) but it is not going to be installed
              Depends: libmono-cil-dev (= 3.2.8+dfsg-4ubuntu1.1) but it is not going to be installed
              Depends: libmono-2.0-dev (>= 3.2.8+dfsg-4ubuntu1.1) but it is not going to be installed
              Depends: libmono-2.0-dev (< 3.2.8+dfsg-4ubuntu1.1.1~) but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
 

 

 

Linux mint here.

Share this post


Link to post

E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

 

Did you try this one?

 

Try to use apt-get for all your package needs. Add the Eddie repository to your /etc/apt/sources.list.d directory and do

apt-get install airvpn

This will download and install all packages dpkg screams about. Bonus: Don't worry about updates, they're covered in your hopefully regular apt-get (dist-)upgrade runs.

 


Always remember:
There's a guide to AirVPN,

Amazon IPs are not dangerous here,
running TOR exits is discouraged,

using spoilers for your logs helps us read your thread.

~ Furthermore, I propose that your paranoia is to be destroyed. ~

Instead of writing me a personal mail, consider contacting me via XMPP at gigan3rd@xmpp.airvpn.org or join the lounge@conference.xmpp.airvpn.org. I might read the mail too late whereas I'm always available on XMPP

Share this post


Link to post

 

E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

 

Did you try this one?

 

Try to use apt-get for all your package needs. Add the Eddie repository to your /etc/apt/sources.list.d directory and do

apt-get install airvpn

This will download and install all packages dpkg screams about. Bonus: Don't worry about updates, they're covered in your hopefully regular apt-get (dist-)upgrade runs.

 

Ok that must be my problem, when I try to install apt-get -f install I get an error, like this

E: Could not open lock file /var/lib/dpkg/lock - open (13: Permission denied)

E: Unable to lock the administration directory (/var/lib/dpkg/), are you root?

 

I tried it on root the one I downloaded and itdos not work it seems like that root software is strange

 

  *******************************************

  *                                         *

  *        W E L C O M E  to  R O O T       *

  *                                         *

  *   Version   5.34/14  16 December 2013   *

  *                                         *

  *  You are welcome to visit our Web site  *

  *          http://root.cern.ch            *

  *                                         *

  *******************************************

 

ROOT 5.34/14 (heads/v5-34-00-patches@v5-34-13-131-gd110ad3, Jan 07 2014, 00:12:00 on linuxx8664gcc)

 

CINT/ROOT C/C++ Interpreter version 5.18.00, July 2, 2010

Type ? for help. Commands must be C++ statements.

Enclose multiple statements between { }.

Error: cannot open file "DllImport.h"  (tmpfile):2:

*** Interpreter error recovered ***

root [0] apt-get -f install

Error: Symbol apt is not defined in current scope  (tmpfile):1:

Error: Symbol get is not defined in current scope  (tmpfile):1:

Error: Invalid type 'f' in declaration of 'install' (tmpfile):1:

Error: Symbol f install is not defined in current scope  (tmpfile):1:

(const int)0

*** Interpreter error recovered ***

root [1]

 

 

why did I have to install root on linux mint very strange linux mint

does nohave root installed from the showroom??

Edited by webworkers21

Share this post


Link to post

By default, on GNU/Linux you are what Windows users would call a restricted user. To install software, you need to be "root" (the "Local God", the superuser) or someone "cleared" to execute software as root. Now, I know for sure that on Linux Mint you are this someone. So you execute the commands above with a "sudo" in front of it, like so:

sudo apt-get install airvpn

Try this one.

 

I'm deliberately writing Local God. As root you can delete your running system for good. Something an admin account on Windows can't really do because he is not the highest authority on the system... but that's another topic


Always remember:
There's a guide to AirVPN,

Amazon IPs are not dangerous here,
running TOR exits is discouraged,

using spoilers for your logs helps us read your thread.

~ Furthermore, I propose that your paranoia is to be destroyed. ~

Instead of writing me a personal mail, consider contacting me via XMPP at gigan3rd@xmpp.airvpn.org or join the lounge@conference.xmpp.airvpn.org. I might read the mail too late whereas I'm always available on XMPP

Share this post


Link to post

Ok I think I fixed the poroblem ansd was able to install it

I just had to run

 

sudo apt-get install -f
 

 

Now it gives me this and looks like it is installed right?

 

4_debian.deb
(Reading database ... 163095 files and directories currently installed.)
Preparing to unpack eddie-ui_2.12.4_linux_x64_debian.deb ...
Unpacking airvpn (2.12.4) over (2.12.4) ...
Setting up airvpn (2.12.4) ...
Processing triggers for man-db (2.6.7.1-1ubuntu1) ...
Processing triggers for gnome-menus (3.10.1-0ubuntu2) ...
Processing triggers for desktop-file-utils (0.22-1ubuntu1) ...
Processing triggers for mime-support (3.54ubuntu1.1) ...

 

 

So if this is right then how do I start the aplication running to begin configuring my long awaited vpn service...wow this is hard
 

Share this post


Link to post

So if this is right then how do I start the aplication running to begin configuring my long awaited vpn service...wow this is hard

 

It's probably in your menu somewhere. Or use a terminal and call

airvpn

Type the password of root and off you go.


Always remember:
There's a guide to AirVPN,

Amazon IPs are not dangerous here,
running TOR exits is discouraged,

using spoilers for your logs helps us read your thread.

~ Furthermore, I propose that your paranoia is to be destroyed. ~

Instead of writing me a personal mail, consider contacting me via XMPP at gigan3rd@xmpp.airvpn.org or join the lounge@conference.xmpp.airvpn.org. I might read the mail too late whereas I'm always available on XMPP

Share this post


Link to post

The Airvpn client package for installation from a debian/ubuntu (apt-get) style repository is called eddie-ui.

 

sudo apt search eddie-ui
Sorting... Done
Full Text Search... Done
eddie-ui/now 2.16.3 amd64 [installed,local]
  Eddie - OpenVPN UI

 

 

However!! Remember! that nothing will be found in the repositories, or with apt unless you add the eddie-ui repositories.

 

 

 

# Create a list file in apt/sources.list.d directory, but if
# preferred you can edit the main apt/sources.list file instead. It's up to you.
sudo nano /etc/apt/sources.list.d/eddie_ui.list
# or
sudo nono /etc/apt/sources.list

# Either way add the release string to the file:
deb http://eddie.website/repository/apt stable main

# Then import the Airvpn eddie signing key, or if you prefer then copy paste
# on the commandline the public key and pipe to apt-key add. It's up to you.
wget -qO - https://eddie.website/repository/keys/eddie_maintainer_gpg.key|sudo apt-key add -
# or
echo "very-long-key-goes-here" | sudo apt-key add -

# Refresh the apt-list
sudo apt update
 

Now the "sudo apt search eddie-ui" command should work fine and you will find the eddie-ui package!

 

 

So then we can:

udo apt install eddie-ui

 

 

If it complains about unmet dependencies:

 

You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 eddie-ui : Depends: libappindicator1 but it is not going to be installed
            Depends: mono-runtime but it is not going to be installed
            Depends: mono-utils but it is not going to be installed
            Depends: libmono-system-core4.0-cil but it is not going to be installed
            Depends: libmono-system-windows-forms4.0-cil but it is not going to be installed
            Depends: openvpn but it is not going to be installed
            Depends: stunnel4 but it is not going to be installed
            Depends: curl but it is not going to be installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

 

 

Then obiviously:

sudo apt --fix-broken install

 

 

 

The only issue that seems to occur frequently is the dreaded "Checking route IPv6 failed" when the client keeps reconnecting. Not sure what to do about that one still! The only working solution is to set "Layer IPv6" to "Block" in the network settings of the eddie-ui.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Security Check
    Play CAPTCHA Audio
    Refresh Image

×
×
  • Create New...