Jump to content
Not connected, Your IP: 3.84.182.112

Recommended Posts

I've been having this problem for months now.

I'm running Windows 7 and Windows 10 and use Bitdefender Internet Security on both machines.

 

I want to be able to access certain websites outside of the VPN tunnel (so they see my real IP), but still force all other traffic through the VPN tunnel.

To achieve this, I added the exceptions inside Eddie under Settings -> Routes.
The problem is: they only work as long as I don't have network lock enabled.

How do I know this? I'm testing these routes with sites like ipleak.net, doileak.com, ifconfig.co etc.
As soon as I activate network lock, I can't access the sites I specified under "routes" anymore.
I can ping them just fine, and run a traceroute command, but I can't access them inside any web browser.
I also tried adding them under "allowed addresses" inside the "network lock" settings without any luck.

I've been trying to solve this issue with staff for almost two months now, but without luck so far.
It would be awesome if some of you could try to reproduce the same error, i.e. setting up these routes to see if you can access these sites while network lock is active.

 

"Disclaimer":
I'm using the "Windows Filtering Platform" method for network lock. (Which is the default method anyway as far as I'm aware)
Everything is working just fine when I'm using the "Windows Firewall" method, even with network lock enabled.
However, I don't want to rely on the Windows Firewall, so I'm using the firewall from Bitdefender Internet Security instead

 

Any ideas or suggestions?

Can any of you reproduce this same issue?

Are any of you using another third party firewall that doesn't cause this issue? If so, which one?

 

PS: Here are the IPs for some of the sites I used for testing so you can just copy and paste them if you want to test it for yourselves:
95.85.16.212 (ipleak.net)
62.243.70.171 (doileak.com)
188.113.88.193 (ifconfig.co)

 

Share this post


Link to post

are you using the latest version of Eddie and configuring it to use WFP for network lock, not windows firewall?

Yes, I have been using the latest beta versions of Eddie for quite some time now. I have tested lots of different versions. I think I went back as far as version 2.9.

I currently don't have it set to "WFP" specifically, but to "automatic". It doesn't make any difference, though. I've tested this multiple times already.

I'm pretty sure WFP is used as the default option if it's set to automatic.

Also, my Windows Firewall is disabled, so network lock has to use WFP.

 

Thank you for your input, though

Share this post


Link to post

More input is needed, for example what happens when you turn Bitdefender off.

This is technically impossible for any service to be 100% compatible with 3d party software firewalls and their rules.

If you are a technical person, you would probably do way better without any kind of such firewall from the first place.


Occasional moderator, sometimes BOFH. Opinions are my own, except when my wife disagrees.

Share this post


Link to post

Huh.

Just uninstalled Bitdefender Internet Security using their uninstall tool.

Now I still have this issue.

It only works when I manually set network lock to "Windows Firewall (not recommended)"

 

What the...?!

Share this post


Link to post

Haha, this is getting ridiculous.

 

Did a clean install using the latest stable release.

I set custom routes for the IPs I mentioned in my original post.

 

Now I can't access ipleak.net.

doileak.com shows my VPN exit IP.

ifconfig.co shows my real IP.

 

Share this post


Link to post

Oh boy...

I just installed Windows 7 from scratch.

So I'm running as a clean a Windows installation as possible.

Haven't installed Bitdefender Internet Security or any other firewall.

 

I'm still having the same problem.

I still can't access the sites for which I set up custom routes.

 

What the ...?!

 

Here's my log in case anyone wants to take a look: http://paste.debian.net/hidden/a4474e51/

 

This is really getting frustrating...

Share this post


Link to post

What are your custom routes and how did you set them?

 

These are the custom routes I always use to test if it's working:

xhiEXGl.png

 

I set them up inside the settings under "Routes".

 

I also tested setting up the routes manually in the settings under "OVPN directives" end entered them in the "custom directives" tab. Didn't make any difference, though.

Share this post


Link to post

Anyone?   

 

Please, if you could spare a minute to try if this works for you (custom routes with network lock enabled using the "Windows Filtering Platform"), that would be awesome!

 

Staff doesn't seem to care anymore. They haven't responded in weeks.

Share this post


Link to post

Anyone? 

 

Please, if you could spare a minute to try if this works for you (custom routes with network lock enabled using the "Windows Filtering Platform"), that would be awesome!

 

Staff doesn't seem to care anymore. They haven't responded in weeks.

 

 

if I used Eddie I'd test for you.  Sorry. 

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Security Check
    Play CAPTCHA Audio
    Refresh Image

×
×
  • Create New...