Jump to content
Not connected, Your IP: 3.234.214.179
AirBR

PfSense - Set to use VPN DNS, cant use DNS until VPN is up ;)

Recommended Posts

Hey All,

  I use PfSense with AirVPN and its set up to use AirVPN DNS (10.39.0.1 IIRC) to prevent DNS leakage, however the "client" in Pfsense is configured to use europe.vpn.airdns.org which cannot resolve until the AirVPN is up.

 

I've found out what europe.vpn.airdns.org CURRENTLY resolves to and used the IP instead to work around this, but i assume this changes frequently to manage load (correct?).

 

So am i ok to just leave this as it is or should i be doing something else?

 

Finally, download speed across the VPN are about 2-3Mbps when i have a 20Mbps connection - seems a little slow -  anything i can check here?

Share this post


Link to post

my suggestion is to choose a server that works best for you and use its IP address specifically.

 

That flows into the next question.  Test different *locations* and ports and protocols to see which ones give you the best performance.  This will largely be affected by your route to that datacenter.

 

Your max line speed isn't very high to begin with if you really meant megabits/second so unless you're using really weak hardware in your pfsense box you should be able to reach close to 20mbit/s on the VPN.

Share this post


Link to post

If you used my guide, this is a caveat of that, you must use direct IP for clients. You are better off that way anyway as you are leaving a trail with a third party that your are connecting to a VPN service. That being said, I did make a provision in the client settings that will automatically connect to another server if the one you are using goes down.

### Use Multple "remote" entries with the according entry IP address of your favorite servers       ###;
### other than the server entered in the "Server Host or Address" entry above and pfSense ###;
### will automatically recconnect in a round robin fashion if the server you are connected to ###;
### goes down or is having quality issues. Edit and uncomment the fake lines below or add your own. ###;
remote XX.XX.XX.XX 443 ###AirVPN_US-Atlanta-Georgia_Kaus_UDP-443###;
remote XXX.XX.XX.XXX 2018 ###AirVPN_US-Miami_Acamar_UDP-2018###;
remote XXX.XX.XX.XXX 2018 ###AirVPN_US-Miami_Yildun_UDP-2018###;
remote XX.XX.XX.XX 53 ###AirVPN_US-Miami_Cursa_UDP-53###;
remote XXX.XX.XX.XX 443 ###AirVPN_CA-Dheneb_UDP-443###;
remote XXX.XX.XXX.XXX 443 ###AirVPN_CA-Saiph_UDP-443###;
All you have to do is enter multiple remote lines into the advanced section on your client settings. There may be a short delay as it reconnects but i have honestly never noticed when mine does. Just choose your favorite server in the main entry and a number of secondary options.

Have my guides helped you? Help me keep helping you, use my referral: userbar.png

How to set up pfSense 2.3 for AirVPN

Friends don't let friends use consumer networking equipment!

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Security Check
    Play CAPTCHA Audio
    Refresh Image

×
×
  • Create New...