Jump to content
Not connected, Your IP: 3.238.235.155

Recommended Posts

Good Morning,

 

I signed up for AirVPN yesterday and installed the client however, when I went to connect to one of the servers I got a BSOD.  I restarted the computer and tried connecting again, but got the same BSOD just as it was connecting.  Below are the specs of my computer and system/program information:

 

Client Version: 2.10.3

OS: Windows 7 Ultimate x64

RAM: 6.00 GB

CPU: Quad-core Intel i5 @ 2.53 GHz

Page File: Custom set to recommended amount of 8817 MB

 

I also already ran and check of my hard drive and no issues were found.

 

The specific BSOD I am getting is in the NETIO.sys file and is PAGE_FAULT_IN_NONPAGED_AREA.  The STOP codes are:

 

0x00000050 (0xFFFFF88009D2DC69, 0x0000000000000000,0xFFFFF88001969E4C, 0x0000000000000000)

 

The address information listed on the BSOD for the address in NETIO.sys is FFFFF88001969E4C base at FFFFF88001968000 with a DateStamp of 5294760d.

 

I can't remember the last time I got a BSOD and the fact that I got two of them within 10 minutes, both right after trying to connect to the AirVPN servers (and that it was in the NETIO.sys file), I am pretty sure they have something to do with the AirVPN Client.

 

I would appreciate any assistance that can be provided for this issue.  I used AirVPN on my Android and it worked great and I am really looking forward to using it on my computer.

 

Thank you in advance for any help.

Share this post


Link to post

Hello,

 

as you can see on the screenshot you posted, the system-wide crash has been caused by netio.sys. As a first step, make sure that the driver(s) of your network card(s) are all up to date.

 

We would rule out that the Air software, running in the userspace and  in the .NET framework, is capable to directly cause a Page_Fault_In_Non_Paged_Area and bring down the entire system. 

 

At most, it could cause it very indirectly, for example when low level drivers are already bugged.

 

Kind regards

Share this post


Link to post

Thank you for the quick response.

 

To further troubleshoot this issue, this is what I have done since my first post:

 

1. Uninstalled AirVPN software and removed the network adapter it installed.

2. Restarted the computer

3. Updated my Ethernet drivers to the latest from Realtek's website and updated my WiFi drivers to the latest from Intel's website, along with all available Windows updates

4. Restarted the computer

5. Re-downloaded and re-installed the AirVPN software (Windows 7 64-bit EXE)

6. Software installed without an issue, including the TAP-Windows Provider V9 Network adapters

7. Run the AirVPN software and login successfully

 

After I login, I choose to connect to the recommended server.  This is fine until it says "Checking Route"; this is where the BSOD occurs.  I also tried the 32-bit version of the software but get the same BSOD at the same point.  Please note that I have been using this computer for 2 years without every getting a BSOD and every time I run the software, and it is trying to connect to the recommended servers, the BSOD occurs.

 

I am a .NET programmer so I fully understand how the framework works, but the fact the the BSOD is occurring every single time I run the software, and always at the same point, leads me to believe (however unlikely or indirectly) that the software, or something that the software installs, is somehow triggering the BSOD.  Could it be the TAP-Windows Provider V9 Network adapters, that the software installs, is the cause of this issue?

 

I really like the service and would like to use it regularly but having a BSOD occur every time I try to connect to the servers on my main Windows machine is a showstopper.  Is there any other suggestions or troubleshooting steps you can recommend?

 

Thank You

Share this post


Link to post

Hello,

 

let's remain to the system message, because "TAP driver" runs in millions of Windows machines without causing page faults. If you can rule out any low level driver problem, the message suggests that you have some other problem in your system. Searching for:

bsod Page_Fault_In_Non_Paged_Area netio.sys

 

in Google Search returns 4400 results. The first returned pages are interesting, hopefully they can give you some useful hint to solve the problem.

 

Kind regards

Share this post


Link to post

Did you overclock your machine ? Sometimes overclocking the CPU causes such kind of BSODs out of the blue. At least by my personal experience...

 

Regards

 

Fox

Share this post


Link to post

which AV is installed ? which firewall ? if adguard disable the WPF driver for Windows apps  inside of addguard 

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Security Check
    Play CAPTCHA Audio
    Refresh Image
Sign in to follow this  

×
×
  • Create New...