Jump to content
Not connected, Your IP: 34.238.190.122
Aaronson

Eddie (AirVPN client) freezes after sleep - OSx

Recommended Posts

Same here and I wish that Eddie would be stable as it's otherwise a great client. (Sure, I'd like the option to store the password so an auto reboot wouldn't require me to be around to sign in).

Share this post


Link to post

Hey everyone, 

 

 

Not sure if that interests anyone, but I made a small applescript in Automator that launches Eddie without using its GUI. I m sure there are more elegant ways of coding this, but it does the job and doesn't seem to crash after waking up... so far.

I added it as a login item in preferences so no need to manually launch it at startup. On the plus side, you don't need to enter your password as it is stored within the script (you'll need to amend the script by replacing "password" with your own). 

You can also play around with delay times if you want it to launch faster. 

 

on run {input, parameters}
	tell application "Terminal"
		activate
	end tell
	
	delay 3 -- seconds  
	
	tell application "System Events"
		keystroke "n" using command down
		delay 2
		keystroke "sudo /Applications/Eddie.app/Contents/MacOS/Eddie -cli"
		keystroke return
		delay 1
		keystroke "password"
		keystroke return
		delay 3
		keystroke "c..."
		delay 2
		keystroke "o..."
	end tell
end run

To terminate Eddie, just navigate to the Terminal window and use CTRL-C. As I m lazy, I wrote another small script that does it for me (it also quits Terminal).

 

on run {input, parameters}
	tell application "Terminal"
		activate
	end tell
	
	delay 3 -- seconds  
	
	tell application "System Events"
		keystroke "2" using command down
		delay 1
		keystroke "c" using control down
		delay 4
		keystroke "q" using command down
	end tell
end run

Share this post


Link to post

I have the same issue for a while ... which is quite annoying. Running macOS 10.12.5 and Eddie 2.12.4 ... after my Macbook went to Standby and I'm logging in again, Eddie is frozen ("spinning beachball") and I have to force quit the app to start Eddie again.

 

l65i9nxl.jpg

 

Any input from the Staff on this?

Share this post


Link to post

 

Hey everyone, 

 

 

Not sure if that interests anyone, but I made a small applescript in Automator that launches Eddie without using its GUI. I m sure there are more elegant ways of coding this, but it does the job and doesn't seem to crash after waking up... so far.

I added it as a login item in preferences so no need to manually launch it at startup. On the plus side, you don't need to enter your password as it is stored within the script (you'll need to amend the script by replacing "password" with your own). 

You can also play around with delay times if you want it to launch faster. 

 

on run {input, parameters}
	tell application "Terminal"
		activate
	end tell
	
	delay 3 -- seconds  
	
	tell application "System Events"
		keystroke "n" using command down
		delay 2
		keystroke "sudo /Applications/Eddie.app/Contents/MacOS/Eddie -cli"
		keystroke return
		delay 1
		keystroke "password"
		keystroke return
		delay 3
		keystroke "c..."
		delay 2
		keystroke "o..."
	end tell
end run

To terminate Eddie, just navigate to the Terminal window and use CTRL-C. As I m lazy, I wrote another small script that does it for me (it also quits Terminal).

 

on run {input, parameters}
	tell application "Terminal"
		activate
	end tell
	
	delay 3 -- seconds  
	
	tell application "System Events"
		keystroke "2" using command down
		delay 1
		keystroke "c" using control down
		delay 4
		keystroke "q" using command down
	end tell
end run

 

Just to update this, I have been using this GUI-less solution for over a week and no crash so far. It also automatically re-connects to different wifi networks without issues, something that Eddie & its predecessor had some trouble achieving (i.e close your laptop - goes to sleep, go to friend's house / work, awake laptop, re-connects without issue).

 

The only problem is making sure airvpn is active. For that, I just check iplocation.net .

Share this post


Link to post

Just chipping in to say that I have this problem with Eddie hanging, and it isn't necessarily after long periods of use or after sleep. On one occasion, I launched Eddie, connected to a server, disconnected a few minutes later (I'm in China and often need only short connections), then after a few minutes Eddie froze. My machine didn't sleep or go to screensaver during this time. It does seem to have something to do with the ping times being enabled. However I can't really turn them off permanently since my pings vary wildly from day to day and my situation (China) requires frequent switching of servers.

 

Appreciate all the efforts from those making scripts. For those recommending a downgrade, I'd reply that this has possible security implications.

Share this post


Link to post

Switching to UDP Port 443 seems to have solved the problem for me on my MacBook Retina running 10.12.5.

 

Go to Eddie-->Preferences-->Protocols

Highlight UDP 443.

Hit Save.

Re-boot Eddie.

Share this post


Link to post

I also have the same problem with Eddie.  Latest macOS.

 

I have to Force Quit Eddie every time I wake my Mac and then restart the app.  

It is a PITA - not on a 'solving world hunger' sort of level, but annoying none the less.

Share this post


Link to post

 

 

Hey everyone, 

 

 

Not sure if that interests anyone, but I made a small applescript in Automator that launches Eddie without using its GUI. I m sure there are more elegant ways of coding this, but it does the job and doesn't seem to crash after waking up... so far.

I added it as a login item in preferences so no need to manually launch it at startup. On the plus side, you don't need to enter your password as it is stored within the script (you'll need to amend the script by replacing "password" with your own). 

You can also play around with delay times if you want it to launch faster. 

 

on run {input, parameters}
	tell application "Terminal"
		activate
	end tell
	
	delay 3 -- seconds  
	
	tell application "System Events"
		keystroke "n" using command down
		delay 2
		keystroke "sudo /Applications/Eddie.app/Contents/MacOS/Eddie -cli"
		keystroke return
		delay 1
		keystroke "password"
		keystroke return
		delay 3
		keystroke "c..."
		delay 2
		keystroke "o..."
	end tell
end run

To terminate Eddie, just navigate to the Terminal window and use CTRL-C. As I m lazy, I wrote another small script that does it for me (it also quits Terminal).

 

on run {input, parameters}
	tell application "Terminal"
		activate
	end tell
	
	delay 3 -- seconds  
	
	tell application "System Events"
		keystroke "2" using command down
		delay 1
		keystroke "c" using control down
		delay 4
		keystroke "q" using command down
	end tell
end run

 

Just to update this, I have been using this GUI-less solution for over a week and no crash so far. It also automatically re-connects to different wifi networks without issues, something that Eddie & its predecessor had some trouble achieving (i.e close your laptop - goes to sleep, go to friend's house / work, awake laptop, re-connects without issue).

 

The only problem is making sure airvpn is active. For that, I just check iplocation.net .

 

I can also recommend Little Snitch (very customisable Firewall which can be set up to block all traffic except over AirVPN). I will try the GUI-less approach, when it works it would be great (so thanks in advance!), although it's hardly an elegant solution.

Share this post


Link to post

Switching to UDP Port 443 seems to have solved the problem for me on my MacBook Retina running 10.12.5.

 

Go to Eddie-->Preferences-->Protocols

Highlight UDP 443.

Hit Save.

Re-boot Eddie.

 

Does not change anything for me ...  Also, I doubt that this issue on macOS is in any way relevant to a specific protocol and/or port.

Share this post


Link to post

 

Switching to UDP Port 443 seems to have solved the problem for me on my MacBook Retina running 10.12.5.

 

Go to Eddie-->Preferences-->Protocols

Highlight UDP 443.

Hit Save.

Re-boot Eddie.

Does not change anything for me ...  Also, I doubt that this issue on macOS is in any way relevant to a specific protocol and/or port.

That's too bad. I'm not sure why it worked for me but it did and is still working fine. Since I changed the port, I have had no problems with Eddie disconnecting and then getting stuck in endless reconnect loops.

I also deleted everything Sophos from my computer too around the same time.

I hope you can figure out your connection problems soon.

Share this post


Link to post

Hello!

 

All the persons who experience this problem can test Eddie 2.13beta now.

 

Kind regards

 

Hi,

 

first thing I noticed it still ignores the custom OpenVPN path. Could you please have a look at it?

 

Thanks.

Share this post


Link to post
Guest
This topic is now closed to further replies.

×
×
  • Create New...