Jump to content
Not connected, Your IP:
Sign in to follow this  

Just joined, extremely slow speed, 95+% drop in Mbps, am I missing anything?

Recommended Posts

Hi everybody,


First off, I'm a bit of a VPN newbie - I've researched loads of various possible VPN providers and settled on AirVPN due to great reviews from real people (not stooges as far as I can tell), and an emphasis on privacy on community. These are more important to me than flashy big companies and promises.


I've *just* joined AirVPN, chose the yearly pack due to the discount that ends today (and honestly I'm happy to give to a community like this, even if AirVPN doesn't work out in the log run, it was a conscious and informed decision to go the yearly route).


My issue is that I'm getting extremely slow speeds having just installed the client. I've selected a few of the more recommended/speedier servers based on forums both here and other places online, and it's still very, very slow on all of them.


I've searched forums but there really isn't many posts about slow speeds that I can find.


I'm in Australia on cable internet. My non-VPN speed averages 30-35 Mbps. When the VPN is connected the highest speed I've had is 1.8 Mbps.


My PC is decent - i5 2.8Ghz, 24GB RAM, Win 7 64 bit. I'm using the AirVPN client to connect using Automatic settings and Automatic Server (but have swapped around since to try to find faster locations).


Not sure what else to say. I've got Comodo firewall which I've seen causes some issues sometimes with VPNs but I've allowed the relevant .exe and ports through and made the AirVPN client a Trusted Application.


Is there something I'm missing? What could I try so that I can get better speeds? I've heard from other Australians that they can get 20-25 Mbps, so being under 2 Mbps makes me think it might be me, that I've done something wrong or not done something extra, or at least that it's on my end.


Sorry for posting this as my first post.. I only get 1 post a day at the moment so I wanted to see if there was any help or tips people could provide before I can post back tomorrow. Not sure what other info is required - again, I'm not VPN savvy.


Thanks in advance, I very much appreciate any help!



Share this post

Link to post


As a first attempt please try to enlarge OpenVPN send and receive buffers.

In "AirVPN" -> "Preferences" -> "Advanced" -> "OVPN Directives" menu add the following lines in the "Custom" field:
sndbuf 524288
rcvbuf 524288

Click "Save", try a new VPN connection (test different servers) and check whether there's any improvement in performance or not.

Please feel free to keep us posted at your convenience.

Kind regards

Share this post

Link to post



It seems like I've had the same behaviour since I updated my windows 7 64 AirVPN client yesterday to 2.9.2. Or may be it's just a coincidence...

I used to have a very good bandwidth for both download and upload.


A simple look at my speed test will show you my problem on download :

Down: 31.092 Mbit/s Out, 0.835 Mbit/s In (2%), 20MB - Up: 41.005 Mbit/s Out, 25.494 Mbit/s In (62%), 20MB - Date: Tue, 02 Jun 2015 17:10:48 GMT - Buffers: 20MB/20MB - Laps: 1, Time: 107.36 secs


I didn't change my config, I just updated the client.

Updating sndbuf and rcvbuf settings as mentionned didn't fix the issue.


Thanks for your help.


Kind Regards

Share this post

Link to post

If the above doesn't change things significantly  (I recommend the above anyway even if it doesn't).


While a might be a pain for you, you might to try rolling back the latest tap-adapter driver from (installed with eddy v2.9) to that you can find on the open vpn site or in the older Eddy 2.8 client.  This has resolved this issue for a few users, all of whom so far seem to be on win 7\ or srv2008r2 x64, the latest driver should actually be providing better performance in most cases but apparently is not for a select few.


This is what I did anyway as I couldn't easily locate the old ndis6 driver on the openvpn site.

https://airvpn.org/windows/  click other version, change to 2.8 grab that fileset.

uninstalled Eddy 2.9

installed Eddy 2.8

Grab the tap-windows.exe from the Eddy 2.8 installed folder copied it somewhere else.

re-installed 2.9; opened it once and connected.

disconnected and closed eddy.

Ran %programfiles%\tap-windows\uninstall.exe  (removes version of the driver)

Ran the previous copied older tap-windows.exe which will install the version of the ndis6 driver.

The newer version of the eddy client 2.9 should then work just fine even using the older driver.

Share this post

Link to post

Thanks for the replies!


I think I'm behind the black ball living in Australia for this, but definitely willing to try anything to get AirVPN to acceptable levels.


The send and receive buffers are now set to 524288


I tried your suggestions, knighthawk, but the new Eddie client always installs the latest tap-adapter driver (9.21) when I try to connect. If I leave it as is, the 9.21 driver always gets installed as soon as I click connect (it says "installing tunnel driver" before anything else). ie If I check the installed version before clicking connect then I can see it is 9.9, and after clicking connect it is 9.21.


Tried exiting Eddie a few times and uninstalling/reinstalling the tapi driver but it always just updates it when I connect. Replacing the tap-windows.exe file in the 2.9 client folder with the 9.9 exe from Eddie 2.8 gets a failed driver install and thus no connection. 


Rolling back and just using Eddie 2.8 as the client with 9.9 tap-adapter yields the same speeds overall Eddie 2.9  - tested a few different servers and they all have around these speeds, give or take a few 100 Kbits, regardless of which Eddie version I use:


With VPN (various server selections across US/Canada, Asia, Europe):

Down: 1.424 Mbit/s Out, 1.491 Mbit/s In (104%), 1MB - Up: 0.607 Mbit/s Out, 0.693 Mbit/s In (114%), 1MB - Date: Thu, 04 Jun 2015 14:01:05 GMT - Buffers: 1MB/1MB - Laps: 3, Time: 132.69 secs
Down: 1.710 Mbit/s Out, 1.553 Mbit/s In (90%), 1MB - Up: 0.624 Mbit/s Out, 0.690 Mbit/s In (110%), 1MB - Date: Thu, 04 Jun 2015 14:12:10 GMT - Buffers: 1MB/1MB - Laps: 1, Time: 51.13 secs

Down: 0.641 Mbit/s Out, 0.955 Mbit/s In (148%), 1MB - Up: 0.474 Mbit/s Out, 0.299 Mbit/s In (63%), 1MB - Date: Thu, 04 Jun 2015 14:19:10 GMT - Buffers: 1MB/1MB - Laps: 1, Time: 88.61 secs

Down: 0.620 Mbit/s Out, 0.572 Mbit/s In (92%), 1MB - Up: 0.326 Mbit/s Out, 0.329 Mbit/s In (100%), 1MB - Date: Thu, 04 Jun 2015 14:38:22 GMT - Buffers: 1MB/1MB - Laps: 1, Time: 109.01 secs

Without VPN:



I've read that the Singapore server is best for Australians, however it's the same overall speed as those logs.


For comparison, just so you know it's not my ISP, I've signed up for an alternative US-based VPN service and get ~20Mbit to Sydney servers (but don't want to use Australian servers by default because they'll probably end out having to log things due to the new laws) and ~9Mbit for US (Phoenix) servers. While 9Mbit is still a bit slower than I'd prefer, I'm quite fine with that speed if my online activity is private as a result. Obviously, faster would be better .. and I'd prefer to stay with a community- and privacy-focused VPN provider than a US-based standard business model. 


Any other potential fixes or things I can check to improve performance?


Cheers again, and thanks for the help so far!

Share this post

Link to post

Have you tried the experimental client? The changelog includes a point that might be of interest to you:


[change] Windows - Added option 'Advanced -> General -> Windows Only -> Disable Driver Upgrade'

Share this post

Link to post



@GleeBee - I'm sorry to hear that, maybe it is more of a isp\ finding the right tcp\upd\ ssl tunnel\ port based combo problem in your case.

I must have done some other jacked up step that I forgot related to 2.9 with the 9.0.9 driver though I recall the issues you speak of, maybe I ran the client first and then replaced it and removed permissions, though I think I would have remembered that. 


@blackeyed - That problem sounds much more like the driver issue and exactly what happened to me, try just fully rolling back to eddy 2.8 (safest option anyway) or as someone mentioned you could try 2.10 experimental, see if your normal speed return. 

Share this post

Link to post

Hi everybody,


Yes I got the same behaviour as you GleeBee, the 2.9 client updates the tap-windows driver eventually... And if you try to fool the client with the old driver installer, the driver installation fails anyway...

I had to downgrade to client 2.8 to have everything back to normal. I'll try the experimental and give my feedback, I had not seen this one.


Thank you.

Share this post

Link to post

The Experimental Client checkbox to disable driver upgrade definitely works, I'm now running the older TAP version 9.9.2, which is great news for the next release.. however it hasn't helped my speed issues as yet:


Still getting the same speeds as before.


I just read on a forum that people were significantly fixing their speed issues by using Viscosity VPN - is that supported with AirVPN, and is there anything else I can do with Eddie that might help?

Share this post

Link to post

I'm going to mark this as solved, but really the solution is that there's no solution. If you're in Australia, you'd be lucky to get 5Mbps from any of the servers I tried. I'll keep tabs on server upgrades or installations and keep checking over the next year. Will try to remember to post here if I find out any more info or something extra that helps.


Cheers and thanks for the help guys!

Share this post

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Security Check
    Play CAPTCHA Audio
    Refresh Image
Sign in to follow this  

  • Create New...