Jump to content
Not connected, Your IP: 52.90.49.108
Sign in to follow this  
gijo

ANSWERED Unable to connect using DD-WRT (TLS_ERROR)

Recommended Posts

I am using DD-WRT v24-sp2 (01/04/15) big on a Linksys E1200v2.

 

I wanted to connect to Acrux server in Netherlands (37.48.81.12) by UDP on 443.

I followed the instruction provided here: https://airvpn.org/ddwrt/

but I have an error in my OpenVPN log.

 

Clientlog: 

20150108 22:47:39 N TLS_ERROR: BIO read tls_read_plaintext error: error:140830B5:lib(20):func(131):reason(181) 

20150108 22:47:39 N TLS Error: TLS object -> incoming plaintext read error 

20150108 22:47:39 N TLS Error: TLS handshake failed 

20150108 22:47:39 I SIGUSR1[soft tls-error] received process restarting 

20150108 22:47:39 Restart pause 2 second(s) 

20150108 22:47:41 W NOTE: the current --script-security setting may allow this configuration to call user-defined scripts 

[...]

 

ca /tmp/openvpncl/ca.crt cert /tmp/openvpncl/client.crt key /tmp/openvpncl/client.key management 127.0.0.1 16 management-log-cache 100 verb 3 mute 3 syslog writepid /var/run/openvpncl.pid client resolv-retry infinite nobind persist-key persist-tun script-security 2 dev tun1 proto udp cipher aes-256-cbc auth sha1 remote 37.48.81.12 443 comp-lzo yes tls-client tun-mtu 1500 mtu-disc yes ns-cert-type server fast-io tun-ipv6 tls-auth /tmp/openvpncl/ta.key 1 tls-cipher TLS-DHE-RSA-WITH-AES-256-CBC-SHA256

 

Am I doing some mistake or do you have any idea?

 

Thanks.

Share this post


Link to post

Hello!

 

Wrong TLS cipher: TLS-DHE-RSA-WITH-AES-256-CBC-SHA256

 

Try with "None". If it does not work try with "TLS-DHE-RSA-WITH-AES-128-CBC-SHA". Both are wrong as well but for some bug in several DD-WRT builds either the first OR the second work.

 

Kind regards

Share this post


Link to post

Hello!

 

Wrong TLS cipher: TLS-DHE-RSA-WITH-AES-256-CBC-SHA256

 

Try with "None". If it does not work try with "TLS-DHE-RSA-WITH-AES-128-CBC-SHA". Both are wrong as well but for some bug in several DD-WRT builds either the first OR the second work.

 

Thanks, it did not work with "None" but was ok with "TLS-DHE-RSA-WITH-AES-128-CBC-SHA".

 

Thanks very much for you quick reply.

 

Bests

 

 

Kind regards

Share this post


Link to post

Hi,

 

Had the same issue with configuring my new router. I can confirm that changing the TLS setting to "TLS-DHE-RSA-WITH-AES-128-CBC-SHA" works just fine!

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Security Check
    Play CAPTCHA Audio
    Refresh Image
Sign in to follow this  

×
×
  • Create New...