Jump to content
Not connected, Your IP: 3.235.75.174
Sign in to follow this  
Guest Hammie5150

DD-WRT Setup for Netgear R7000

Recommended Posts

Guest Hammie5150

Hello!

 

"LZO Compression" must be set to "Yes"

 

"Static key" must be empty.

 

"TLS Auth" key is missing (paste there ta.key)

 

After the above modifications, change "TLS Cipher": try with "None" and if it fails try with "TLS-DHE-RSA-WITH-AES-128-CBC-SHA" (both are wrong but for some reason most DD-WRT builds will work with one of the two settings).

 

Kind regards

Share this post


Link to post
Guest Hammie5150

Thanks for the instructions.  I applied them and now the log says "success" but I cannot get any data through the pipe, so it's not working right.  I attached the config and log capture this time.  For info, it didn't seem to make a difference between "None" and "TLS-DHE-RSA-WITH-AES-128-CBC-SHA."  Also, all my keys are in one big file on the Mac.  I do not have separate files for each key, so I am guessing which one is which based upon the HTML tags at the front of the keys.  Please tell me if I'm putting the wrong ones in the boxes.

 

Thanks!

 

 

 

 

Share this post


Link to post

Hello!

 

For clarity, we recommend that you tick "Advanced Mode" in Configuration Generator and then you tick "Separate certs/keys from .ovpn file".

 

user.crt is the client certificate

ca.crt is the CA certificate

ta.key is the TLS Auth key

user.key is the client key

 

Moreover: change "NAT" to "Enabled" (VERY important) and "Bridge TAP" to "Disabled".

 

Check your iptables rules and make sure that the tun interface name is correct (verify it with command "ifconfig"). On some builds it's tun0, on other ones tun1 by default.

 

Kind regards

Share this post


Link to post
Guest Hammie5150

Thanks for the info.  I am now able to connect and pass traffic, verified through the VPN.  The traffic is extremely slow, and latency is amazing.  I am using the standard UDP configuration on the US servers.  Are there any optimizations that I could do to speed up the traffic and (more importantly) reduce latency?  My DD-WRT log is again attached.

 

AirVPN Connection Log - DDWRT.tiff

Share this post


Link to post

I have this on my Netgear Knighthawk too using the dd-wrt firmware.  It works great, and everytime I try to catch it not working it shows that its working...

 

However from time to time I noticed that when I check the "status" page for AirVPN It'll reset the connection anywhere from every couple days to every few hours...

 

My question is:

While the connection is resetting, if I were to do an "icanhazip.com" or "ifconfig.me" would I be able to reach the internet at all with my real IP address? 

 

So far, like I said it's always told me the AIR IP address, I just want to know if there is anymore implementation I can add as a "failsafe" to not allow a device/machine to access the internet unless it's through the VPN.

 

Thanks...

Share this post


Link to post

My question is:

While the connection is resetting, if I were to do an "icanhazip.com" or "ifconfig.me" would I be able to reach the internet at all with my real IP address?

 

Yes.

Share this post


Link to post

Hi,

 

I'm having the same trouble as Guest_Hammie had a year ago.  Not getting any data flow through.  I've tried everything suggested above but to no avail.  I've jumped onto a different router, went to Air without a VPN, checked the Client Area and is indeed telling me that my R7000 is logged into one of the American servers ... but when I get back to it ... no data flow.  I've also changed the tun0 to tun1 in the firewall to see if that made a difference, but seemingly no.  

 

Please let me know, would love all the help  and thank you in advance,

 

Here are some screen shots:

 

Share this post


Link to post

So... in addition I jut ran an experiment.  TO be clear with my problem above I have a R7000 hooked up to a Modem/Router DGND3700.  Seeing as when I configure dd-wrt's OpenVPN with AirVPN, with what I believe to be the correct info ... I decided to turn off the wifi's and hardwire myself into the R7000 and run the Eddie client from my computer to see if I can log into one of the servers.  

 

It keeps failing to establish a route after connecting to one of the servers.

 

So I'm thinking there might be a parallel here? I can connect to any server straight from the DGND3700 Modem Router with no problem, but it's simply a no go with the R7000 attached (dd-wrt OpenVpn, or with Eddie client) .... Am I doing something wrong?

 

I'm trying to have two networks.  One that is from the DGNDR3700 Modem/Router for everyday stuff, the other on the R7000 to have AirVPN .... don't know what I'm doing wrong ...

 

Cheers for any help. 

Share this post


Link to post

@swiss

Try tls cipher aes128 and on Setup Page try Google staticdns1 8.8.8.8 and staticdns2 8.8.4.4

Share this post


Link to post

Hey dj77, 

 

Tried it .. not working.  Changed the staticdns1 and staticdns2 then tried with both the tis cypher on none and then on aes128 ... not working.  But massive cheers.

Share this post


Link to post

Hey dj77,

 

Support team figured it out.  It's all working now, was a tunnel MTU setting that needed tweaking.

Again cheers for the help. 

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Security Check
    Play CAPTCHA Audio
    Refresh Image
Sign in to follow this  

×
×
  • Create New...