Jump to content
Not connected, Your IP: 54.80.173.217
Sign in to follow this  
Guest user1984

ANSWERED openvpn not display websites on linux

Recommended Posts

Guest user1984

Hi,

 

On windows 8, home computer, all is OK, airvpn good speed... but...

On laptop linux (arch), sometime some websites display slowly (google), but most websites does not display.

(Its the same line, internet box, ISP)

 

I try with various protocols and various ports (udp 443, tcp 443 ...53) but nothing...

 

My config file :

 

client
dev tun
proto udp
remote earth.vpn.airdns.org 53
resolv-retry infinite
nobind
ns-cert-type server
cipher AES-256-CBC
comp-lzo
verb 3
explicit-exit-notify 5
ca "etc/openvpn/ca.crt"
cert "etc/openvpn/user.crt"
key "etc/openvpn/user.key"

 

I lauched openvpn :

 

# openvpn /etc/openvpn/airvpn_UDP_53.ovpn

 

Tue Sep 24 09:59:14 2013 OpenVPN 2.3.2 x86_64-unknown-linux-gnu [sSL (OpenSSL)] [LZO] [EPOLL] [eurephia] [MH] [iPv6] built on Jun  9 2013 
Tue Sep 24 09:59:14 2013 Socket Buffers: R=[212982->131062] S=[212982->131062] 
Tue Sep 24 09:59:14 2013 UDPv4 link local: [undef] 
Tue Sep 24 09:59:14 2013 UDPv4 link remote: [AF_INET]181.74.203.161:53 
Tue Sep 24 09:59:14 2013 TLS: Initial packet from [AF_INET]181.74.203.161:53, sid=bd1c2aa8 deb44c102 
Tue Sep 24 09:59:15 2013 VERIFY OK: depth=1, C=IT, ST=IT, L=Perugia, O=airvpn.org, CN=airvpn.org CA, emailAddress=info@airvpn.org 
Tue Sep 24 09:59:15 2013 VERIFY OK: nsCertType=SERVER 
Tue Sep 24 09:59:15 2013 VERIFY OK: depth=0, C=IT, ST=IT, L=Perugia, O=airvpn.org, CN=server, emailAddress=info@vpninfo.org 
Tue Sep 24 09:59:17 2013 Data Channel Encrypt: Cipher 'AES-256-CBC' initialized with 256 bit key 
Tue Sep 24 09:59:17 2013 Data Channel Encrypt: Using 160 bit message hash 'SHA1' for HMAC authentication 
Tue Sep 24 09:59:17 2013 Data Channel Decrypt: Cipher 'AES-256-CBC' initialized with 256 bit key 
Tue Sep 24 09:59:17 2013 Data Channel Decrypt: Using 160 bit message hash 'SHA1' for HMAC authentication 
Tue Sep 24 09:59:17 2013 Control Channel: TLSv1, cipher TLSv1/SSLv3 DHE-RSA-AES256-SHA, 2048 bit RSA 
Tue Sep 24 09:59:17 2013 [server] Peer Connection Initiated with [AF_INET]181.74.203.161:53 
Tue Sep 24 09:59:19 2013 SENT CONTROL [server]: 'PUSH_REQUEST' (status=1) 
Tue Sep 24 09:59:19 2013 PUSH: Received control message: 'PUSH_REPLY,redirect-gateway def1,dhcp-option DNS 10.7.0.1,comp-lzo no,route 10.7.0.1,topology net30,ping 10,ping-restart 60,ifconfig 10.7.1.97 10.7.1.96 
Tue Sep 24 09:59:19 2013 OPTIONS IMPORT: timers and/or timeouts modified 
Tue Sep 24 09:59:19 2013 OPTIONS IMPORT: LZO parms modified 
Tue Sep 24 09:59:19 2013 OPTIONS IMPORT: --ifconfig/up options modified 
Tue Sep 24 09:59:19 2013 OPTIONS IMPORT: route options modified 
Tue Sep 24 09:59:19 2013 OPTIONS IMPORT: --ip-win32 and/or --dhcp-option options modified 
Tue Sep 24 09:59:19 2013 ROUTE_GATEWAY 192.168.0.254/255.255.255.0 IFACE=enp3s0f2 HWADDR=b2:35:42:c1:a3:47 
Tue Sep 24 09:59:19 2013 TUN/TAP device tun0 opened 
Tue Sep 24 09:59:19 2013 TUN/TAP TX queue length set to 100 
Tue Sep 24 09:59:19 2013 do_ifconfig, tt->ipv6=0, tt->did_ifconfig_ipv6_setup=0 
Tue Sep 24 09:59:19 2013 /usr/bin/ip link set dev tun0 up mtu 1500 
Tue Sep 24 09:59:19 2013 /usr/bin/ip addr add dev tun0 local 10.7.1.97 peer 10.7.1.96 
Tue Sep 24 09:59:19 2013 /usr/bin/ip route add 181.74.203.161/32 via 192.168.0.254 
Tue Sep 24 09:59:19 2013 /usr/bin/ip route add 0.0.0.0/1 via 10.7.1.96 
Tue Sep 24 09:59:19 2013 /usr/bin/ip route add 128.0.0.0/1 via 10.7.1.96 
Tue Sep 24 09:59:19 2013 /usr/bin/ip route add 10.7.0.1/32 via 10.7.1.96
Tue Sep 24 09:59:19 2013 Initialization Sequence Completed 

Can you help me please ?

Share this post


Link to post

Hello!

 

The logs are fine. Can you please send us the output of the following commands (while the system is connected to a VPN server):

 

ping 10.4.0.1

traceroute google.com

ping 8.8.8.8

 

Kind regards

Share this post


Link to post
Guest user1984
# ping 10.4.0.1 
PING 10.4.0.1 (10.4.0.1) 56(84) bytes of data. 
64 bytes from 10.4.0.1: icmp_seq=1 ttl=64 time=47.5 ms 
64 bytes from 10.4.0.1: icmp_seq=2 ttl=64 time=47.1 ms 
64 bytes from 10.4.0.1: icmp_seq=3 ttl=64 time=46.6 ms 
64 bytes from 10.4.0.1: icmp_seq=4 ttl=64 time=46.4 ms 
64 bytes from 10.4.0.1: icmp_seq=5 ttl=64 time=48.1 ms 
64 bytes from 10.4.0.1: icmp_seq=6 ttl=64 time=46.7 ms 
64 bytes from 10.4.0.1: icmp_seq=7 ttl=64 time=47.2 ms 
64 bytes from 10.4.0.1: icmp_seq=8 ttl=64 time=47.5 ms 
64 bytes from 10.4.0.1: icmp_seq=9 ttl=64 time=47.1 ms 
^Z 

# ping 8.8.8.8 
PING 8.8.8.8 (8.8.8.8) 56(84) bytes of data. 
64 bytes from 8.8.8.8: icmp_seq=1 ttl=50 time=51.5 ms 
64 bytes from 8.8.8.8: icmp_seq=3 ttl=50 time=52.2 ms 
64 bytes from 8.8.8.8: icmp_seq=4 ttl=50 time=52.9 ms 
64 bytes from 8.8.8.8: icmp_seq=5 ttl=50 time=51.9 ms 
64 bytes from 8.8.8.8: icmp_seq=6 ttl=50 time=51.4 ms 
64 bytes from 8.8.8.8: icmp_seq=7 ttl=50 time=51.9 ms 
64 bytes from 8.8.8.8: icmp_seq=8 ttl=50 time=51.4 ms 
64 bytes from 8.8.8.8: icmp_seq=9 ttl=50 time=56.0 ms 
^Z 

# traceroute google.com 
google.com: Name or service unknown
Cannot handle "host" cmdline arg `google.com' on position 1 (argc 1) 

 

Share this post


Link to post
Guest user1984

/etc/resolv.conf file includes the line:

 

nameserver 10.4.0.1

 

The problem is solved.

 

Thanks !

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Security Check
    Play CAPTCHA Audio
    Refresh Image
Sign in to follow this  

×
×
  • Create New...