Jump to content


Photo

OpenVPN Config not working on multiple devices

openvpn arch android linux error hostname host

  • Please log in to reply
3 replies to this topic

#1 mateudz

mateudz

    Newbie

  • New Members
  • Pip
  • 2 posts

Posted 01 February 2018 - 11:49 AM

Hello,

I recently installed Antergos Linux (Arch Linux) on my main Computer and my Laptop. So I downloaded the Config files and tried to run them with the default openvpn. I cannot establish a connection. The resulting error is:

 

Thu Feb  1 12:47:55 2018 OpenVPN 2.4.4 x86_64-unknown-linux-gnu [SSL (OpenSSL)] [LZO] [LZ4] [EPOLL] [PKCS11] [MH/PKTINFO] [AEAD] built on Sep 26 2017
Thu Feb  1 12:47:55 2018 library versions: OpenSSL 1.1.0g  2 Nov 2017, LZO 2.10
Thu Feb  1 12:47:55 2018 Outgoing Control Channel Authentication: Using 160 bit message hash 'SHA1' for HMAC authentication
Thu Feb  1 12:47:55 2018 Incoming Control Channel Authentication: Using 160 bit message hash 'SHA1' for HMAC authentication
Thu Feb  1 12:47:55 2018 RESOLVE: Cannot resolve host address: switzerland.vpn.airdns.org:443 (Name or service not known)
Thu Feb  1 12:47:55 2018 RESOLVE: Cannot resolve host address: switzerland.vpn.airdns.org:443 (Name or service not known)
Thu Feb  1 12:47:55 2018 Could not determine IPv4/IPv6 protocol
Thu Feb  1 12:47:55 2018 SIGUSR1[soft,init_instance] received, process restarting
Thu Feb  1 12:47:55 2018 Restart pause, 5 second(s)

 

I tried it on my Android device where I also have the config files from before a month. The old ones are working, the new ones don't. Maybe someone has the same problem or a solution? The Problem occurs also when I download another protocol-config or change the Server/State.

 

Thanks

 

 



#2 avpnclient

avpnclient

    Newbie

  • New Members
  • Pip
  • 4 posts

Posted 01 February 2018 - 12:08 PM

I just made a post about it, but it seems that you have the same issue.

I also posted a solution. The old configs use <country code>.vpn.airdns.org, so to fix you problem use "remote ch.vpn.airdns.org 443".

The new configs use domains without valid DNS records.



#3 mateudz

mateudz

    Newbie

  • New Members
  • Pip
  • 2 posts

Posted 01 February 2018 - 12:47 PM

Thanks, that worked for me to establish the connection.

 

Maybe some mods see it and change the generating-algorithm.

 

Edit: Well, now I have a connection, but any Country I try the sequenz initiliazises succesfuly but I have no internet. I cannot access Website nor ping the airvpn.org site. Maybe there are some more things broken with the new config files.



#4 jgalt

jgalt

    Member

  • Members
  • PipPip
  • 20 posts

Posted 03 February 2018 - 01:54 AM

.







Similar Topics Collapse


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

Servers online. Online Sessions: 14024 - BW: 36448 Mbit/sYour IP: 54.162.227.37Guest Access.