Jump to content


Photo

DNS issues when using AirVPN on Router


  • Please log in to reply
8 replies to this topic

#1 ToastyTheEel

ToastyTheEel

    Member

  • Members
  • PipPip
  • 15 posts

Posted 01 October 2017 - 02:49 AM

AirVpn has been working wonderfully, via Eddie on a Win7 machine, using a VPN app on two android tablets, and via OpenVPN configuration files on my Asus router.  However, I can't get it to work on the router recently, and I haven't changed anything.  When I change my router's DNS server from auto to the standard AirVPN DNS server as the primary and one chosen from openNIC for the secondary, I can no longer access the internet and sometimes can't even get logged back onto my router to fix things.  What's going on?  I've always just switched from the DNS auto setting to the manual setting for the AirVPN DNS server, then activated the OpenVPN config file of my choice loaded onto the router (created by using this site's config page).  Never had a hassle.  Now, it breaks the internet.  It's broken now, but for some reason it's letting me access the airvpn site.. here... and nothing else?!?!  I can't even get on my router.   HELP!

 



#2 go558a83nk

go558a83nk

    Advanced Member

  • Members2
  • PipPipPip
  • 1706 posts

Posted 01 October 2017 - 01:32 PM

Are you using Merlin Asus firmware?



#3 ToastyTheEel

ToastyTheEel

    Member

  • Members
  • PipPip
  • 15 posts

Posted 02 October 2017 - 12:35 PM

No, the stock firmware.  I doubt that's the issue...it's been working fine with AirVPN up until recently.



#4 go558a83nk

go558a83nk

    Advanced Member

  • Members2
  • PipPipPip
  • 1706 posts

Posted 02 October 2017 - 01:04 PM

No, the stock firmware.  I doubt that's the issue...it's been working fine with AirVPN up until recently.

 

 

That's not why I asked. :)  Merlin firmware is good and gives you actual options in the openvpn client setup, including policy routing and "killswitch".  If you used Merlin I would tell you how I suggest you settle the DNS problem.



#5 ToastyTheEel

ToastyTheEel

    Member

  • Members
  • PipPip
  • 15 posts

Posted 03 October 2017 - 11:55 AM

Ok.....but....what's the problem?!?!  Why can Eddie on Win7 and OpenVpnConnect on Android connect to dns server 10.4.0.1, but my router can't, even though it used to be able to? What's the mystery?



#6 go558a83nk

go558a83nk

    Advanced Member

  • Members2
  • PipPipPip
  • 1706 posts

Posted 03 October 2017 - 12:23 PM

Ok.....but....what's the problem?!?!  Why can Eddie on Win7 and OpenVpnConnect on Android connect to dns server 10.4.0.1, but my router can't, even though it used to be able to? What's the mystery?

 

1) Eddie knows the IP address of the servers and, thus, doesn't need any DNS lookups to connect to servers.  If you use the IP address of the server you want in your openvpn client setup, and not the name (e.g. azha.airvpn.org) you will not need DNS lookups either.

 

2) You can't reach 10.4.0.1 until you're connected to the VPN because that's a private address.  It doesn't exist on the internet but in private networks.  Remember VPN = virtual private network. 



#7 ToastyTheEel

ToastyTheEel

    Member

  • Members
  • PipPip
  • 15 posts

Posted 03 October 2017 - 12:51 PM

Thanks for writing back.  The directions for using AirVPN on my router, found elsewhere on this site and in these forums, specifically state to asisign the AirVPN private DNS server, 10.4.0.1, BEFORE activating the vpn on the router, and that's what I've always done.  I use AirVPN's config generator to make the variius config files my router uses for servers, so all of the IP info is contained therein...I'm not typing in IPs or URLs by hand at all, other than the original 10.4.0.1 dns server, and even that is stored.

 

  Strangely enough, I just tried it again and it's working now. Who knows....maybe there was a glitch in the dns server over the last few days?



#8 go558a83nk

go558a83nk

    Advanced Member

  • Members2
  • PipPipPip
  • 1706 posts

Posted 03 October 2017 - 04:12 PM

Thanks for writing back.  The directions for using AirVPN on my router, found elsewhere on this site and in these forums, specifically state to asisign the AirVPN private DNS server, 10.4.0.1, BEFORE activating the vpn on the router, and that's what I've always done.  I use AirVPN's config generator to make the variius config files my router uses for servers, so all of the IP info is contained therein...I'm not typing in IPs or URLs by hand at all, other than the original 10.4.0.1 dns server, and even that is stored.

 

  Strangely enough, I just tried it again and it's working now. Who knows....maybe there was a glitch in the dns server over the last few days?

 

 

When you generate configs select the option on the bottom right that says resolved hosts in ovpn file.  That way you can connect without having to resolve the server name - it puts IP address in instead of name.



#9 2975863j

2975863j

    Member

  • Members2
  • PipPip
  • 11 posts

Posted 15 March 2019 - 03:59 PM

Thanks for the info on using 'Resolved hosts in .ovpn file' setting (Tick Advanced Settings box to get the option)

 

Over 15 months later this is still not listed on the setup section for Asus routers.

Also needing updated is the DD_WRT setup settings as they still list the old SHA1 setting.

 

AirVPN are great, but some things like this could do with an update.







Similar Topics Collapse

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

Servers online. Online Sessions: 13623 - BW: 49404 Mbit/sYour IP: 54.82.99.169Guest Access.