Jump to content


Photo

Eddie 2.12.4 keeps crashing on Mint 18.1


  • Please log in to reply
16 replies to this topic

#1 greerd

greerd

    Newbie

  • Members
  • Pip
  • 7 posts

Posted 11 April 2017 - 11:09 PM

I've been having problems with the latest eddie stable (2.12.4) and its predecessor (2.12.?) on Mint 18.1 cinnamon, were eddie crashes sometime after startup. It starts up normally, connects and runs fine for some time, could be hours, could be days (desktop is 24/7) but it will eventually crash.

 

When it crashes openvpn always continues running and I'm still connected to the airvpn server with ipleak.net not showing any leaks. Mono is sometimes still running, sometimes not. Killing openvpn and mono (if still running) allows me to restart eddie.

 

Anyone have any idea's? Hope the terminal output isn't too large!

 

Thanks

 

inxi -Fxz

Spoiler

 

Output from running from a terminal (large)

Spoiler
@openvpn.net>



#2 go558a83nk

go558a83nk

    Advanced Member

  • Members
  • PipPipPip
  • 1150 posts

Posted 12 April 2017 - 06:56 PM

no ideas here.  I run mint 18.1 in a VM (windows host) and have never seen a crash of Eddie.



#3 greerd

greerd

    Newbie

  • Members
  • Pip
  • 7 posts

Posted 12 April 2017 - 08:26 PM

Must be something on my end then, thanks for the input. A couple more questions if you don't mind:

Do you use firejail for anything? For sandboxing  apps (Firefox, Thunderbird, etc.)

What DE and theme are you using? I'm using cinnamon with Crunchy-green theme.

​Thanks again!



#4 serenacat

serenacat

    Advanced Member

  • Members
  • PipPipPip
  • 182 posts

Posted 13 April 2017 - 12:22 AM

If you check Linux Mint Forums, there are several network issue threads currently active re 18.1.

https://forums.linuxmint.com/viewforum.php?f=52&sid=1188f36dbec19b7e9085b7282856d1a6

Including with PIA (install?)

https://forums.linuxmint.com/viewtopic.php?f=157&t=243410&sid=1bef6933d3bf12032e76b816dfbaef90

I have not read all, but also issues with underlying wifi, maybe need to check with cable to router ?

I run LM18.1 in a Virtual Box as the "inner citadel" with a W10 host "rabble yard" with Eddie on W10 so do not see the problem condition.

 



#5 greerd

greerd

    Newbie

  • Members
  • Pip
  • 7 posts

Posted 13 April 2017 - 10:45 AM

Yea, thanks serenacat,

 

I'm somewhat  active on the Mint forums, and have read/responded to most PIA and other vpn posts. There are a lot of noobs in the Mint forums these days, most are landing there after bailing out of Win 10. There are continuous repeated questions like 'My wifi doesn't work' or 'My sound doesn't work' or something about graphics but less often about vpn's. (until a few days ago, 'US IPS's')

 

I've mentioned AirVPN there and discussed it once and have seen it mentioned a couple of times but PIA, which sponsors Linux Mint, is by far the most talked about on the Mint forums, thus the eddie client has not been discussed to my knowledge.

 

I have used eddie cli before without issue but I like having visual feedback (besides a buried terminal output). I've also used network-manager and would use that full time if it didn't screw with my quasi-smart TV and could be set up with a kill-switch.

 

I'm going through quarantine here so my responses are delayed,

 

Thanks again!



#6 Treiberschreiber

Treiberschreiber

    :() { :|: & }; :

  • Members
  • PipPipPip
  • 2297 posts
  • LocationGermany

Posted 14 April 2017 - 10:30 PM

There must be something in some logfile... did you eat yourself through /var/log? If a GUI breaks, maybe /var/log/Xorg.log? Or ~/.cinnamon/glass.log? I'm not aware of other Eddie logs except for the Logs tab which is not saved to file by default.. maybe turning that on will help..

Did you try turning off any desklets, applets, custom themes and extensions of Cinnamon?


Always remember:
There's a guide to AirVPN,

Amazon IPs are not dangerous here,
running TOR exits is discouraged,

using spoilers for your logs is the proper way to heaven.
Same issues are rare! Search for solutions and if not successful open your own threads.

~ Furthermore, I propose that your paranoia is to be destroyed. ~

 


#7 serenacat

serenacat

    Advanced Member

  • Members
  • PipPipPip
  • 182 posts

Posted 15 April 2017 - 10:38 AM

I suspect Eddie is collateral damage from some other problem.

Looking at your inxi output at the time you ran it:

On my LM18.1 after clean boot and running just qBittorrent, Firefox and a couple of other tools, I have 172 processes and use 1.5GB ram. You show 275 processes and use 8.5GB of 12GB.

After a default VirtualBox install of LM18.1, I have swap-1 size: 4.29GB with 4GB ram. You have swap-1 size: 2.15GB.

Bad things happen if you have runaway processes and exhaust ram and then swap.

Although unlikely to be the problem, Mint recommend sticking with the 4.4.0-53 kernel released with LM18.1 until they release LM18.2 after testing unless a significant problem. You have upgraded to the later Ubuntu release 4.4.0-72. There have been odd problems in the past which makes people cautious of Ubuntu unless they can easily roll back.

So perhaps you need to keep an eye on your system resources with "System Monitor" or a "conky" script or "top", and rummage through the Linux engine room with "System Log" looking for clues as Treiberschreiber suggests.



#8 greerd

greerd

    Newbie

  • Members
  • Pip
  • 7 posts

Posted 15 April 2017 - 11:59 AM

Thanks for the suggestions,

 

@Treiberschreiber, As soon as I complain about it, it stops acting up! I will check the logs next time, I had Air's logs turned off (after I had them on), but are now turned back on. I haven't disabled any Desklets/Applets yet, but good idea, I use Crunchy-green theme and can certainly switch to the default. 

 

@serenacat, yes I have lots of stuff running, Folding@Home with Nvidia coolbits and a custom fan control, Radiotray, and bunch of other stuff. I guess I like to play with my setup. One of the reasons I like Mint so much is it got me in the habit of a fresh install every LTS release (every 6 months before that), so things are 'Fresh' for awhile. 172 processes sounds more like LMDE that Mint 18.1, are you running XFCE instead of Cinnamon? I have 4.4.0-53 installed as a backup, good idea to try that. I do run Conky (great app) and do (normally) keep an eye on things, I've noticed Firefox has started eating up memory since the last update to 52.0.2, I'll keep a closer eye on that.

 

inxi after a reboot:

Spoiler

 

I'll leave things as is, until another eddie crash, check the logs and go from there, thanks again.



#9 snoodlehouse

snoodlehouse

    Member

  • Members
  • PipPip
  • 15 posts

Posted 22 April 2017 - 09:10 PM

I just upgraded to the latest version of Eddie and started getting the exact same problem. But I'm running LM 17.2 Cinnamon.

The GUI window disappears but the VPN connection keeps running.

Since we're both having problems despite different Mint versions, I would suspect there is a problem with the Eddie Client.

 

my inxi -Fxz :

inxi -Fxz
System:    Host: zombiebox-17 Kernel: 3.13.0-37-generic x86_64 (64 bit, gcc: 4.8.2) 
           Desktop: Cinnamon 2.6.13  Distro: Linux Mint 17.2 Rafaela
Machine:   Mobo: Gigabyte model: GA-MA785GM-US2H version: x.x Bios: Award version: F11 date: 05/17/2010
CPU:       Dual core AMD Phenom II X2 555 (-MCP-) cache: 1024 KB flags: (lm nx sse sse2 sse3 sse4a svm) bmips: 12858.4 
           Clock Speeds: 1: 3214.605 MHz 2: 3214.605 MHz
Graphics:  Card: Advanced Micro Devices [AMD/ATI] RS880 [Radeon HD 4200] bus-ID: 01:05.0 
           X.Org: 1.15.1 drivers: ati,radeon (unloaded: fbdev,vesa) Resolution: 1600x900@60.0hz 
           GLX Renderer: Gallium 0.4 on AMD RS880 GLX Version: 3.0 Mesa 10.1.3 Direct Rendering: Yes
Audio:     Card-1: Advanced Micro Devices [AMD/ATI] RS880 HDMI Audio [Radeon HD 4200 Series] 
           driver: snd_hda_intel bus-ID: 01:05.1 
           Card-2: Advanced Micro Devices [AMD/ATI] SBx00 Azalia (Intel HDA) driver: snd_hda_intel bus-ID: 00:14.2 
           Sound: Advanced Linux Sound Architecture ver: k3.13.0-37-generic
Network:   Card-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller 
           driver: r8169 ver: 2.3LK-NAPI port: de00 bus-ID: 04:00.0
           IF: eth0 state: down mac: <filter>
           Card-2: Broadcom BCM4352 802.11ac Wireless Network Adapter driver: wl bus-ID: 03:00.0
           IF: eth1 state: up mac: <filter>
Drives:    HDD Total Size: 2184.5GB (72.2% used) 1: id: /dev/sda model: SAMSUNG_HD204UI size: 2000.4GB 
           2: id: /dev/sdb model: Corsair_CSSD size: 32.0GB 3: id: /dev/sdc model: SPCC_Solid_State size: 120.0GB 
           4: id: /dev/sdg model: SD/MMC size: 32.0GB 
Partition: ID: / size: 22G used: 9.9G (48%) fs: ext4 ID: /home size: 1.8T used: 1.5T (84%) fs: ext4 
           ID: swap-1 size: 8.02GB used: 0.41GB (5%) fs: swap 
RAID:      No RAID devices detected - /proc/mdstat and md_mod kernel raid module present
Sensors:   System Temperatures: cpu: 27.2C mobo: N/A 
           Fan Speeds (in rpm): cpu: N/A 
Info:      Processes: 212 Uptime: 17 days Memory: 1673.7/3445.7MB Runlevel: 2 Gcc sys: 4.8.4 
           Client: Shell (bash 4.3.11) inxi: 1.9.17 

 



#10 greerd

greerd

    Newbie

  • Members
  • Pip
  • 7 posts

Posted 22 April 2017 - 11:15 PM

I have had one crash since my first post but since eddie wasn't running from the terminal, I didn't find anything in the logs. Airvpn logs were turned on for it but nothing in there that I noticed as an eddie/mono problem. Makes sense I guess since openvpn keeps running.

The only thing so far is in my first post 'spoiler' were I ran airvpn from a terminal, here's what I think is the pertinent part:

. 2017.04.10 14:02:59 - Systems & servers data update completed
mono() [0x49ff2f]
mono() [0x4f390e]
mono() [0x426c19]
/lib/x86_64-linux-gnu/libpthread.so.0(+0x11390) [0x7fc95eabf390]
/lib/x86_64-linux-gnu/libc.so.6(+0x7e461) [0x7fc95e763461]
/lib/x86_64-linux-gnu/libc.so.6(+0x800a8) [0x7fc95e7650a8]
/lib/x86_64-linux-gnu/libc.so.6(cfree+0x4c) [0x7fc95e76898c]
/usr/lib/libgdiplus.so.0(+0x11786) [0x7fc95aba9786]
[0x4099b9d0]

Debug info from gdb:

​=================================================================
Got a SIGSEGV while executing native code. This usually indicates
a fatal error in the mono runtime or one of the native libraries
used by your application.
=================================================================

 



#11 serenacat

serenacat

    Advanced Member

  • Members
  • PipPipPip
  • 182 posts

Posted 23 April 2017 - 12:35 PM

So an intermittent bug in mono would not be a big surprise.

This seems like an indicator of stretched resources:

http://www.mono-project.com/docs/gui/libgdiplus/

 

Maybe the SIGSEGV made a "core" dump file which you could ship to Air with a bug report.

But maybe it is not a high priority problem due to fairly infrequent, limited negative impact, difficult to program around if in mono, better to wait for mono bug fix, ... ???

I am afraid I did C++/C programming and debugging on Unix in the late 80s and early 90s, then went away to the land of Java/J2EE and then became a refugee from the IT industry dot com crash and toxic fallout in 2001 to go bush and down the beach, so now have barnacles on the rust on the neurons.



#12 greerd

greerd

    Newbie

  • Members
  • Pip
  • 7 posts

Posted 23 April 2017 - 01:41 PM

@serenacat, at least you have the neurons, more than I can say!

 

I have a core dump, but with the crash frequency dropping to a manageable level, I won't bother with a bug report, let them work on eddie 3.0 instead.

 

I'll be glad when eddie 3.0 comes out, I've already dropped Tomboy and Clementine, so my last mono dependent is eddie.



#13 satoshitree

satoshitree

    Newbie

  • New Members
  • Pip
  • 4 posts

Posted 24 April 2017 - 06:50 AM

I'm one of those Linux Mint newbies on the forum, but I haven't asked any questions yet. I was hoping to find answers myself and now im questioning my idea to build a vpn router on linux. It's more of a personal project than need, but I was going to run my crypto miners off of it. Looks best to hold off until eddie 3.0 and see how that goes.



#14 serenacat

serenacat

    Advanced Member

  • Members
  • PipPipPip
  • 182 posts

Posted 29 April 2017 - 05:19 AM

@satoshitree

If I was interested in building a "vpn router on linux" and had various systems for "crypto miners" and wanted to learn more about network design and operations (which can pay regular money!) I think I would build a pfsense box and fit it with Eddie and Openvpn and whatever other of use or interest from the set of extensions/addons.

That keeps you also on a well trodden path to select hardware, learn and run FreeBSD ("subset-ish" of GnuLinux), configure industry standard firewall, routing, admin, etc.

No need to wait for Eddie 3, plenty of Eddie 2 / Air / pfsense users around here.

https://en.wikipedia.org/wiki/Pfsense

https://www.pfsense.org/

Search forums here for "pfsense".

 

Edit:

Ignorant, assumed Eddie ported to XWindows/FreeBSD.

"How To Set Up pfSense 2.3 for AirVPN"

https://airvpn.org/topic/17444-how-to-set-up-pfsense-23-for-airvpn/

 

Maybe Eddie 3 / Gtk / XWindows / FreeBSD, or a separation of UI from functional code and also a Web/js/html remote interface ? And a ssh/bash/termio interface ? And runs on bash on W10 ?

Probably need to do some more forums reading about future plans, wandering into ignorance again. :mellow:



#15 slick1537

slick1537

    Newbie

  • New Members
  • Pip
  • 1 posts

Posted 16 May 2017 - 09:50 AM

Hello guys,

 

I just wanted to note, I am running mint cinnamon 18.1 and this morning I also experienced the same bug in Eddie.  I woke up and the eddie gui was gone.  However there is still a airvpn process running and ipleak.net shows all connections traveling via VPN.



#16 snoodlehouse

snoodlehouse

    Member

  • Members
  • PipPip
  • 15 posts

Posted 03 June 2017 - 03:45 PM

Just to update over the last month: This bug stopped occurring for me some time in may.

Last week I upgraded from Mint 17.2 to 18.1 for unrelated reasons. I haven't seen any Eddie crashes. Maybe there was a mono update that fixed this. 



#17 greerd

greerd

    Newbie

  • Members
  • Pip
  • 7 posts

Posted 03 June 2017 - 05:59 PM

It keeps crashing on me, every now and then, and I'm running 18.1 Cinnamon and have been since it was available. Once mono went zombie and I couldn't kill it (can't kill a zombie) so I was forced to reboot, that sucked! I had a good spell of a couple of weeks that it didn't crash, but it back at it again.

 

I've never found any logs that show the crash, the only time I seen something was when I ran airvpn from the terminal (see my first post) but it seems that most of the time when mono crashes it's when the server disconnects and eddie has to re-connect.







Similar Topics Collapse

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

Servers online. Online Users: 15132 - BW: 43195 Mbit/sYour IP: 54.81.83.207Guest Access.