Jump to content
Not connected, Your IP: 52.203.18.65

Recommended Posts

I am unable to install eddie on Debian 11 Buster (stable), so any help will be greatly appreciated.

Toward the end of the steps, after I run:

sudo apt-get install eddie-ui

I get this:

Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 eddie-ui : Depends: libappindicator1 but it is not installable
E: Unable to correct problems, you have held broken packages.

Running "apt-get install libappindicator1" did not do any good either, as it doesn't seem to be in the Debian Main repositories:

Package libappindicator1 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
E: Package 'libappindicator1' has no installation candidate

Thanks!

Share this post


Link to post

It is known, Debian finished a transition with Bullseye from libappindicator1 to libappindicator-ayatana which was not the case when Eddie stable was released. Eddie beta 2.21.x removed the dependency, but it's on the testing channel. Change the APT sources file (/etc/apt/sources.list.d/eddie.list, or whatever you named it) from stable to testing.


NOT AN AIRVPN TEAM MEMBER. USE TICKETS FOR PROFESSIONAL SUPPORT.

LZ1's New User Guide to AirVPN « Plenty of stuff for advanced users, too!

Unofficial Eddie for Android F-Droid repository: repo.opensourcery.eu

Want to contact me directly? All relevant methods are on my About me page.

Share this post


Link to post

I have the same problem. Fresh installed bullseye, need to run Eddie. Downloaded eddie-ui_2.21.3_linux_x64_debian.deb, but it won't install with dpkg:
 

Quote
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von eddie-ui:
eddie-ui hängt ab von curl; aber:
 Paket curl ist nicht installiert.
eddie-ui hängt ab von libnotify-bin; aber:
 Paket libnotify-bin ist nicht installiert.
eddie-ui hängt ab von mono-runtime; aber:
 Paket mono-runtime ist nicht installiert.
eddie-ui hängt ab von mono-utils; aber:
 Paket mono-utils ist nicht installiert.
eddie-ui hängt ab von libmono-system-core4.0-cil; aber:
 Paket libmono-system-core4.0-cil ist nicht installiert.
eddie-ui hängt ab von libmono-system-windows-forms4.0-cil; aber:
 Paket libmono-system-windows-forms4.0-cil ist nicht installiert.
eddie-ui hängt ab von openvpn; aber:
 Paket openvpn ist nicht installiert.
eddie-ui hängt ab von stunnel4; aber:
 Paket stunnel4 ist nicht installiert.
eddie-ui hängt ab von curl; aber:
 Paket curl ist nicht installiert.
eddie-ui hängt ab von libsecret-tools; aber:
 Paket libsecret-tools ist nicht installiert.


 
 
Quote
Change the APT sources file (/etc/apt/sources.list.d/eddie.list, or whatever you named it) from stable to testing.


How exactly do I do this? My directory /etc/apt/sources.list.d/ does not contain any file.
Please help
 

Share this post


Link to post

In this case, the line in question is in the main sources config file in /etc/apt/sources.list.

Edit: Scratch, you're installing this with dpkg directly. In this case, simply make sure you download the Beta. On the download page, click Other versions, then select Experimental. But I really recommend you add Eddie as an APT source. The instructions are found on the Download page, too.


NOT AN AIRVPN TEAM MEMBER. USE TICKETS FOR PROFESSIONAL SUPPORT.

LZ1's New User Guide to AirVPN « Plenty of stuff for advanced users, too!

Unofficial Eddie for Android F-Droid repository: repo.opensourcery.eu

Want to contact me directly? All relevant methods are on my About me page.

Share this post


Link to post
Quote
On the download page, click Other versions, then select Experimental. But I really recommend you add Eddie as an APT source. The instructions are found on the Download page, too.
That's exactly what I did.
Quote
Downloaded eddie-ui_2.21.3_linux_x64_debian.deb, but it won't install with dpkg

But that was an hour ago! In the meantime, I got a notification for many updates. I updated - and then - wow! Eddie installs and runs!
Thank you for your help!

BTW, does this memory leak still persist?

https://airvpn.org/forums/topic/49980-memory-leak-eddie-2212beta/#

Share this post


Link to post
1 hour ago, MarxBrother said:

BTW, does this memory leak still persist?


It's Windows-specific, so not in your case. Fixed otherwise.

NOT AN AIRVPN TEAM MEMBER. USE TICKETS FOR PROFESSIONAL SUPPORT.

LZ1's New User Guide to AirVPN « Plenty of stuff for advanced users, too!

Unofficial Eddie for Android F-Droid repository: repo.opensourcery.eu

Want to contact me directly? All relevant methods are on my About me page.

Share this post


Link to post

Thank you all for the help, and especially OpenSourcerer for the solution.  For others using Debian 11 (Buster) this seems to work:

I have been able to install the TESTING version of eddie-ui on Debian 11 (LXDE in this case).  After installing the stable version of the debian repository using the instructions from the download page, modify the following file:

/etc/apt/sources.list.d/eddie.website.list

And change "stable" to "testing".  The line should read:

deb http://eddie.website/repository/apt testing main

The stable version of eddie-ui gives a libappindicator1 error when installing from repository or .deb package.

Parrot OS 4 (4.11, I think) WILL install BOTH STABLE and TESTING of eddie-ui, but will complain with stable.  Better, I think, to follow the same instructions for Debian 11 above on Parrot OS 4.11.

My guess (but cannot confirm) is that Parrot OS 4.11 must still be based on Debian 10, which was the last to include libappindicator1.  Debian posted that libappindicator would be phased out in the Buster (11) testing cycle back in 2018 April:

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=895037

If the eddie-ui devs are using electron for any of the binaries, it may be that electron defaults to libappindicator1, but I would not know for sure.

Share this post


Link to post
8 hours ago, 254894 said:

If the eddie-ui devs are using electron for any of the binaries, it may be that electron defaults to libappindicator1, but I would not know for sure.


Eddie is a C# app run with Mono on Linux and natively with .NET on Windows. :) There is no JavaScript code.

You're welcome otherwise. Enjoy!

NOT AN AIRVPN TEAM MEMBER. USE TICKETS FOR PROFESSIONAL SUPPORT.

LZ1's New User Guide to AirVPN « Plenty of stuff for advanced users, too!

Unofficial Eddie for Android F-Droid repository: repo.opensourcery.eu

Want to contact me directly? All relevant methods are on my About me page.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Security Check
    Play CAPTCHA Audio
    Refresh Image

×
×
  • Create New...