Jump to content
Not connected, Your IP: 34.239.158.223
GaryH

ANSWERED AirVPN install problem /w Debian 11.0

Recommended Posts

AirVPN fails to install on new Debian 11.0 distro.
It gets a dependency error failure checking for a lib appindicator file and goes no further.
The lib file appears to be obsolete for this new distro.
 

Share this post


Link to post

Can confirm, the dependency libappindicator1 is no longer in the testing repos. The reason is that libappindicator1 was scheduled to be phased out in the Buster release cycle due to upstream deprecation (or at least the abandoning of maintainership). Everywhere I look libayatana-libappindicator1 seems to be promoted as the new replacement against which software needs to be rebuilt. See #895037 #895038; #944872 showing reasons for the transition.


NOT AN AIRVPN TEAM MEMBER. USE TICKETS FOR PROFESSIONAL SUPPORT.

LZ1's New User Guide to AirVPN « Plenty of stuff for advanced users, too!

Want to contact me directly? All relevant methods are on my About me page.

Share this post


Link to post

The download page supplies version 2.20.
Where is the 2.21.1 version ?

Screenshot from 2021-08-20 07-38-57.png

Share this post


Link to post

It's a beta. On the download page click on Other versions and select Experimental.


NOT AN AIRVPN TEAM MEMBER. USE TICKETS FOR PROFESSIONAL SUPPORT.

LZ1's New User Guide to AirVPN « Plenty of stuff for advanced users, too!

Want to contact me directly? All relevant methods are on my About me page.

Share this post


Link to post

Happy to report that the 2.21.1 experimental version installed ok on my debian 11.0 desktop PC.
THANKS for the fast fix and excellent help !!!
Problem Solved.

Share this post


Link to post
Guest
This topic is now closed to further replies.

×
×
  • Create New...