Jump to content
Not connected, Your IP:

Slow vpn speed after Asus WRT merlin update

Recommended Posts

Hello everyone,

Since I updated my router firmware from merlin 384.19 to 386_2_4 i get slow speeds on my vpn connection.

I use the same config i used before i updated. But speeds dropped a lot, it was like 25MB/s with the old firmware and with the new firmware it's like 15MB/s. It never gets over 15MB/s.
To me it looks like there's nothing changed on the config side of things in my router but i might be wrong. The only thing that changed is the Openvpn version the router uses.
On the old firmware it was 2.4.9 and the new uses 2.5.2.

I did make a new config in the generator for version 2.5 (AES not automatic) to use on the router.

Any ideas are welcome, like to solve it rather than go back to the old firmware.

Share this post

Link to post

What data cipher is being used now?  Which one was being used?

I mean, look in the system log to see what actually happened.

It sounds like you have an ac86 or one of the asus routers with AES-NI.  So, you maybe need to make sure to use an AES encryption though chacha20 (available with openvpn 2.5) may be fast too.

Is it possible that AES-NI acceleration has been disabled?  Have you asked this in Merlin support forum?

Share this post

Link to post


I have a ac86u router indeed. Acceleration is enabled and the cipher is the same as before AES-256-GCM. 


Share this post

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Security Check
    Play CAPTCHA Audio
    Refresh Image

  • Create New...