Jump to content
Not connected, Your IP: 34.200.222.93
monica.castro86

AirVPN + Rsaapber Pi + Transmission

Recommended Posts

I have 3 issues with my VPN:
 

  1. Port Forward -> Even thought I have made a port forward in client area my Transmission client says that the port is closed. Why is that? Is there something I should do on Pi? If I forward this port on my router it works ok. How can I check if the port is actually forwarded?
  2. DNS -> If I connect to the VPN, DNS stop to work. I checked the /etc/resov.conf file and the addresses don't change. When I edit this file and add manually VPN's DNS server address it works OK. What's the best option to do it automatically?
  3. Kill Switch -> my IPtables is vary simple:
    -P INPUT ACCEPT
    -P FORWARD ACCEPT
    -P OUTPUT ACCEPT

    I followed the guide here: Prevent leaks with Linux & iptables
         After putting all the lines I still have the access to internet although VPN is not connected. Is there anything I can do to make sure Pi will only traffic through VPN?

Share this post


Link to post
2 hours ago, monica.castro86 said:

Port Forward -> Even thought I have made a port forward in client area my Transmission client says that the port is closed. Why is that? Is there something I should do on Pi? If I forward this port on my router it works ok. How can I check if the port is actually forwarded?


This suggests you're not connected, and if you are, something is not configured right. In this case we need an OpenVPN log.
 
2 hours ago, monica.castro86 said:

DNS -> If I connect to the VPN, DNS stop to work. I checked the /etc/resov.conf file and the addresses don't change. When I edit this file and add manually VPN's DNS server address it works OK. What's the best option to do it automatically?


An up script, maybe. Every time a connection gets established you rename resolv.conf to resolv.conf.bak or so, then write the necessary info to a new resolv.conf file. If disconnecting, you call a down script which will delete the resolv.conf and rename resolv.conf.bak to resolv.conf. More info in the manual, as usual.
 
2 hours ago, monica.castro86 said:

         After putting all the lines I still have the access to internet although VPN is not connected. Is there anything I can do to make sure Pi will only traffic through VPN?


Normally this is set by default. The iptables rules are only there to drop anything that for some reason slips through, but everything goes through the VPN interface, anyway.

» I am not an AirVPN team member. All opinions are my own and are not to be considered official. Only the AirVPN Staff account should be viewed as such.

» The forums is a place where you can ask questions to the community. You are not entitled to guaranteed answer times. Answer quality may vary, too. If you need professional support, please create tickets.

» If you're new, take some time to read LZ1's New User Guide to AirVPN. On questions, use the search function first. On errors, search for the error message instead.

» If you choose to create a new thread, keep in mind that we don't know your setup. Give info about it. Never forget the OpenVPN logs or, for Eddie, the support file (Logs > lifebelt icon).

» The community kindly asks you to not set up Tor exit relays when connected to AirVPN. Their IP addresses are subject to restrictions and these are relayed to all users of the affected servers.

 

» Furthermore, I propose that your paranoia is to be destroyed. If you overdo privacy, chances are you will be unique amond the mass again.

Share this post


Link to post
Posted ... (edited)
On 1/15/2020 at 4:48 PM, giganerd said:

This suggests you're not connected, and if you are, something is not configured right. In this case we need an OpenVPN log.


Thank you giganerd. I solved the DNS issue, thanks a lot.

The port forward problem was that I did not spot that the external and internal ports are different No. When those are the same it works perfect

 

Edited ... by monica.castro86
Problem soved

Share this post


Link to post

 

23 hours ago, giganerd said:

Normally this is set by default. The iptables rules are only there to drop anything that for some reason slips through, but everything goes through the VPN interface, anyway.


After setting the iptables from the link should I delete the 3 original:
-P INPUT ACCEPT
-P FORWARD ACCEPT
-P OUTPUT ACCEPT
 

Share this post


Link to post

You can't really delete them, it's the default for all chains.


» I am not an AirVPN team member. All opinions are my own and are not to be considered official. Only the AirVPN Staff account should be viewed as such.

» The forums is a place where you can ask questions to the community. You are not entitled to guaranteed answer times. Answer quality may vary, too. If you need professional support, please create tickets.

» If you're new, take some time to read LZ1's New User Guide to AirVPN. On questions, use the search function first. On errors, search for the error message instead.

» If you choose to create a new thread, keep in mind that we don't know your setup. Give info about it. Never forget the OpenVPN logs or, for Eddie, the support file (Logs > lifebelt icon).

» The community kindly asks you to not set up Tor exit relays when connected to AirVPN. Their IP addresses are subject to restrictions and these are relayed to all users of the affected servers.

 

» Furthermore, I propose that your paranoia is to be destroyed. If you overdo privacy, chances are you will be unique amond the mass again.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Security Check
    Play CAPTCHA Audio
    Refresh Image

×
×
  • Create New...