Jump to content
Not connected, Your IP: 18.232.124.77
Mad_Max

Netflix doesnt work with Pfsense but works with Eddie!

Recommended Posts

Hello
I have this weird problem. where Netflix doesnt work when im connected to AirVPN through my Pfsense with vpn. However, if i just start eddie and connect to any server netflix works again :S!

My pfsense is not leaking dns and i have locked the dns to Airvpn's dns.

Any ideas to fix this problem?

Share this post


Link to post
13 hours ago, Mad_Max said:

i have locked the dns to Airvpn's dns.


Are you sure this works as intended? Which country are you in?

Four simple things:
There's a guide to AirVPN. Before you ask questions, take 30 minutes of your time to go through it.

Amazon IPs are not dangerous here. It's the fallback DNS.
Running TOR exits is discouraged. They're subject to restrictions on the internet and harm all AirVPN users.

Furthermore, I propose that your paranoia is to be destroyed. If you overdo privacy, you'll be unique among the mass again.

 

XMPP: gigan3rd@xmpp.airvpn.org or join our lounge@conference.xmpp.airvpn.org

Share this post


Link to post
10 hours ago, giganerd said:

Are you sure this works as intended? Which country are you in?
I think yes. I did a couple of dns leak tests and none has shown which country im in. they only show the server that im connected to.

Share this post


Link to post
9 hours ago, Air4141841 said:

I’ve tried for two years on pfsense with NO success.

various android and LG WEBOS tv’s
same issue. 

its really weird! if i just run a 2nd connection with eddie it works fine ! :|

Share this post


Link to post

Worked fine on pfsense for me. Just make sure your VPN network is actually using AV DNS. For example: block outgoing port 53 on WAN and VPN and only allow AV DNS on VPN interface. Then check if your VPN network clients still can resolve hosts. If not check firewall logs for port 53 blocks and you’ll see which DNS server they’re actually querying.

Share this post


Link to post
9 hours ago, 0.07305880509955043xP said:

Worked fine on pfsense for me. Just make sure your VPN network is actually using AV DNS. For example: block outgoing port 53 on WAN and VPN and only allow AV DNS on VPN interface. Then check if your VPN network clients still can resolve hosts. If not check firewall logs for port 53 blocks and you’ll see which DNS server they’re actually querying.

Hello 007,
Can you explain AV DNS for me please.
Thank you,Casper

xmpp.airvpn.org ; D70D4969 808093D5 ED232F8A 1764CFBC C020509B

Share this post


Link to post

For Netflix to work properly your clients need to use AirVPN DNS. Here’s more info https://airvpn.org/specs/ (search for DNS). On pfSense the easiest way is to set DNS to 10.4.0.1 in DHCP config. You will also need to add ‘route 10.4.0.1;’ to your OpenVPN client custom config. 

Share this post


Link to post
17 hours ago, 0.07305880509955043xP said:

AV DNS


I honestly cringed slightly. :D Casper is long enough a member to know what AirVPN DNS is, but he probably has never seen it called "AV DNS", like me, so the confusion is real :DD Please just use the word AirDNS for it. https://airdns.org

But I agree with Mr. 0.07305880509955043xP that I think you are indeed leaking somewhere. You still didn't answer which country you are in. I wanted to know which version of Netflix you are seeing. If you're not in the US but you see the US version, then you were indeed using AirDNS and the issue is deeper than we think.

Four simple things:
There's a guide to AirVPN. Before you ask questions, take 30 minutes of your time to go through it.

Amazon IPs are not dangerous here. It's the fallback DNS.
Running TOR exits is discouraged. They're subject to restrictions on the internet and harm all AirVPN users.

Furthermore, I propose that your paranoia is to be destroyed. If you overdo privacy, you'll be unique among the mass again.

 

XMPP: gigan3rd@xmpp.airvpn.org or join our lounge@conference.xmpp.airvpn.org

Share this post


Link to post
3 hours ago, 0.07305880509955043xP said:

For Netflix to work properly your clients need to use AirVPN DNS. Here’s more info https://airvpn.org/specs/ (search for DNS). On pfSense the easiest way is to set DNS to 10.4.0.1 in DHCP config. You will also need to add ‘route 10.4.0.1;’ to your OpenVPN client custom config. 


my devices show 2 IP addresses. the 2nd address is 10.4.0.1 and the 1rst one is followed by this message from that page If that's not possible, then we suggest to set the DNS IP address matching the VPN gateway IP address, as this is the safest method to prevent certain attacks based on hijacking.

so  every time i  reconnect to openvpn i change the new gateway address so its there.

how do you add route 10.4.0.1 or the default gateway to the openvpn client config?    which part of the openvpn manuals explains this...   i have typed EXAMPLE: push dhcp-option dns 10.4.0.1 and it still does not work 



thank you 

Share this post


Link to post

The router tunnel is changed to Airvpn, tv has static ip, and statically assigned dns from pfsense.   It gets the dns and I pleak.net shows only the server I am on..

like i I said I’ve tried this for two years... 

I’ll post my config:



route "10.4.0.1 255l255.255.0";
push "dhcp-option dns 10.4.0.1";
explicit-exit-notify 5;
route-delay 5;
resolv-retry infinite;
persist-key;
persist-tun;
remote-cert-tls server;
auth-nocache;
tls-version-min 1.2;
remote 199.249.230.34 443;
remote us3.vpn.airdns.org 443;remote us3.vpn.airdns.org 443;remote us3.vpn.airdns.org 443;

406C1C00-640C-4432-866B-DC34D49C05A2.jpeg

38DBC53E-C7CC-4D57-B722-3EB17841F90B.jpeg

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Security Check
    Play CAPTCHA Audio
    Refresh Image

×
×
  • Create New...