Jump to content
Not connected, Your IP: 18.215.161.19
Sign in to follow this  
gpieper

[SOLVED] Failed to connect through DD-WRT router

Recommended Posts

I seem to be in the exact same boat as Vedius.  I'm running DD-WRT on a ASUS RT N-16, Build XXXXX

 

I have set up for using port 80 UDP (after trying port 443 UDP) and still no resolution.  I am configured exactly as is shown in the above screen shots.  My openVPN log is as follows:

 

Serverlog Clientlog 20140209 02:45:35 I SIGUSR1[soft tls-error] received process restarting 
20140209 02:45:35 Restart pause 2 second(s) 
20140209 02:45:37 W NOTE: the current --script-security setting may allow this configuration to call user-defined scripts 
20140209 02:45:37 I Re-using SSL/TLS context 
20140209 02:45:37 I LZO compression initialized 
20140209 02:45:37 Control Channel MTU parms [ L:1558 D:138 EF:38 EB:0 ET:0 EL:0 ] 
20140209 02:45:37 Socket Buffers: R=[114688->131072] S=[114688->131072] 
20140209 02:45:37 Data Channel MTU parms [ L:1558 D:1450 EF:58 EB:135 ET:0 EL:0 AF:3/1 ] 
20140209 02:45:37 Local Options String: 'V4 dev-type tun link-mtu 1558 tun-mtu 1500 proto UDPv4 comp-lzo cipher AES-256-CBC auth SHA1 keysize 256 key-method 2 tls-client' 
20140209 02:45:37 Expected Remote Options String: 'V4 dev-type tun link-mtu 1558 tun-mtu 1500 proto UDPv4 comp-lzo cipher AES-256-CBC auth SHA1 keysize 256 key-method 2 tls-server' 
20140209 02:45:37 Local Options hash (VER=V4): '22188c5b' 
20140209 02:45:37 Expected Remote Options hash (VER=V4): 'a8f55717' 
20140209 02:45:37 I UDPv4 link local: [undef] 
20140209 02:45:37 I UDPv4 link remote: 198.203.28.42:80 
20140209 02:45:37 TLS: Initial packet from 198.203.28.42:80 sid=839f5dd4 d1fe692b 
20140209 02:45:37 VERIFY OK: depth=1 /C=IT/ST=IT/L=Perugia/O=airvpn.org/CN=airvpn.org_CA/emailAddress=info@airvpn.org 
20140209 02:45:37 VERIFY OK: nsCertType=SERVER 
20140209 02:45:37 VERIFY OK: depth=0 /C=IT/ST=IT/L=Perugia/O=airvpn.org/CN=server/emailAddress=info@airvpn.org 
20140209 02:46:37 N TLS Error: TLS key negotiation failed to occur within 60 seconds (check your network connectivity) 
20140209 02:46:37 N TLS Error: TLS handshake failed 
20140209 02:46:37 TCP/UDP: Closing socket 
20140209 02:46:37 I SIGUSR1[soft tls-error] received process restarting 
20140209 02:46:37 Restart pause 2 second(s) 
20140209 02:46:39 W NOTE: the current --script-security setting may allow this configuration to call user-defined scripts 
20140209 02:46:39 I Re-using SSL/TLS context 
20140209 02:46:39 I LZO compression initialized 
20140209 02:46:39 Control Channel MTU parms [ L:1558 D:138 EF:38 EB:0 ET:0 EL:0 ] 
20140209 02:46:39 Socket Buffers: R=[114688->131072] S=[114688->131072] 
20140209 02:46:39 Data Channel MTU parms [ L:1558 D:1450 EF:58 EB:135 ET:0 EL:0 AF:3/1 ] 
20140209 02:46:39 Local Options String: 'V4 dev-type tun link-mtu 1558 tun-mtu 1500 proto UDPv4 comp-lzo cipher AES-256-CBC auth SHA1 keysize 256 key-method 2 tls-client' 
20140209 02:46:39 Expected Remote Options String: 'V4 dev-type tun link-mtu 1558 tun-mtu 1500 proto UDPv4 comp-lzo cipher AES-256-CBC auth SHA1 keysize 256 key-method 2 tls-server' 
20140209 02:46:39 Local Options hash (VER=V4): '22188c5b' 
20140209 02:46:39 Expected Remote Options hash (VER=V4): 'a8f55717' 
20140209 02:46:39 I UDPv4 link local: [undef] 
20140209 02:46:39 I UDPv4 link remote: 198.203.28.42:80 
20140209 02:46:40 TLS: Initial packet from 198.203.28.42:80 sid=511d2beb 1814b6c1 
20140209 02:46:40 VERIFY OK: depth=1 /C=IT/ST=IT/L=Perugia/O=airvpn.org/CN=airvpn.org_CA/emailAddress=info@airvpn.org 
20140209 02:46:40 VERIFY OK: nsCertType=SERVER 
20140209 02:46:40 VERIFY OK: depth=0 /C=IT/ST=IT/L=Perugia/O=airvpn.org/CN=server/emailAddress=info@airvpn.org 
20140209 02:46:52 MANAGEMENT: Client connected from 127.0.0.1:5001 
20140209 02:46:52 D MANAGEMENT: CMD 'state' 
20140209 02:46:52 MANAGEMENT: Client disconnected 
20140209 02:46:52 MANAGEMENT: Client connected from 127.0.0.1:5001 
20140209 02:46:52 D MANAGEMENT: CMD 'state' 
20140209 02:46:52 MANAGEMENT: Client disconnected 
20140209 02:46:52 MANAGEMENT: Client connected from 127.0.0.1:5001 
20140209 02:46:52 D MANAGEMENT: CMD 'state' 
20140209 02:46:52 MANAGEMENT: Client disconnected 
20140209 02:46:52 MANAGEMENT: Client connected from 127.0.0.1:5001 
20140209 02:46:52 D MANAGEMENT: CMD 'log 500' 
19700101 00:00:00 

 

Where I get constant disconnection.  Any help would be greatly appreciated!

 

Thanks.

Share this post


Link to post

Just wanted to let everyone know I got this solved.  In case you have a similar problem, I downgraded my DD-WRT to build 1824 and now everything seems to work.

Whew!

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Security Check
    Play CAPTCHA Audio
    Refresh Image
Sign in to follow this  

×
×
  • Create New...