Jump to content
Not connected, Your IP:

ANSWERED [Chromecast] dd-wrt // geo-blocking still happening but only on some devices

Recommended Posts


So I have a router with ww-drt that is connected to the vpn.

I have two devices connected to that network.
1. desktop

2. chromecast

When going to http://pluzz.francetv.fr
1. desktop can stream content.
2. chromecast is still geo-blocked, the video service warns about the vpn server location not being in fr. (ca,be,ch are those I have tried, airvpn does not have an fr server)

Can't understand why one device on the same network would work and not the other.

Thanks for any help.

Share this post

Link to post

Chromecast has hard-coded Google DNS (, so you need to "hijack" those requests and forward them to the VPN DNS.

In the DNSMasq options, enter the text strict-order, and in the firewall configuration you should enter something like:

iptables -I FORWARD --destination -j REJECT
iptables -I FORWARD --destination -j REJECT

iptables -t nat -A PREROUTING -i br0 -p udp --dport 53 -j DNAT --to $(nvram get lan_ipaddr)
iptables -t nat -A PREROUTING -i br0 -p tcp --dport 53 -j DNAT --to $(nvram get lan_ipaddr)

Occasional moderator, sometimes BOFH. Opinions are my own, except when my wife disagrees.

Share this post

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Security Check
    Play CAPTCHA Audio
    Refresh Image

  • Create New...