Jump to content
Not connected, Your IP: 44.192.26.60
kbps

Network Lock blocking local LAN even though option to allow is on.

Recommended Posts

I am using Eddie 2.16.3 on Ubuntu 18.04.  I use a DLNA/Upnp media server to stream to other devices on the network.  When I have network lock enabled I cannot see my DLNA server on other devices.  Also cannot use samba or anything like that.  The local network is being blocked even though allow lan/private is ticked.

 

I see from the faq https://airvpn.org/faq/software_lock/

 

that these are the allowed address

# Make sure that you can communicate within your own network if Private Network option is enablediptables -A INPUT -s 192.168.0.0/16 -d 192.168.0.0/16 -j ACCEPTiptables -A OUTPUT -s 192.168.0.0/16 -d 192.168.0.0/16 -j ACCEPTiptables -A INPUT -s 10.0.0.0/8 -d 10.0.0.0/8 -j ACCEPTiptables -A OUTPUT -s 10.0.0.0/8 -d 10.0.0.0/8 -j ACCEPTiptables -A INPUT -s 172.16.0.0/12 -d 172.16.0.0/12 -j ACCEPTiptables -A OUTPUT -s 172.16.0.0/12 -d 172.16.0.0/12 -j ACCEPT

 

however my local network is 192.168.1.* Is this the reason for my problems?  How do I change eddies iptables rules to also include 192.168.1.* ?

 

 

Share this post


Link to post

Hi, I have the same problem.
I have eddie software installed on my linux computer, minidlna is running, but i can't acces with my other devices.
My local network is in 192.168.2.*
How do i can acces to my local network ?
Thanks.

Share this post


Link to post

For information : I reconfigure my network with 192.168.0.* address IP but it doesn't work.
In the settings / routes, i place the IP address i want to access outside the VPN tunnel
In the settings / Network lock, i place the IP address of the devices witch are allowed to access minidlna in "allowed for incoming" and "allowed for outgoing"
I try to add some rules to iptables to be more permissive (but i'm not an expert) ...
... always with the same result 😞

I read a lot of thread about how sharing or activate local network but it's often for windows otherwise it look very complicated for a non specialist.
some help would be greatly appreciated.
 

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Security Check
    Play CAPTCHA Audio
    Refresh Image

×
×
  • Create New...