Jump to content
Not connected, Your IP:

virgin media throttling speed with huge packet loss

Recommended Posts

i've read most of the posts here about virgin media throttling speed for openvpn, i'm actually getting this too.

my broadband speed is well over 100MB, but with openvpn, speed gets throttled to 15-25mb with alot of connection drops, making it near impossible to browse.

here's the protocols i've tried (unticking automatic protocol on eddie)


UDP 443 - huge packet loss with speed throttled to 10-18mb

UDP 1194 - high packet loss with speed throttled to 12-23mb

at this point, i decided to use the TLS-crypt1.2 protocols


UDP 443 TLScrypt - average packet loss with speed throttled to 25-35mb

UDP 1194 TLScrypt - average packet loss with speed throttled to 25-35mb

SSL 443 TLScrypt - small packet loss with speed throttled to 20-40mb

SSH 80 TLScrypt - little to no packet loss with speed still throttled to 30-50mb


this doesn't only happen on airvpn but other vpn providers that use openvpn... happens on android too.

actually it's much worse on other openvpn vpn providers

at this point, i thought i'd try wireguard (tunsafe) surprisingly no throttling no packet loss, full speed 90-120mb


not sure what to do, can anyone advice? firewall is completely disabled on my router.



Share this post

Link to post

I am also a VM customer and have there 200Mbps package. Like you I suffered from very bad throttling starting approx 4-5mths ago, previously I would get between 75-100+Mbp/s while running through AirVPN  but found this was cut right down to 18 -20Mbp/s now while on AirVPN. 

                                                                 I think it began after they replaced my old Superhub 2.1ac for the Superhub 3.0. I tried a lot of different solutions from here and also the Virgin site but nothing seemed to work. I use qBittorrent and previously I had up to 15-17Mib/s on well seeded downloads but found that now it was like I was capped at 5.2Mib/s in total. In the end I bought a Linksys EA7500 Max Stream router for £50, set my Superhub 3.0 to modem mode and found that I was still having the same issue.


                                                On further research I came across a post here where the OP was advised to use UDP 1194 the Official OpenVPN port in the AirVPN Preferences>Protocols and this solved it for me. Now I am getting between 75- 100+Mbp/s while using AirVPN and my download speed on qBittorrent has risen to better than it was before in fact I had one download where I was gettiing a little over 20Mib's for a short time. Now I only found out about the UDP 1194 option after I bought the router so I can't say if it will work for you through your Superhub but if it doesn't then I can recommend the Linksys EA7500. Hope this helps.

Share this post

Link to post

I have used airvpn for years, when i had sky adsl, using the vpn, i got about 70% of the normal speed, which is fine. I switched to virgin about 15months ago, for the first few months i couldnt get downloads to come in at even 10% of the full speed. Then i found a youtube clip of a user showing the throttling in place, and then suggested a protocol, using SSL, though i cant remember the port. This worked astonishingly well. I have VM350mps, and over vpn saw DL rates of 34MB/s - again i was happy with this.


Then i few months ago, i notice the speed went back to 3MB/s - had very little time to resolve this - and any time i've invested (reinstalling, changing protocols), i've failed!


Anyone with specific instructions to fix or just something to try?



Share this post

Link to post

I am on the VM 200M package. Speed test through AirVPN MANCHESTER server is 208M. (Yes I know what you are thinking but the 200 package is actually around 210).


That’s using my iPad connected via WiFi to my ASUS AX-RT88U


No complaints from me.

Asus RT-AC88U [Hardware:A2] Mode: Wireless Router

Firmware by @RMerlin

Share this post

Link to post

Didn't realise Virgin were so bad at throttling, was previously with PlusNet they were fine.  I use Windscribe and little bit of tinkering I found a Stealth mode I could set which - Encapsulates OpenVPN in a TLS tunnel via Stunnel.  It says to only use is other standard methods fail handy in China they say.

So if your VPNs provide a way to Encapsulates the traffic in TLS tunnel it should just look like normal secure traffic to them.

Share this post

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Security Check
    Play CAPTCHA Audio
    Refresh Image

  • Create New...