Jump to content
Not connected, Your IP: 34.229.151.87
Sign in to follow this  
Snowplow

iPhone iOS12 very slow VPN on AT&T LTE

Recommended Posts

The essence of my question is whether anybody's had issues with an iPhone on iOS12 suffering very poor VPN speed on LTE?

 

Some background....

iPhone 6s Plus.  On iOS10 with the prior generation (v2.x) of OpenVPN, things worked great.

 

I moved to iOS11, still with the prior generation of OpenVPN.  The VPN aspect seemed to work well for me, but the overall phone performance was lackluster enough to motivate me into an update to iOS12.

 

In a short period of time, I moved my phone to iOS12 and changed my plan type -- still AT&T -- from an ancient to a modern plan.  Also the update to iOS12 required me to update OpenVPN to v3.x (3.0.2 -- 894 presently).

 

The VPN connects quickly, no issues there on both LTE and Wifi.  But once connected, I often do not get data access via LTE.  The graph shows the Y-axis in BYTES per second.  It seems I can sometimes close then reopen OpenVPN and it improves, or switch to airplane mode & back, or reboot the phone...but at best I get a day or two, often only a matter of minutes, where I get data.

 

I am looking for help to diagnose the issue.  I am inclined to believe it's a phone issue, because sometimes it seems to get stuck in some loop where the phone battery drains very quickly while also not providing data access.  But when it *does* work, it works like I expect and battery usage is fine.  I see nothing odd in the logs when it's burning battery.

 

I backed up the phone and did a full DFU restore, and for 2 days it was bliss.  Now I'm back to the same issues.

 

Any thoughts/help?

Share this post


Link to post

my gf's 6s went from a ancient data plan to an unlimited plan.

 

her speeds went from acceptable to poor.

 

i don't believe ATT when the first 10+Gb is unthrottled one bit

Share this post


Link to post

I was on ancient "unlimited"...the original iPhone unlimited plan, before going to their newer one.  From a fine-print perspective, they both throttle data > 22 GB/month (and I'm nowhere near that).

 

Interesting experience you mention, as it sounds similar.  Is she using VPN?  My LTE data behaves quite normally without VPN.

Share this post


Link to post

Anybody else have experience here? I am sure there are others using AT&T wireless and similar hardware/software.

 

Update: I just realized how to do the more advanced configs, and am trying the combined ipv4/6 with TCP on port 80 and entry IP 3, see how that goes.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Security Check
    Play CAPTCHA Audio
    Refresh Image
Sign in to follow this  

×
×
  • Create New...