Jump to content
Not connected, Your IP: 34.226.244.70

Recommended Posts

Hello,

 

This has been asked in quite a few places already but there is no clear answer as far as I can tell. Long story short, if you ISP provides you with both IPv4 and IPv6 addresses, then by connecting to AirVPN VPN only the IPv4 traffic is being routed through the tunnel. If a website (or any other remote endpoint) runs on IPv6, then your real IPv6 (the one provided to you by your ISP) will be used and so you end up with an IP leak. Not good.

 

The easiest choice is to disable IPv6 per host basis or use some iptables or other firewall magic to filter out all the IPv6 traffic. This is only a workaround and a very inconvenient one especially when you run AirVPN on a router.

 

The best solution would be for AirVPN to provide a dual stack IPv4/IPv6 tunnel so connected clients can reach the modern IPv6 world privately and securely in a similar fashion to IPv4.

 

Are there any plans to support this option? As far as I can see there are only a handful of VPN providers out there which actually provide dual stack VPNs so it would be nice for AirVPN join this effort.

Share this post


Link to post

Hi,

AirVPN already has in-tunnel dual stack connectivity. If you're worried about IP leaks, activate network lock!

Share this post


Link to post
Posted ... (edited)

this is my opinion only but i stay away from ipv6

i shut it down at the kernel via grub edit:

 

GRUB_DEFAULT=0
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR="Arch"
GRUB_CMDLINE_LINUX_DEFAULT="quiet loglevel=3 pnpbios=off acpi=off"
GRUB_CMDLINE_LINUX="cryptdevice=/dev/sda1:cryptroot ipv6.disable=1 bluetooth.blacklist=yes"
Edited ... by tokzco

Share this post


Link to post

So are you saying that your device gets both IPv4 and IPv6 addresses from the AirVPN endpoint? Because I can only see a single 10.X.X.X/8 address assigned to the tunnel device on both Windows and Linux

Share this post


Link to post

Yes, if configured correctly, you should get both IPv4/IPv6 addresses on your tun device.

 

Make sure you :

  • if using Eddie, see in the preferences if IPv6 is enabled
  • If using Eddie, is it up to date (version 2.16.3)?
  • if using OpenVPN, download the config files that activate IPv6
  • if using OpenVPN, are you using version 2.4 and over?
  • you have IPv6 enabled system-wide and on the tun device

Do you have ::1 as your IPv6 address on the loopback (lo) in your linux?

Share this post


Link to post

OK you are right. The problem is that I am importing the .ovpn file in NetworkManager and the 'push-peer-info' and 'setenv UV_IPV6 yes' options are not being understood by NM at all so they are being silently dropped. It works fine if I use openvpn --config ... directly. Slightly inconvenient but so be it.

 

Thank you

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Security Check
    Play CAPTCHA Audio
    Refresh Image

×
×
  • Create New...