Jump to content
Not connected, Your IP: 34.229.151.87

Recommended Posts

If you trust the OpenVPN code to run as root, then there is nothing much different than running Eddie.

The code is not perfect, just like anything, and some security issues are discovered from time to time.

At least with Eddie you can be sure that you will have the recent updates, without actively reading the

OpenVPN official updates and security mailing lists.

 

Many people do not trust OpenVPN's code on their endpoints, and for that they deploy middle routing

boxes or/and running it on their routers. Such vulnerabilities are very rare, but still exist (Heartbleed in 2014).

 

You can safely assume that there will be no new vulnerability introduced while using Eddie, except if there

is a vulnerability in some underlying components of it, as of now - OpenVPN, OpenSSL, Stunnel.


Occasional moderator, sometimes BOFH. Opinions are my own, except when my wife disagrees.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Security Check
    Play CAPTCHA Audio
    Refresh Image

×
×
  • Create New...