Jump to content
Not connected, Your IP:

Unable to connect to the internet using network lock

Recommended Posts

I had to do a clean install of my OS today.  When I did this, I installed the latest version of Eddie 2.15.2.  It seems to function fine when I just connect.  If I activate the network lock, I lose all internet access with every program and browser.  My browser just says Unable to Connect to the Internet.

I have 8 text documents of data.  4 are logs: Connecting with network lock, disconnecting with network lock, connecting without network lock, and disconnecting without network lock.  These tasks were performed in this order.  The other 4 are system reports after performing the aforementioned tasks.  Those are numbered files, but are numerically in the same order as the tasks were performed.

I appreciate any and all help since a VPN is fairly useless without the lock.


Eddie turned on with Network Lock.txt


Eddie turned off with Network Lock.txt


Eddie turned on without Network Lock.txt


Eddie turned off without Network Lock.txt


Share this post

Link to post

>   If I activate the network lock, I lose all internet access with every program and browser.  My browser just says Unable to Connect to the Internet.


That's the point of the 'network lock' - it prevents any data from leaking outside the tunnel, you can choose to allow private/lan or ping in the settings. You can also choose a whitelist of allowed addresses if that would be useful.


I'm confused what your issue is here, if you don't want your internet blocked if the VPN drops disable network lock.

Share this post

Link to post

I think you are misunderstanding the problem.  You have to activate the network lock before you connect.  You cannot activate it after.  It seems as if you thought I was activating it after I connected and then it dropped my current internet connections.  The purpose of the network lock is to prevent "leaks" as people call them, sure.  But this is between the time when you lose a connection and it reconnects.  Again, that is not the issue.  Maybe it's my fault.  I may have not been specific enough.  I will go through the steps.

1. I start with a fresh computer, just turned it on.

2. I start the Eddie program.

3. I select "Activate Network Lock".

4. I select "Connect to a recommended server".

5. It connects somewhere and it shows the upload/download speed screen.

6. No internet!


It is only supposed to have no internet if it lost its connection.  I have no internet all of the time.  I used to do the above steps and I could immediately access the internet like normal and programs could do the same.  If I lost connection to a server via Eddie, I would lose all internet until it connected to a new server.  This is how the lock prevents the leaks.  But it is supposed to allow me to get on the internet when I am connected to a server.  It doesn't.


My understanding is the above suggestions are basically ways to bypass the tunnel created by Eddie.  I don't want to do that.  As you said, that's the point of the network lock.  Right now, the GUI shows that everything is working fine and the tunnel created with the VPN is open and active.  Not mine.  No traffic in or out, ever.


Now, as I previously stated, this is a clean install of 2.15.2.  I have not modified any settings what so ever.  I do not know what version I was using before, but I know it was not this one.  I never changed any settings with that one and it just worked.  With this new version, do I have to change settings somewhere?


I hope this clears things up.


Share this post

Link to post

Oh, well that certainly helps clarify the situation. Taking a look through your logs I noticed with the network lock on there are a few disconnections, I imagine that might have been you trying different servers. The only suggestions I can make are:


In options -> advanced -> uncheck "check tunnel works", although that's probably not ideal.


Also, I noticed this in your logs:



I 2018.08.05 20:27:03 - Checking route IPv6

. 2018.08.05 20:27:23 - curl: (28) Connection timed out after 20015 milliseconds
. 2018.08.05 20:27:23 - Checking route (2° try)
. 2018.08.05 20:27:44 - curl: (28) Connection timed out after 20015 milliseconds
. 2018.08.05 20:27:44 - Checking route (3° try)
. 2018.08.05 20:28:06 - curl: (28) Connection timed out after 20015 milliseconds
E 2018.08.05 20:28:06 - Checking route IPv6 failed.


try going to options -> networking -> layer IPv6 and choosing 'block' or 'inside tunnel if supported otherwise blocked'. curl seems to be stuck trying to see if v6 works (I assume these are gen2 servers).


maybe try the same for dns -> check AirVPN DNS and perhaps try different protocols. Essentially trying different things to understand where the problem may lie, I can't offer more than that, but perhaps raising a ticket the staff may be able to help you further.

Share this post

Link to post
Of course there is something wrong, but I have not yet identified what...

I think there are at least two different issues, one related to NetLock, and another one is related to IPv6. We start focusing on the first issue.


Open a ticket if you want to talk with me privately. Or write here, for me it doesn't matter.


If I understand correctly, Internet works if you don't use Network Lock, right?

It's a Windows 7. It's not a problem, but do you have any other PC in the same lan to check? 


At the moment, please perform these steps:


Go to Settings -> Networking -> Layer IPv6 and switch it to "Block".



- Open Eddie

- DON'T activate NetLock

- Connect to Tyl server (double-click it in servers list).

- Check if Internet works (go to ipleak.net for example).

- Disconnect

- Generate a full-log (lifebelt), name it "without-netlock.txt".

- CLOSE Eddie


2) Repeat the same, but activate the NetLock before connecting. Name the log "with-netlock.txt". Please, connect to the same server, Tyl.


3) Go to Settings -> Network Lock -> Mode and pick "Windows Firewall". Repeat the 2). Name the log "with-wf.txt".


Thanks for your patience.

Share this post

Link to post

Had the same issue with 2.15.2. I decided to install the experimental version of Eddie (2.16.2); and lo and behold, it works now (for me at least ).

Share this post

Link to post

Guys, I had this problem after updating to Eddie: 2.18.9. It seems it's a recurring bug.
Just make sure your Eddie settings are the same as before after updating.
Make sure you go into your internet security firewall program list and allow connections with everything related to AirVPN.
Usually most of the things named and located in your default storage folder: C:\Program Files\AirVPN


1: openvpn.exe
2: curl.exe
3: stunnel.exe
4: plink.exe

In General settings of Eddie, for now (if you don't like it), make sure "Connect at start up", "activate network lock at start up" and "start with system" are checked to force Windows to recognise it as a trusted program.
After doing the above, you may find it doesn't work straight away.
Keep using Eddie without Network Lock for a little while (hour or so). Restart 3 times, and switch off your PC.
Upon reboot, hopefully, all should be working.

If you have a ipv6/ipv4 loop, etc... Try the settings in the following post: https://airvpn.org/forums/topic/46285-eddie-2189-desktop-released/page/2/?tab=comments#comment-106505

This is usually a bug. If the above doesn't work for you, try opening a ticket.

Kind regards

Share this post

Link to post
This topic is now closed to further replies.

  • Create New...