Jump to content
Not connected, Your IP: 184.73.14.222
Britman

ANSWERED No Internet after using eddie

Recommended Posts

So I installed eddie on Ubuntu 18.04 and it all seemed to go well.

however when I disconnect the VPN my Internet no longer works, even if I leave eddie running or close the program. I can still access my local network but pinging Google fails. This has only been happening since I first tried the GUI, I normally connect via the terminal. I was always able to reconnect to my ISP after ending the VPN session. But now, even connecting via the terminal and after ending a VPN session (ctrl+C) the Internet is still no longer accessible.

 

 

 

Thanks.

Share this post


Link to post

That is because Eddie does more than simply establish a tunnel. It also disables IPv6, changes DNS settings, enables NetLock and some more things.

 

It looks like a DNS or NetLock issue, so check if iptables are empty and resolv.conf is back to normal.

$ sudo iptables -L
Chain INPUT (policy ACCEPT)
target     prot opt source               destination         

Chain FORWARD (policy ACCEPT)
target     prot opt source               destination         

Chain OUTPUT (policy ACCEPT)
target     prot opt source               destination
$ less /etc/resolv.conf

resolv.conf should not contain comments from Eddie.


Always remember:
There's a guide to AirVPN,

Amazon IPs are not dangerous here,
running TOR exits is discouraged,

using spoilers for your logs helps us read your thread.

~ Furthermore, I propose that your paranoia is to be destroyed. ~

Instead of writing me a personal mail, consider contacting me via XMPP at gigan3rd@xmpp.airvpn.org or join the lounge@conference.xmpp.airvpn.org. I might read the mail too late whereas I'm always available on XMPP

Share this post


Link to post

Hi, thanks for the fast reply.

sudo iptables -L gave the same result as you quoted. However less /etc/resolv.conf gave this result.

 

# Generated by Eddie v2.13.6 | https://eddie.website

nameserver 10.4.0.1

I set my IP, Netmask and gateway manually if that has any bearing on the matter

Share this post


Link to post

Seems like the original resolv.conf is not being restored, allowing the conclusion that it is indeed a DNS issue. This is, if my memory serves me right, known but I've known it only in older versions. You could try a connection with one of the two methods selected manually in Preferences > DNS > Mode - I think your current setting is Automatic. Try them both, Renaming and Resolv.conf sound very similar.

Also, check if there is an Eddie update available. The most recent version seems to be 2.14.5. Update and repeat the procedure with Automatic setting. Tell us about the results.

 

As a workaround, set the DNS of your primary network interface statically to 10.4.0.1 and in the preferences, set the DNS changing mode to None. Linux gives you much more control over network settings than Windows, so it should be possible to create a second profile in your network manager. For example, I've got one for complete DHCP and one with the aforementioned static DNS entry. This works for me seamlessly.


Always remember:
There's a guide to AirVPN,

Amazon IPs are not dangerous here,
running TOR exits is discouraged,

using spoilers for your logs helps us read your thread.

~ Furthermore, I propose that your paranoia is to be destroyed. ~

Instead of writing me a personal mail, consider contacting me via XMPP at gigan3rd@xmpp.airvpn.org or join the lounge@conference.xmpp.airvpn.org. I might read the mail too late whereas I'm always available on XMPP

Share this post


Link to post

So I installed eddie on Ubuntu 18.04 and it all seemed to go well.

however when I disconnect the VPN my Internet no longer works, even if I leave eddie running or close the program. I can still access my local network but pinging Google fails. This has only been happening since I first tried the GUI, I normally connect via the terminal. I was always able to reconnect to my ISP after ending the VPN session. But now, even connecting via the terminal and after ending a VPN session (ctrl+C) the Internet is still no longer accessible.

 

 

 

Thanks.

I have the same problem using OS X High Sierra and it's a recent issue. I updated to Eddie 2.14.5, no change. I reversed to the default settings, same problem.

I checked the solution given here but, for what I understand (little) it doesn't apply to OS X.

 

Any idea?

Share this post


Link to post

Please open your own thread for this, append logs and other useful info if you need to do so. Since OP marked this thread as solved, chances are your inquiry will be blatantly ignored. :)

 

Also, the fact you are using macOS, another OS with other things to look out for, makes your issue distinct from OP's.


Always remember:
There's a guide to AirVPN,

Amazon IPs are not dangerous here,
running TOR exits is discouraged,

using spoilers for your logs helps us read your thread.

~ Furthermore, I propose that your paranoia is to be destroyed. ~

Instead of writing me a personal mail, consider contacting me via XMPP at gigan3rd@xmpp.airvpn.org or join the lounge@conference.xmpp.airvpn.org. I might read the mail too late whereas I'm always available on XMPP

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Security Check
    Play CAPTCHA Audio
    Refresh Image

×
×
  • Create New...