Jump to content
Not connected, Your IP: 54.161.31.247
ssling

Using one server all the time - privacy risk?

Recommended Posts

I currently connect to the same sever all the time (I auto-connect through NetworkManager on Linux) and I wonder if it's all right or maybe should I rather change servers on regular basis? I don't have any issues with that server, it's reliable, fast, just works great for me so I didn't care changing it in past couple months. What do you think?

Share this post


Link to post

I currently connect to the same sever all the time (I auto-connect through NetworkManager on Linux) and I wonder if it's all right or maybe should I rather change servers on regular basis? I don't have any issues with that server, it's reliable, fast, just works great for me so I didn't care changing it in past couple months. What do you think?

I would say choose 4 servers that work for you.(based on location/latency etc.)

In OpenVPN config file for your .opvn add/modify it like this, (if you haven't done this already):

-------------------------------------

remote-random

remote server1.airvpn.org 443

remote server2.airvpn.org 80

remote server3.airvpn.org 2018

remote server4.airvpn.org 53

--------------------------------------

OR

--------------------------------------

remote-random

remote us.airvpn.org

--------------------------------------

choose the server by IP, if it turns out server name/address cannot be resolved when connecting...

See if that works for you,

Regards,

Flex

Share this post


Link to post

I, too, switch servers frequently. Connecting to the same server all the time is not a huge privacy issue in itself, though, I guess. Flx's solution is a very convenient way to achieve effortless switching with NetworkManager. Since you seem to be using GNU/Linux you can also have a look at an app I have written. It integrates nicely with GNU/Linux DEs and was actually inspired by the NetworkManager applet. Have a look at this thread if you are interested. It's an early release, though, and only installable via github atm.

Share this post


Link to post

 

I currently connect to the same sever all the time (I auto-connect through NetworkManager on Linux) and I wonder if it's all right or maybe should I rather change servers on regular basis? I don't have any issues with that server, it's reliable, fast, just works great for me so I didn't care changing it in past couple months. What do you think?

I would say choose 4 servers that work for you.(based on location/latency etc.)

In OpenVPN config file for your .opvn add/modify it like this, (if you haven't done this already):

-------------------------------------

remote-random

remote server1.airvpn.org 443

remote server2.airvpn.org 80

remote server3.airvpn.org 2018

remote server4.airvpn.org 53

--------------------------------------

OR

--------------------------------------

remote-random

remote us.airvpn.org

--------------------------------------

choose the server by IP, if it turns out server name/address cannot be resolved when connecting...

See if that works for you,

Regards,

Flex

 

Hey, thanks but it doesn't seem to work for me. It always connects to the last server I put one the list instead of choosing randomly. I have something like that in config file:

 

remote-random

remote 213.152.161.68 443

remote 213.152.161.9 443

remote 213.152.162.108 443

remote 213.152.161.24 443

remote 109.232.227.148 443

remote 213.152.161.73 443

 

and it connects only to 213.152.161.73. I don't connect through CLI but through Network Manager and I guess it might be NM limitation.

Share this post


Link to post

I don't connect through CLI but through Network Manager and I guess it might be NM limitation.

NM limitation yes it's possible....tested your remote-random(servers by IP) in Windows 10 and it does rotate the servers.

Test the app developed by corrado.....and see if that does work in your case.

If you wish to rotate the servers every 60 mins create a script.sh run it as a cron job for OpenVPN.(keep alive 10 60). Till now I only did this for Windows platform(s)-keep-alive bat files that do work. It is maybe easier in Linux\Unix. restaring OpenVPN make sure it will not connect to the same server. Use server1.airvpn.org format in the script you can cut/tr/bash vars commands. and time your OpenVPN connection in the script. when it hits 0 restart the openvpn process point it to a different server2.airvpn.org.

I can look into it for you if you like. You can ask corrado LZ1 or giganerd of what they think as a better option.

Let me know how things go

Regards,

Flex

Share this post


Link to post

I had that same issue when I was running config'd as you.  I didn't seem to see which Linux flavor you are running, but I wanted to point out something that I find is secure and works great.  You may just flat out NOT want to employ Eddie on your system but I have looked it over (open source code) and find it to be excellent.  Anyway, I run Eddie on my linux host and have it configured so that it doesn't auto-login.  I simply click the server list (you can pre-select which servers display on the list) and its one click to pick my server for the session.  Couldn't be more simple, and again that would be any country or as you pre-determine you want your list of available servers displayed.

 

Suggestion to Staff:  One Eddie feature that I feel would be nice (optional of course determined by user) would be a NOT last server option.  In other words I would never connect to the server I used last session.  Don't know if many others here would use such a feature but I would like it offered.  Just sayin!

Share this post


Link to post

Hey, thanks but it doesn't seem to work for me. It always connects to the last server I put one the list instead of choosing randomly. I have something like that in config file:

 

remote-random

remote 213.152.161.68 443

remote 213.152.161.9 443

remote 213.152.162.108 443

remote 213.152.161.24 443

remote 109.232.227.148 443

remote 213.152.161.73 443

These are all NL servers as far as I know. Use this and see if it works:

--------------------------------------

remote-random

remote nl.airvpn.org 443

--------------------------------------

where nl.airvpn.org 443 gives you all the Air servers located in Netherlands.

Try it that way.

Share this post


Link to post

Hi,

 

I was wondering about this thing of always connecting to the same server too. I run the generated airVPN generated config .ovpn config file on the commandline.

 

The remote is as follows:  europe.vpn.airdns.org 443

 

There is no entry for remote-random in the file by default.

 

I always get connect to "Altarf" in Sweden.

 

 

Just saying that maybe the generated config file should have remote-random enabled.
 

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Security Check
    Play CAPTCHA Audio
    Refresh Image

×
×
  • Create New...