Jump to content
Not connected, Your IP:
Sign in to follow this  

After rebooting pFsense, I have to restart OpenVPN - is there a fix?

Recommended Posts



After rebooting pfsense, the openvpn service starts however I don't have internet access over avpn until I manually restart the service again.


This has been an ongoing issue and was hoping there might have been a fix with the most recent update.  Guess not.  Any idea how to fix this?






Share this post

Link to post

Go to the package manager and install "Service_Watchdog" package. It monitors for stopped services and restarts them.


Once installed, configure it and make sure openvpn is monitored.

Have my guides helped you? Help me keep helping you, use my referral: userbar.png

How to set up pfSense 2.3 for AirVPN

Friends don't let friends use consumer networking equipment!

Share this post

Link to post

Hey thanks for the tip!   So does this imply the service is not starting on reboot? It looks like it started but I had to restart it to get it working.


I configured it but it says there is a newer version available (currently 1.8.3) and it says it's "configured but not fully installed".  What does that mean? Where are the email settings for notifications?


Off topic here, I see there is a vmtools package! Is it recommended to install it given pfsense is a vmware vm?

Share this post

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Security Check
    Play CAPTCHA Audio
    Refresh Image
Sign in to follow this  

  • Create New...