Jump to content
Not connected, Your IP: 3.235.101.141
Sign in to follow this  
greenclaydog

I cannot add other providers, Eddie reverts to original options upon startup

Recommended Posts

Staff, i am attempting to use Eddie to help me trial ProtonVPN using the .ovpn files they provided, however when i add the lines of code:

 

<providers>
<OpenVPN title="ProtonVPN" path="C:\Users\User\Downloads\ProtonVPN_config\">
</providers>

 

The client gives me this error

 

 

I 2017.03.14 17:32:02 - Eddie client version: 2.11.15 / windows_x64, System: Windows, Name: Microsoft Windows NT 10.0.14393.0, Mono/.Net Framework: v4.0.30319
. 2017.03.14 17:32:02 - Reading options from C:\Users\User\AppData\Local\AirVPN\AirVPN.xml
F 2017.03.14 17:32:02 - Sorry, an error occurred during loading options. Options reverted to default.
. 2017.03.14 17:32:05 - Data path: C:\Users\User\AppData\Local\AirVPN
. 2017.03.14 17:32:05 - Application path: C:\Program Files\AirVPN
. 2017.03.14 17:32:05 - Executable path: C:\Program Files\AirVPN\AirVPN.exe
. 2017.03.14 17:32:05 - Command line arguments (1): path="home"
. 2017.03.14 17:32:05 - Operating System: Microsoft Windows NT 10.0.14393.0
I 2017.03.14 17:32:05 - OpenVPN Driver - TAP-Windows Adapter V9, version 9.21.2
I 2017.03.14 17:32:07 - OpenVPN - Version: 2.4.0 - OpenSSL 1.0.2k  26 Jan 2017, LZO 2.09 (C:\Program Files\AirVPN\openvpn.exe)
I 2017.03.14 17:32:07 - SSH - Version: plink 0.67 (C:\Program Files\AirVPN\plink.exe)
I 2017.03.14 17:32:07 - SSL - Version: stunnel 5.40 (C:\Program Files\AirVPN\stunnel.exe)
. 2017.03.14 17:32:07 - Updating systems & servers data ...
! 2017.03.14 17:32:07 - Ready
. 2017.03.14 17:32:08 - Systems & servers data update completed

 

I also tried removing the backslash at the end of the path, but that did not work either. What am i doing wrong?

 

EDIT: also, i did place the code after Eddie and before options.

Share this post


Link to post

Seems only way is to add it in the /ovpn path in the installed folder with the latest experimental version however using that method idk how to use servers that require login info.

Share this post


Link to post

Seems only way is to add it in the /ovpn path in the installed folder with the latest experimental version however using that method idk how to use servers that require login info.

 

Yeah, ProtonVPN requires a username and password to be inputted. 

 

Is this error I'm getting a bug? Or am i doing it wrong? 

Share this post


Link to post

 

Seems only way is to add it in the /ovpn path in the installed folder with the latest experimental version however using that method idk how to use servers that require login info.

 

Yeah, ProtonVPN requires a username and password to be inputted. 

 

Is this error I'm getting a bug? Or am i doing it wrong?

 

I don't know me and some others are doing it same way and get same error but others it seems to work for and we got no support for it sadly...

Share this post


Link to post

Seems only way is to add it in the /ovpn path in the installed folder with the latest experimental version however using that method idk how to use servers that require login info.

 

I don't understand that - could you explain that a bit please? Put hat in which folder? the .ovpn in the Eddie folder? I need a workaround here badly ...

Share this post


Link to post

Is this error I'm getting a bug? Or am i doing it wrong?

Sorry about the delay.

The syntax must be:

<providers>
<OpenVPN title="ProtonVPN" path="C:\Users\User\Downloads\ProtonVPN_config\"/>
</providers>
with a backslash before the closing >, and NOT:
<providers>
<OpenVPN title="ProtonVPN" path="C:\Users\User\Downloads\ProtonVPN_config\">
</providers>
It's not your fault, the docs here it's fixed now. Sorry.

 

Anyway, with 2.12 you don't need to do that anymore, simply add a "ovpn" directory inside your data directory.

 

About "Login & password", Eddie right now don't prompt in UI, but you can close Eddie, edit AirVPN.xml, you will find the piece of code "

and change like his:

<OpenVPN title="Custom Profiles 1" path="d:\archive\ovpn1\" login="mylogin" password="mypassword">
It will be improved in next versions, please be patient.

Share this post


Link to post

 

Is this error I'm getting a bug? Or am i doing it wrong?

Sorry about the delay.

The syntax must be:

<providers>
<OpenVPN title="ProtonVPN" path="C:\Users\User\Downloads\ProtonVPN_config\"/>
</providers>
with a backslash before the closing >, and NOT:
<providers>
<OpenVPN title="ProtonVPN" path="C:\Users\User\Downloads\ProtonVPN_config\">
</providers>
It's not your fault, the docs here it's fixed now. Sorry.

 

Anyway, with 2.12 you don't need to do that anymore, simply add a "ovpn" directory inside your data directory.

 

About "Login & password", Eddie right now don't prompt in UI, but you can close Eddie, edit AirVPN.xml, you will find the piece of code "<openvpn",

and change like his:

<OpenVPN title="Custom Profiles 1" path="d:\archive\ovpn1\" login="mylogin" password="mypassword">
It will be improved in next versions, please be patient.

 

Thanks, adding that backslash seemed to do the trick!

 

Now, for anyone trying to do this, backup your original AirVPN.xml, adding providers changes the code, and if you simply try to delete the providers code the client will completely reset the file on startup.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Security Check
    Play CAPTCHA Audio
    Refresh Image
Sign in to follow this  

×
×
  • Create New...