Jump to content
Not connected, Your IP: 3.92.28.52
uatavpn

how to use only AirVPN DNS (Linux/OpenVPN/router)?

Recommended Posts

read through thread after thread and i can't solve this... i need DNS to work both within and outside of the VPN (using a different connection), but when the tunnel connection is active, i want to use only the DNS provided by the Air servers

 

mint 18.1/opendns

 

process should be straight forward: config gen > advanced > resolve host names > generate > change 'opvn' extensions to 'conf' and dump files in /etc/openvpn

 

router (tomato): advanced > DHCP/DNS > 'Use internal DNS' ??? i don't know, but doesn't seem to work without this selected - 'Use received DNS with user-entered DNS' ??? i don't know

 

OS: connection editor > IPV4 > method: tried 'automatic' and 'automatic (addresses only)' - no DNS servers added to the IPV4 tab (shouldn't need any since domains were resolved when i gen'd the config's?)

 

so when i restart openvpn and connect to the connection i created, i expect that no DNS lookup should be needed to reach the VPN because the IP's were resolved when i gen'd the config files - and after i connect, i should be using the VPN DNS, however i cannot even connect to the servers

 

adding 10.4.0.1 to resolv.conf does not survive a reboot and nothing else i've tried works

 

the only way i can connect seems to be to set 'method' to 'automatic' in the connection editor and use the random DNS servers configured in the router - so when i go to ipleak.net, i'm connected to the VPN, but the DNS is not provided by the VPN server

Share this post


Link to post

In mint: I suggest you use the Eddie client.  It switches DNS when connected and switches back to regular DNS when disconnected.  Just go through the disconnection process, don't close the app forcefully.

 

IN tomato: is there another option to use received DNS only?  IF so, I'd use that.

Share this post


Link to post

I'm kind of a newbie to all of this compared to most folks here, AND I'm not 100% sure I even understand your question, but others have been very helpful to me so I figured I'd give helping someone else a shot..

 

When I use AirVPN on my Asus (stock firmware) router, I first change the DNS selection in the WAN menu from "connect automatically" to "manual," where I've entered the AirVPN server, 10.4.0.1 and a second server taken from the OpenNic site.  After that, I activate the VPN client and choose one of the AirVPN config files I've uploaded.  After a couple seconds, everything works.  To go back to non-VPN usage, first turn off the vpn client on the router, then return the DNS selection setting to automatic.  It took me WAY longer to type this than it does to actually make the switch.. once you've done the routine a few times, it's just a few key strokes. 

 

I've only got a nodding acquaintance with Linux, but I'm a little confused by your original post; it seems like you're manipulating settings on your OS as well as your router, and I don't think you need to do that.. just get your router to use your manual DNS settings and leave your OS alone, no?  Maybe I'm misunderstanding what you're trying to do..

 

Hope that helps a bit.

Share this post


Link to post

@ToastyTheEel - thanks for your help - i'm doing essentially what you're doing, except not on the router

 

i'm just going to drop this at this point and wait on the upcoming Eddie 3.x release which is supposed to do-away with the Mono dependency

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Security Check
    Play CAPTCHA Audio
    Refresh Image

×
×
  • Create New...