Jump to content
Not connected, Your IP: 3.80.6.131
SonicMetal15

So far VPN working by not revealing my actual public IP address except for this site...why?

Recommended Posts

So I followed this guide in setting up AirVPN with my pfSense box:

 

https://airvpn.org/topic/17444-how-to-set-up-pfsense-23-for-airvpn/?do=findComment&comment=40144

 

Everything looked good - I was able to browse the internet and dnsleak.com reported only one leak (the AirVPN DNS server I was using). I went to a couple of websites that report your public IP address just to make sure, such as whatismyip.com and even google.com can do it too, and they all showed the VPN server IP...except for this site: whatismyipaddress.com

 

That website actually reported my true public IP address when all the others didn't. How is that possible? Do you guys get the same results? Does this mean I didn't set this up properly? How secure is my VPN connection and does it have to do with the particular AirVPN server I chose to connect to? I will try a different server tomorrow and see if I get the same results.

Share this post


Link to post

I am guessing there is a mistake in your setup. I am using the same setup and I don't have leaks at all. It is strange that only one site reports more than one server, though. Did you disable all ipv6 settings? It is enabled by default by pfsense.

 

Maybe the experts can chime in (Zhang?).

I just wanted to tell you that it's working for me.

Share this post


Link to post

Do you have Squid Proxy Server enabled? If so, disable it and check again.

Share this post


Link to post

Yes, I am running a Squid Proxy Cache server on pfSense.  So you think that's what's causing it?  But why only that website and not the others?  For security's sake though I will disable it, thank you.

Share this post


Link to post

Yes, I am running a Squid Proxy Cache server on pfSense. So you think that's what's causing it?

Could be, but it's just a guess. I'd try and see if it still leaks without squid. Maybe pfSense_fan can help in setting up squid (snort et cetera) for this particular configuration so that there are no leaks?

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Security Check
    Play CAPTCHA Audio
    Refresh Image

×
×
  • Create New...