Jump to content
Not connected, Your IP: 3.235.139.152
Sign in to follow this  
unitymedia-vpn-info

how to: get good speed on Unitymedia

Recommended Posts

Just got AirVPN - very impressed overall! I had some issues and only got -4 mbps and dropped connections all over the place on my 120mpbs line on Unitymedia / Kabel BW (German ISP).

I had to change this is the configuration file to easily get >60 mbps now. (And I believe the 60 mbps limit is because Unitymedia has horrible peering to the server I used)

 

proto tcp

sndbuf 0
rcvbuf 0
mssfix 1250
 
proto tcp is because my DS Lite CGNAT seems to be overwhelmed with lots of UDP traffic, mssfix fixes some broken MTU path discovery somewhere along the way and sndbuf/rcvbuf allow openvpn to decide what the best buffer sizes are. Hope this helps someone!

Share this post


Link to post

Just wanted to say THANK YOU so much for this post. I was fiddling around for a good day with all kinds of configurations to no avail. Only was getting about 500kb/s to max. 1MB/s, now I get up to 9MB/s. Can recommend this to all Unitymedia customers!

Share this post


Link to post

I found these parameters work good on Spectrum(former TWC). UDP port 443. TCP works too but other ports seem throttled.

mtu-disc no

tun-mtu 24000

mssfix 0

fragment 0

sndbuf 0

rcvbuf 0

 

Best off to leave the fragmenting to the OS, at least on my Linux based router.

 

For an Android on T-Mobile, any port seems to work fine but use UDP.

mtu-disc no

tun-mtu 23552

mssfix 0

fragment 0

sndbuf 0

rcvbuf 0

 

Pretty much same thing, letting OS fragment it but tun-mtu is a multiple of 1472 instead of 1500, compensating for the IPv4 interface having a 1472 mtu, allowing exactly 16 packets in processing by OpenVPN. I find this makes for a consistent data stream.

Share this post


Link to post
Guest

 

Just got AirVPN - very impressed overall! I had some issues and only got -4 mbps and dropped connections all over the place on my 120mpbs line on Unitymedia / Kabel BW (German ISP).

I had to change this is the configuration file to easily get >60 mbps now. (And I believe the 60 mbps limit is because Unitymedia has horrible peering to the server I used)

 

proto tcp

sndbuf 0
rcvbuf 0
mssfix 1250
 
proto tcp is because my DS Lite CGNAT seems to be overwhelmed with lots of UDP traffic, mssfix fixes some broken MTU path discovery somewhere along the way and sndbuf/rcvbuf allow openvpn to decide what the best buffer sizes are. Hope this helps someone!

Where do i have to enter this?

Share this post


Link to post

 

 

Just got AirVPN - very impressed overall! I had some issues and only got -4 mbps and dropped connections all over the place on my 120mpbs line on Unitymedia / Kabel BW (German ISP).

I had to change this is the configuration file to easily get >60 mbps now. (And I believe the 60 mbps limit is because Unitymedia has horrible peering to the server I used)

 

proto tcp

sndbuf 0
rcvbuf 0
mssfix 1250
 
proto tcp is because my DS Lite CGNAT seems to be overwhelmed with lots of UDP traffic, mssfix fixes some broken MTU path discovery somewhere along the way and sndbuf/rcvbuf allow openvpn to decide what the best buffer sizes are. Hope this helps someone!

Where do i have to enter this?

 

In Eddie client:

 

Preferences>OVPN directives>Custom directives

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Security Check
    Play CAPTCHA Audio
    Refresh Image
Sign in to follow this  

×
×
  • Create New...