Jump to content
Not connected, Your IP:

Setting up SSH on Linux with OpenVPN

Recommended Posts

I am trying to use AirVPN to SSH into a computer. How do I do this?

I have tried the .sh file I got from the SSH tutorial, but when I try to connect to the computer running it, I can never log in (permission denied).

Trying to use OpenVPN as root with the .ovpn file caused errors about not being able to connect.

Share this post

Link to post

good to meet ya, yer first post


aaahhhhh the ssh joyz, i still get them myself


easiest way to get help with your ssh is post up some logs

use verbose blur out anything don't want others to read

or copy paste and use 'xxxxx' sumthin like that


here's a link to help with troubleshooting

but back to your question first it could literally be a number of things

why the logs will help so can at least narrow it down


for myself a lot of the times yeah it was permissions and i had my permissions set wrong

another time i forgot i had my firewall to allow only xyz ip addy and that was on my own

network, i literally spent a few hours 'troubleshooting' my own security i set in place


tbh what i basically did when starting out on ssh was dial into the box next to me and just kept tweaken it

till i got the security settings i liked and the configs i liked


one time i forgot to turn ssh on on the other box so can be many things

sometimes it'd work for me other times not you can copy id and it's automagical


anyway here's a link to help in the meantime:




Share this post

Link to post



I realized I was doing something wrong, and now I realize I probably should run the sh file on the target PC (one I want to connect to with SSH) and the ovpn file on the PC I am trying to connect with (the 'client'). Or maybe the other way around? Either way, I still get connection problems.


When running the ovpn file, I get "TCP: connect to [AF_INET] failed" on both client and target.


Using the sh file on the client machine I get prompted for sshtunnel@[target's AirVPN IP address]'s password, and on the target machine I get "ssh: connect to host [target's AirVPN IP address] port 22: No route to host"


The ssh daemon is turned on for the target, but not the client.

Share this post

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Security Check
    Play CAPTCHA Audio
    Refresh Image

  • Create New...