Jump to content
Not connected, Your IP: 3.233.224.8
breathfree

Google knows real location while connected to AirVPN

Recommended Posts

Hey,

 

Im wondering what I missed.

 

The problem is that google still suggests me search results for my real location.

 

WebRTC is disabled checked via:

 

https://ipleak.net/

http://www.browserleaks.com/webrtc

 

No DNS Leak checked via:

https://ipleak.net/

https://www.dnsleaktest.com/

 

Im using a totally fresh Firefox copy on Windows 7.

I only searched for some queries with my real IP.

I closed the browser. Enabled AirVPN via the AirVPN software.

Restarted the browser... but Google still gives me result from location where I live. (Tells me the region "based on my ip")

I do not search for location sensitive search terms. Just "car", "tree" ... etc normal words.

 

I connected to serveral Servers, Netherlands, Canada.. etc.

The same result.. google still know my location. (I closed and restarted Firefox before I changed AirServer)

 

I also erased the firefox profile via (firefox -p) and created a new one.

Im also using the privacy options from here: https://github.com/pyllyukko/user.js/

Geolocation etc disabled...

 

Visiting google with a fresh installed Opera Browser while being connected all the time to Cananda AirVPN (ipleak.net says Im unsing AirVPN Exit Node) google still gives me result for my region if I search for eg. "bike" (and tells me by region).

 

Does anyone has any suggestion?

Does anyone have the same problem?

 

Thank you in advanced.

 

 

 

Update:

I installed again a fresh and different version of Firefox.. no changes.

Perhaps a useful information: if I go to https://www.google.ca/ it says "Unknown location",
but if I go to https://www.google.de/ it tells me my true location/region (of course while connected to AirVPN via software)
The address is only 'https://www.google.de' (no engineid [&ei=] etc.)

 

Important Anomaly:

The extended dns leak test on https://www.dnsleaktest.com/ shows in 2 of 10 runs a german DNS address while

connecting to a Canadian AirVPN Server with AirVPN Software. Windows 7 network setting "Use the following DNS" is set to '10.4.0.1.'

Can anyone provide more information to this problem?

 

Fixed update:

I think I "fixed" it. I disabled IPv6 support in the router.

Now https://www.dnsleaktest.com/ always only shows AirVPN DNS.

Googling via https://www.google.de/ says "Unkown location" (perhaps because I reconnected with a new IPv4)

 

 

My question now: Are there any known problems when connecting with IPv6? Thank you! (Only system configuration for IPv4 was automatically set during the installation of the AirVPN software, but not for IPv6).

 

The main problem remains:

Googling for one search without AirVPN Browser. Cleaning everything.., Connecting to AirVPN

https://www.google.de/ still shows me my true location/region all the time.

Share this post


Link to post

This has been mentioned loads of times, this should cover it.

 

There is rarely any reason to install/reinstall any software, it will make no difference to anything apart from probably losing all your secure and other settings you carefully set up. So fresh copies of firefox will in fact be less secure since you wiould probably want to alter some of the location config settings.

Share this post


Link to post

Try in Firefox in adress bar "about:config"

Press enter.

 

Search for "geo.enabled" change from true to false via double click.

 

Regards,

Me

Share this post


Link to post

Try in Firefox in adress bar "about:config"

Press enter.

 

Search for "geo.enabled" change from true to false via double click.

 

Regards,

Me

Thank you for suggesting, but I already used this property (of course after reinstallations)

 

 

This has been mentioned loads of times, this should cover it.

 

There is rarely any reason to install/reinstall any software, it will make no difference to anything apart from probably losing all your secure and other settings you carefully set up. So fresh copies of firefox will in fact be less secure since you wiould probably want to alter some of the location config settings.

 

Thank you for linking. Accessing https://www.google.com/maps/ via AirVPN does no more reveal my location (also after disconnecting and reconnecting/visiting the website with my ISP IP).

If anyone else has the same problem, try to disable IPv6 support / ISP IPv6s (I think it was the main problem that DNS IPv6 was accesible)

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Security Check
    Play CAPTCHA Audio
    Refresh Image

×
×
  • Create New...