Jump to content
Not connected, Your IP: 3.236.143.154
Sign in to follow this  
allshinesun

Eddie portable no mono on Ubuntu 16 stopped working suddenly after hard reboot will not initiate now

Recommended Posts

So a couple of hours ago my client crashed after I had a freeze(to many windows open) and was forced to hard reboot. The client normally runs phenomenally, I have crappy graphics card so 16 crashes from time to time if I'm working on a lot and I've never had issue reconnecting. This time, however, after logging into my computer and starting up the client it gives the following error in terminal and the icon does its little dance and disappears, signifying it does not want to play

 

Unhandled Exception: System.TypeInitializationException: An exception was thrown by the type initializer for Mono.Unix.Native.Syscall ---> System.DllNotFoundException: $mono_libdir/libMonoPosixHelper.so
  at (wrapper managed-to-native) Mono.Unix.Native.Syscall:_L_ctermid ()
  at Mono.Unix.Native.Syscall..cctor () [0x00000] in <filename unknown>:0
  --- End of inner exception stack trace ---
  at AirVPN.Platforms.Linux.GetExecutablePath () [0x00000] in <filename unknown>:0
  at AirVPN.Core.Platform.GetProgramFolder () [0x00000] in <filename unknown>:0
  at AirVPN.Core.Engine.Initialization () [0x00000] in <filename unknown>:0
  at AirVPN.UI.Linux.Program.Main () [0x00000] in <filename unknown>:0
[ERROR] FATAL UNHANDLED EXCEPTION: System.TypeInitializationException: An exception was thrown by the type initializer for Mono.Unix.Native.Syscall ---> System.DllNotFoundException: $mono_libdir/libMonoPosixHelper.so
  at (wrapper managed-to-native) Mono.Unix.Native.Syscall:_L_ctermid ()
  at Mono.Unix.Native.Syscall..cctor () [0x00000] in <filename unknown>:0
  --- End of inner exception stack trace ---
  at AirVPN.Platforms.Linux.GetExecutablePath () [0x00000] in <filename unknown>:0
  at AirVPN.Core.Platform.GetProgramFolder () [0x00000] in <filename unknown>:0
  at AirVPN.Core.Engine.Initialization () [0x00000] in <filename unknown>:0
  at AirVPN.UI.Linux.Program.Main () [0x00000] in <filename unknown>:0

 

I've only been on ubuntu a few months and have come leaps and bounds, but this is chinese to me. Can anyone translate?

Share this post


Link to post

Somehow your system cannot find a critical file called llibMonoPosixHelper.so.

Are you using the portable version or the installation package?

 

You should try to reinstall the client (in case of installation package) or extract it again in case of the portable.

This should recheck the mono dependencies as well.


Occasional moderator, sometimes BOFH. Opinions are my own, except when my wife disagrees.

Share this post


Link to post

It is the portable. I deleted and redownloaded/extracted and ran for the same errors. I was using the portable because the libmono dependency issues where I have a newer version than is required to install the deb file. I couldn't ever find an answer to solve that issue and after hours of looping between install -f and attempting to manually install deps, then dpkg still reads the same errors. I wish i could wrap my head around building from source. I have mono-devel installed but cannot follow directions as I don't see the menu that it talks about to insert the github clone address within monodevel. Like I said I'm real new to linux and I love it, but only because it is such a challenge to learn. Such challenges are frustrating, and a little troubling as I was running portable client for 4 or 5 days uninterrupted  until I started blogging about this rigged US election. then it crashed. Sure thats paranoia speaking, but I feel uncomfortable without service at this point.

Share this post


Link to post

I can open the windows client with wine, but it wont connect either

 

The error I get when trying to connect through the exe on wine says driver not installed. any idea what driver I need?

Share this post


Link to post

Now trying to compile on monodevelop

 

Folowing https://airvpn.org/topic/12760-how-can-i-compile-the-source-code/

 

I imported the git, but cannot find a file called AirVPN.sln in the src directory. There are two different eddie....sln's.

 

Which if any should I debug?

 

It seems like when i open the vs2015 eddie I get the following error

 

Error while trying to load the project '/home/willynilly/Projects/AirVPN/airvpn-client.git/src/UI.WpfWeb.Windows/UI.WpfWeb.Windows.csproj': Could not find a part of the path "/home/willynilly/Projects/AirVPN/airvpn-client.git/src/UI.WpfWeb.Windows/UI.WpfWeb.Windows.csproj".

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Security Check
    Play CAPTCHA Audio
    Refresh Image
Sign in to follow this  

×
×
  • Create New...