Jump to content
Not connected, Your IP: 34.238.190.122
psychlops

Eddie 2.10.3 network lock breaks AirDrop on Mac, causes Airport Extreme confusion

Recommended Posts

No, still not working.

 

Perhaps it's good idea to check your AirDrop settings ?

 

-Access AirDrop by swiping up from the bottom of the screen to call up Control Center. From here your current AirDrop status will be displayed — you can choose between Off, Contacts Only, and Everyone.

Choose for "Everyone"

 

-For testing purpose try to disabling your firewall entirely ! Make sure that all incoming connections are not blocked, otherwise AirDrop will not work.


You're not afraid of the dark web, are you ?

Share this post


Link to post

It's been set to Everyone, it works with network lock disabled.

 

Turning off the firewall worked with network lock enabled! Still, I can't do without the firewall, so, like you said, it's for testing purposes. 

 

I found that turning off the firewall allows AirDrop to connect, and turning the firewall on again once it's connected doesn't break the connection. As long as the iPad is awake, AirDrop will keep working. But as soon as I close the iPad cover the connection is broken. 

 

 I've been trying to post this reply for the last 20 minutes, but I guess this forum is overloaded. Probably because of the US privacy laws. Bad for us here, good for AirVPN 

 

(and I had to go back to 2.12.4. I ditched 2.11.5 a while ago because it kept dropping my connection, and the same thing has been happening during this test. 2.12.4 seems to work better)

Share this post


Link to post

Your Mac comes with a built-in firewall, which prevents unwanted connections being made to your computer by blocking virtual ports. This can also have a detrimental effect on file transfers, particularly AirDrop.

Did you add Airdrop as an exception for incoming/outgoing connection ?

Make sure that "Block all incoming connections" is not checked !

 

Please note, there are many users that are having trouble with Airdrop, even the ones not using VPN/network lock/kill switch.

I'm afraid until Apple improves AirDrop, you might be tempted to simply not use it. Just my 2 cents.

 

A very good and rather stable alternative for Airdrop is VLC for IOS

See video tutorial please : https://www.youtube.com/watch?v=BQxDFeVqmTI

 

Wish you all the best buddy and good luck.


You're not afraid of the dark web, are you ?

Share this post


Link to post

Block all incoming connections is not checked. I added Eddie as an exception, but Airdrop isn't an app, so is it even possible to add it? I should also mention that I'm using Little Snitch, but I'm allowing Eddie and Airport all connections, so theoretically it's allowed both incoming and outgoing. If I disable Network Lock or the firewall, it works reliably for me. I haven't had any trouble, except when I enable both.

 

I really appreciate all the time you've spent on your replies! Even if it's a problem on Apple's end, disabling the firewall long enough to connect, then enabling it again is a better option than disconnecting Eddie / Network lock. It may be a clunky workaround, but it's still a workaround.

 

If you can suggest a way to add Airdrop as an exception to the firewall, I'll try that. In any case, thanks again and I just bought you and your family a virtual meal at the restaurant of your choice. 

Share this post


Link to post

Good link. My desktop and iPad are compliant with all the specs and everything is "on" and allowed. I followed the links from that page and read the troubleshooting tutorials, but still no help.

 

What is Airserver, though? I don't have that on my Mac. The closest I have is Airport Utility, and that's allowed.

Share this post


Link to post

Hi 

 

I have the same issue running Eddie 2.12.4 on Mac OS Sierra 12.10.4,  Firewall Off. using Eddie Network Lock setting:

 

Mode: Automatic/ OS X - PF

Allow lan/ private

Allow ping

 

Still AirDrop does not work, deactivating Network Lock allows Discovery and ables to use the AirDrop.

 

I don't know what to do. Thanks!

Share this post


Link to post

Unfortunately, that doesn't address this problem, and it still hasn't been solved.

 

AirDrop works fine with Eddie (for most of us, I think) as long as network lock isn't engaged. Once you engage network lock, it breaks AirDrop again.

 

But network lock is an important security feature, and we're forced to choose either AirDrop or network lock. We can't use both at the same time.

Share this post


Link to post

It is shot in the dark here, You should try to add Bluetooth device to the firewall allowed list? What I read, AirDrop use Bluetooth (And WiFi, but it seem saying it chose bluetooth to sniff it around) to discover. I am not sure if it is only exclusive between iOS devices, but I tried to find information if Mac use bluetooth to find it, I couldn't find the information. I came to this thought because my PC is capable of using Bluetooth Network Connection. I imagine OSX use the same protocol as what PC do. It is possible Eddie is blocking that connection to Bluetooth? again, it is just shot in the dark here.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Security Check
    Play CAPTCHA Audio
    Refresh Image

×
×
  • Create New...